Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 7 of 7
  1. #1
    Join Date
    February 2012

    Solved Lost Serveradmin Rights [.."error id=2568"..]....[.."failed_permid=17308"..]

    Hey guys,

    the error message I receive is:
    "error id=2568 msg=insufficient\sclient\spermissions failed_permid=17308".

    So I lost control about the highest instance permissions, so I think there is no other way, than to try out fixing my Client Permissions (for ServerQuery, etc) via SQL Database Edit.

    Let's figure out my problem:
    1. No user in Guest Server Query - Group (normal?)
    Guest Server Query Group

    2. Three users in Admin Query Group
    Admin Server Query Group

    3. No user in SAdmin Template Group
    SAdmin Template Group

    4. "error id=2568 msg=insufficient\sclient\spermissions failed_permid=17308" after Server Query to delete me from SGID 2 (still got the red S)

    Vilden Server Groups

    but failed Server Query

    5. PuTTy Login on VS, listing up dir /home/teamspeak/teamspeak3-server_linux-x86
    PuTTy Login

    6. SQL dir
    SQL Directory of my Teamspeak VS

    7. Direct Query Login via Port 10011, Login with serveradmin and passwd, try like in Pic no. 4 => same Error Message
    Teamspeak Server Query via PuTTy

    8. Win SCP
    Win SCP

    9. Win SCP Login

    10. Successfully logged in

    11. Navigating to /home/teamspeak/... Navigating

    12. .../teamspeak3-server_linux-x86 Navigation complete

    13. Looking for MySQL Data
    MySQL Data

    14. Dunno ts3server.sqlitedb is the right one?

    15. SQLite Data Browser to open that .sqlitedb data

    16. Where do I find myself to edit my permissions? Or whatever?!
    Which Permission Table Content to change?

    And now hopefully you can help me out of this misery, because it's driving me crazy.
    Where/how can I fix up my Server Query Admin Rights?

    Best Regards, thanks
    Last edited by VILDEN; February 24th, 2012 at 01:57 PM.

  2. #2
    Join Date
    June 2008
    Wow this was a lot of informations

    I quote anwser and fixx, because this was answered many times. Please follow these steps.
    Quote Originally Posted by Jordi View Post
    PLEASE NOTE : Never add yourself in the Query Admin group. It's dangerous, you could destroy your permission system.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    February 2012
    Thanks, but I already tried it out.
    Whatever I am going to do, which command I am going to execute, it always says:
    "error id=2568 msg=insufficient\sclient\spermissions failed_permid=17304"
    Some different perm ids sometimes..
    Maybe the example works for the "b_virtualserver_create" permission, but obviously not for my "i_group_modify_power" permission.

    Hopefully there is another way to fix it (?).

    Thanks for your fast help!

    edit: uploaded the Permission Overview:

  4. #4
    Join Date
    January 2010
    Again: Never add yourself in the Query Admin group. It's dangerous, you could destroy your permission system.

    Quote Originally Posted by from your permissions
    Group Modify Power 75 0 0 75
    Needed Group Modify Power 100 0 0 100
    If you remove AdminServerQuery from this identity, will work.

  5. #5
    Join Date
    February 2012
    Umm, okay.
    And how shall I remove ASQ from myself without being able to use Server Query to remove it?

    Thanks so far

  6. #6
    Join Date
    January 2010
    You can use ServerQuery

    login serveradmin <password>
    use sid=<server_ID> or use port=<voice_port>
    servergroupdelclient sgid=2  cldbid=<db_ID_from_this_user>

  7. #7
    Join Date
    February 2012
    An error occurs as well..
    Now I am just going to reset my V-Server and set up a new Teamspeak VS. I guess it is an easy way to solve the problem, or even to avoid making that mistake with ASQ.

    Thanks for help!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: July 8th, 2015, 11:39 AM
  2. Can I use "whisper" to enable a "Public" and "Private" channel?
    By DadisAjax in forum General Questions
    Replies: 2
    Last Post: June 29th, 2012, 12:59 AM
  3. [No Bug] Updated to "Beta Channel" version, reverted, "lost" my contacts
    By Nev0r in forum Client Support
    Replies: 3
    Last Post: March 21st, 2011, 02:02 PM
  4. Replies: 0
    Last Post: December 23rd, 2009, 09:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts