Alright here's the situation : me and my friend wants to communicate on teamspeak. Theres absolutly no problem on my end whatsoever. My friend uses speakers and a desktop microphone, changing his setup isn't an option.

The problem is everytime someone talk, he echoes it all the time. We've tried the echo reduction/cancellation in the options but it didn't help. Adjusting the volumes dosn't help ether.

Here's the catch, it works flawlessly on skype. I hate skype and would much rather not have to use it. Is there a way to setup teamspeak so that he dosn't echo everything all the time?

Push to talk dosn't work because its still horrible everytime he talks.

Ty