Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 7 of 7
  1. #1
    Join Date
    December 2009
    Location
    Hungary
    Posts
    404

    Question Server (3.0.3) freezes / hangs on VPS Ubuntu 10.04 x64

    Hi,

    We run our server on a stable VPS host. There were no problems for months but in the last week our server stopped two times on two different days. MySQL, Apache...etc are running fine, only TS3 server process hangs up. After the freeze the process is still running, but it is not possible to connect via Telnet or Web interface and it is not possible to connect with TS3 client either. CPU running around 6%, the log is normal we didn't find any strange behavior except one: If I reboot the server the log contains the Server shutdown message properly:

    Received signal SIGTERM, shutting down.
    (however we need to issue "./ts3server_startscript.sh stop" command twice since the first one doesn't stop the server.)

    Can you help me how to solve this situation? Thank you.
    Last edited by Slater; April 4th, 2012 at 03:01 PM.

  2. #2
    Join Date
    June 2008
    Posts
    18,513
    This message indicates, that something from outside stops the server.
    Do you use serverprocessstop, to stop the server?
    Last edited by dante696; April 4th, 2012 at 02:56 PM. Reason: wrong command
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    December 2009
    Location
    Hungary
    Posts
    404
    I use only "./ts3server_startscript.sh start" and "./ts3server_startscript.sh stop" to start / stop the server itself. I don't use any instance commands since we have only 1 instance. I don't know what the hell is happening. The Linux server and VPS was not modified and only TS3 process stops responding. However if I reboot the VPS server the TS3 log contains the Server shutdown message properly (Received signal SIGTERM, shutting down.). It just doesn't accepty any connection anymore. How can I debug the server if it happens again? Thx.

  4. #4
    Join Date
    December 2009
    Location
    Hungary
    Posts
    404
    Unfortunately my server keeps freezing (or locking up who knows) on my VPS. Do you have any debug solution how to identify the source of the issue? Is it the TS3 freezes or firewall or server error or hacking attempt? Since I enabled Query logging, some strange activity are visible in the log:

    Last lines of log:

    2012-04-04 18:57:06.671056|WARNING |PktHandler | | detected incorrectly running system clock (>)
    2012-04-05 15:28:52.882514|ERROR |ParamParser | | Protocol mismatch, old client or old server?
    2012-04-06 11:14:03.354406|ERROR |ParamParser | | Protocol mismatch, old client or old server?
    2012-04-06 11:16:43.648408|ERROR |ParamParser | | Protocol mismatch, old client or old server?
    2012-04-06 18:53:49.145114|ERROR |ParamParser | | Protocol mismatch, old client or old server?
    2012-04-06 19:16:24.961779|WARNING |PktHandler | | detected incorrectly running system clock (>)
    2012-04-09 10:08:17.426583|INFO |ServerMain | | Received signal SIGTERM, shutting down.
    2012-04-09 10:08:27.457845|ERROR |VirtualSvrMgr | | stopserver for sid: 1 still waiting for shutdown
    2012-04-09 10:08:37.457028|ERROR |VirtualSvrMgr | | stopserver for sid: 1 still waiting for shutdown
    2012-04-09 10:08:47.486411|ERROR |VirtualSvrMgr | | stopserver for sid: 1 still waiting for shutdown
    2012-04-09 10:08:57.518217|ERROR |VirtualSvrMgr | | stopserver for sid: 1 still waiting for shutdown
    2012-04-09 10:09:07.533778|ERROR |VirtualSvrMgr | | stopserver for sid: 1 still waiting for shutdown
    2012-04-09 10:09:17.564454|ERROR |VirtualSvrMgr | | stopserver for sid: 1 still waiting for shutdown
    2012-04-09 10:09:27.596507|ERROR |VirtualSvrMgr | | stopserver for sid: 1 still waiting for shutdown
    2012-04-09 10:09:37.627047|ERROR |VirtualSvrMgr | | stopserver for sid: 1 still waiting for shutdown
    2012-04-09 10:09:47.657341|ERROR |VirtualSvrMgr | | stopserver for sid: 1 still waiting for shutdown
    2012-04-09 10:09:57.681577|ERROR |VirtualSvrMgr | | stopserver for sid: 1 still waiting for shutdown
    ---this is the last line of the log---
    2012-04-09 10:00:51.794095|INFO |VirtualServer | 1| client connected 'Minyur'(id:55791) from 89.134.13.2:52519
    2012-04-09 10:00:58.796026|INFO |VirtualServer | 1| query client disconnected 'Unknown from 67.227.138.164:48697'(id:97149) reason 'reasonmsg=disconnecting'
    2012-04-09 10:01:04.541176|INFO |VirtualServer | 1| client disconnected 'Deathknight'(id:88792) reason 'reasonmsg=leaving'
    2012-04-09 10:01:09.275883|INFO |VirtualServer | 1| client disconnected 'Timi'(id:55584) reason 'reasonmsg=connection lost'
    2012-04-09 10:01:15.134775|INFO |VirtualServer | 1| client disconnected 'Sephi'(id:98066) reason 'reasonmsg=leaving'
    2012-04-09 10:01:16.084334|INFO |VirtualServer | 1| query client connected 'Unknown from 67.227.138.164:51041'(id:97149)
    2012-04-09 10:01:16.399082|INFO |VirtualServer | 1| query client connected 'Unknown from 67.227.138.164:51072'(id:97149)
    2012-04-09 10:01:16.747959|INFO |VirtualServer | 1| query client connected 'Unknown from 67.227.138.164:51110'(id:97149)
    2012-04-09 10:01:17.238875|INFO |VirtualServer | 1| query client connected 'Unknown from 67.227.138.164:51146'(id:97149)

    2012-04-09 10:01:17.318947|INFO |VirtualServer | 1| query client disconnected 'Unknown from 67.227.138.164:51041'(id:97149) reason 'reasonmsg=connection lost'
    2012-04-09 10:01:17.353036|INFO |VirtualServer | 1| query client disconnected 'Unknown from 67.227.138.164:51110'(id:97149) reason 'reasonmsg=connection lost'
    2012-04-09 10:01:17.539077|INFO |VirtualServer | 1| query client disconnected 'Unknown from 67.227.138.164:51146'(id:97149) reason 'reasonmsg=connection lost'
    2012-04-09 10:01:19.992364|INFO |VirtualServer | 1| client connected 'Sephi'(id:98066) from 89.147.126.244:62980
    ---this is the last line of the log---
    Last edited by Slater; April 10th, 2012 at 08:22 AM.

  5. #5
    Join Date
    December 2009
    Location
    Hungary
    Posts
    404
    This problem still exist (upgraded to server 3.0.5). I've created two more servers (two separate processes 1 sqlite, 1 mySQL, with 2-2 users) to see if they crash too (server or network problem) or just the main server (505 users). The main server crashed again today but the other two servers were running fine. (!) It is very frustrating I think some database corruption causes the crash. Can you help me out? Do you have any advanced solution to log mySQL errors or other advice? Thank you.

    Last lines of logs:

    2012-05-15 18:21:20.913982|INFO |VirtualServer | 1| query client connected 'Unknown from 108.61.78.148:54963'(id:97149)
    2012-05-15 18:21:22.326848|INFO |VirtualServer | 1| query client disconnected 'GameTracker'(id:97149) reason 'reasonmsg=connection lost'
    2012-05-15 18:21:22.812018|INFO |VirtualServer | 1| query client connected 'Unknown from 108.61.78.148:52408'(id:97149)
    2012-05-15 18:21:23.008334|INFO |VirtualServer | 1| client disconnected 'LEVEStheKING#33'(id:85709) reason 'reasonmsg=leaving'
    2012-05-15 18:21:23.129293|INFO |VirtualServer | 1| query client connected 'Unknown from 85.214.124.238:38482'(id:97149)
    2012-05-15 18:21:23.931237|INFO |VirtualServer | 1| query client disconnected 'Unknown from 85.214.124.238:38482'(id:97149) reason 'reasonmsg=disconnecting'
    2012-05-04 16:49:28.774197|INFO |Query | | listening on 212.52.164.162:10011
    2012-05-04 21:27:12.530322|ERROR |ParamParser | | Protocol mismatch, old client or old server?
    2012-05-08 16:39:56.886068|WARNING |PktHandler | | detected incorrectly running system clock (>)
    2012-05-11 11:51:35.469639|WARNING |PktHandler | | detected incorrectly running system clock (>)
    2012-05-11 11:51:35.470068|WARNING |PktHandler | | detected incorrectly running system clock (>)
    2012-05-11 19:07:03.754692|ERROR |ParamParser | | Protocol mismatch, old client or old server?
    2012-05-11 19:08:54.195298|ERROR |ParamParser | | Protocol mismatch, old client or old server?
    2012-05-11 21:20:55.621646|ERROR |ParamParser | | Protocol mismatch, old client or old server?
    2012-05-15 18:29:18.211764|INFO |ServerMain | | Received signal SIGTERM, shutting down.
    2012-05-15 18:29:28.232842|ERROR |VirtualSvrMgr | | stopserver for sid: 1 still waiting for shutdown
    2012-05-15 18:29:38.264727|ERROR |VirtualSvrMgr | | stopserver for sid: 1 still waiting for shutdown
    After freezing "./ts3server_startscript.sh stop" does nothing it doesn't stop the server. I need to Ctrl+C and enter "./ts3server_startscript.sh stop" again to stop the server.
    Last edited by Slater; May 16th, 2012 at 09:12 AM.

  6. #6
    Join Date
    June 2008
    Posts
    18,513
    detected incorrectly running system clock (>)
    Maybe this is not logged, when you server does recieve this shutdown. This needs to get fixed first, to make sure that your clock is not the problem here.
    This can happen, when you clock on your mainboard is broken or when a script does change your system time or when a gameserver is running with scripts, that do change the framerate.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  7. #7
    Join Date
    December 2009
    Location
    Hungary
    Posts
    404
    My VPS has 2GB Ram but OOM killer kills TS3 process anyway. I had to limit Apache resources until I find out whats happening. Something (maybe php code) eats the memory. Mark this topic as solved. Ty.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Server hangs up at 'checking database integrity'
    By tjett in forum Linux / FreeBSD
    Replies: 0
    Last Post: July 16th, 2015, 12:29 AM
  2. Server hangs every other day (Ubuntu 12.04.1 LTS)
    By benbashy in forum Linux / FreeBSD
    Replies: 1
    Last Post: May 4th, 2013, 08:46 PM
  3. Replies: 9
    Last Post: July 21st, 2011, 06:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •