Forum

Results 1 to 10 of 10

Thread: Mysql problem

  1. #1
    Join Date
    April 2012
    Posts
    5

    Solved Mysql problem

    Hello,
    i tried to use a mysql database for my teamspeak server (running on my local pc for testing, but not the mysql-server) and i got a probem:
    Everytime i start my ts3 server, the log tells me:
    2012-04-08 12:57:32.667000|INFO |ServerLibPriv | | TeamSpeak 3 Server 3.0.3 (2012-03-17 06:12:11)
    2012-04-08 12:57:32.668000|INFO |DatabaseQuery | | dbPlugin name: MySQL plugin, (c)TeamSpeak Systems GmbH
    2012-04-08 12:57:32.668000|INFO |DatabaseQuery | | dbPlugin version: 1
    2012-04-08 12:57:33.674000|ERROR |DatabaseQuery | | mysql_real_connect() failed with error: Can't connect to MySQL server on '127.0.0.1' (10061)
    2012-04-08 12:57:33.674000|CRITICAL|ServerLibPriv | | Server() DatabaseError
    my configuration files are:
    ts3server.ini
    dbplugin=ts3db_mysql
    dbpluginparameter=ts3db_mysql.ini
    dbsqlcreatepath=create_mysql/
    and
    ts3db_mysql.ini
    host=a extern server
    port=3306
    username=xxx
    password=xxx
    database=xxx
    socket=
    The config files are in the ts3 folder
    Here my startup:
    C:\Users\xxx\Desktop\teamspeak3-server_win64\ts3server_win64.exe inifile=ts3server.ini
    It only works when i start a local mysql server without a root password
    I hope thats enough information.
    Please dont complain about my english, im german and not very well in english

  2. #2
    Join Date
    December 2009
    Location
    Texas
    Posts
    745
    It is trying to connect to a server at localhost which probably means one of two things.

    • Something is incorrect in ts3db_mysql.ini
    • ts3db_mysql.ini is in the wrong place and is not being read at all

  3. #3
    Join Date
    April 2012
    Posts
    5
    I thought the same thing an i tried many locations for the ts3db_mysql.ini nothing helped or put the absolut path to it, or take it in quotes. it never read the ts3db_mysql.ini

  4. #4
    Join Date
    December 2009
    Location
    Texas
    Posts
    745
    Have you searched the forums for this issue? I would but I have to go somewhere. I think I remember seeing issues like this before. Post back if you find something useful.

  5. #5
    Join Date
    April 2012
    Posts
    5
    Thank you for your tips but i ve searched the last hour and found similar problems and no solution has worked.
    Maybe its a bug ?

  6. #6
    Join Date
    December 2009
    Location
    Texas
    Posts
    745
    Found a parameter in a sample ts3server.ini file that yours is missing

    Code:
    dbsqlpath=sql/
    It may or may not help. Never actually done this before.

  7. #7
    Join Date
    April 2012
    Posts
    5
    Nope this doesn´t help
    I think the problem is that the teamspeak server doesn´t load the mysql configuration file, because it want to connect to the standart ip ( 127.0.0.1 and not to the given ip)

  8. #8
    Join Date
    December 2009
    Location
    Texas
    Posts
    745
    Try creating a shortcut then add this line after the path
    Code:
     dbplugin=ts3db_mysql dbsqlpath=sql/ dbsqlcreatepath=create_mysql/
    example:
    Code:
    C:\teamspeak3-server\ts3server.exe dbplugin=ts3db_mysql dbsqlpath=sql/ dbsqlcreatepath=create_mysql/
    Solution originally provided here: http://forum.teamspeak.com/showthrea...erver-to-MySql

  9. #9
    Join Date
    April 2012
    Posts
    5
    Nope, it still not works

    --- Merged ---

    I ve found the problem.
    The mysql config file has to begin with a "[config]"
    thanks for helping
    Last edited by florian_fr40; April 9th, 2012 at 08:10 AM.

  10. #10
    Join Date
    December 2009
    Location
    Texas
    Posts
    745
    glad you found a solution!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock'
    By Svenskunganka in forum Server Support
    Replies: 2
    Last Post: September 12th, 2013, 10:59 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •