Forum

Page 1 of 2 12 LastLast
Results 1 to 15 of 18
  1. #1
    Join Date
    December 2011
    Posts
    25

    Users are not keeping permissions

    I created 2 groups for my users to be in. The first one works great and users are always in that server group. The Channel group though is not right. Users will be given Operator status and the settings will keep as long as they are on the server. Once they leave and come back it seems that they get auto demoted to guest.

    I add them back and the next day, same thing.

    any ideas?

  2. #2
    Join Date
    May 2010
    Posts
    6,310
    Hello

    Check the b_group_is_permanent permission.

  3. #3
    Join Date
    December 2011
    Posts
    25
    Can you tell me a little more about that? Where is it?

  4. #4
    Join Date
    May 2010
    Posts
    6,310
    First you have to use the permission advanced mode, read this : http://forum.teamspeak.com/showthrea...tem-is-missing

    So, if you want a user to be still in a group (server or channel) after a disconnection you have to activate this permission.

  5. #5
    Join Date
    December 2011
    Posts
    25
    Thank you, I have activated advanced mode and set the permissions on the users. I'll check tomorrow to see if it sticks!

    --- Merged ---

    My users did not end up keeping the permissions that were set. They were back on today without them.

    Any further or more ideas?
    Last edited by florian_fr40; April 22nd, 2012 at 08:47 AM.

  6. #6
    Join Date
    January 2010
    Location
    Germany
    Posts
    2,029
    Are they using the same Unique ID?
    If you want you can send me a Private Message with your Server Info so I can take a look.

  7. #7
    Join Date
    December 2011
    Posts
    25
    Yes, they are using the same UID's as when the perms get applied.

    PM sent!

  8. #8
    Join Date
    December 2011
    Posts
    25
    Users are still not keeping permissions. Any ideas?

  9. #9
    Join Date
    June 2008
    Posts
    18,032
    I followed this thread since it was created, but it seems you did not check, that b_group_is_permanent is set for that server or channel group.

    Please give use feedback about it and make sure , that this group is not set as default group!
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  10. #10
    Join Date
    December 2011
    Posts
    25
    I will check that, thank you. Where is it located?

  11. #11
    Join Date
    June 2008
    Posts
    18,032
    This has been explained in post #4 of this thread
    http://forum.teamspeak.com/showthrea...734#post312734
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  12. #12
    Join Date
    December 2011
    Posts
    25
    I looked in the thread and didn't see any help. Maybe I suck at looking, but I did answer the advanced permissions thing.

    Thank you, I have activated advanced mode and set the permissions on the users. I'll check tomorrow to see if it sticks!

    If that is not the same thing, then I need a little more help please.

    Upon checking this path; Permissions, Channel Groups, Operator , Group, Group is permanent is checked. Does that help?

  13. #13
    Join Date
    June 2008
    Posts
    18,032
    By default all permanent Group names are blue and temporary are black.

    and yes a detailed information was given in post #4 and post #2
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  14. #14
    Join Date
    December 2011
    Posts
    25
    So I have confirmed that the b group is permanent and the issue still exists. I have copied the group (operator) and named it a custom name. I have also made sure that it is perm. I will check tomorrow to see if it is still there.

  15. #15
    Join Date
    December 2011
    Posts
    25
    Nope, they did not stick.

    I even created a new group and assigned the users to it. They still drop perms. But I have noticed, its after moving from channel to channel, but its unpredictable.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] Remove users permissions
    By nbtc971 in forum Permission System
    Replies: 15
    Last Post: April 12th, 2015, 06:29 PM
  2. [Resolved] Keeping users from leaving a Group
    By Arsimael in forum Permission System
    Replies: 2
    Last Post: July 18th, 2012, 09:15 PM
  3. Users and permissions
    By pdean44 in forum Permission System
    Replies: 5
    Last Post: January 29th, 2010, 04:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •