Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 3 of 3
  1. #1
    Join Date
    April 2012
    Boston, MA

    Solved Custom group/channel icons not showing for fresh TS installs


    I've searched around the forums and haven't been able to find a similar issue or fix.

    I'm having an issue where users who have recently re-installed Windows and have a fresh TeamSpeak installation are unable to see the custom icons set for user groups and certain channels.

    I'm running TeamSpeak Server 3.0.3 on Linux. I just upgraded from 3.0.2 hoping it would solve the issues, however it hasn't.

    Other users are using TeamSpeak Client versions 3.0.5 and 3.0.6 without issue.

    I have a laptop running 3.0.5 and it displays all the icons properly, however on my desktop fresh win 7 ultimate install and TeamSpeak 3.0.5, I cannot view the majority of the icons, only 4 channel icons display, and no user group icons.

    All necessary ports have been opened, users have tested both 32-bit and 64-bit version installs of the TeamSpeak client.

    Any help would be greatly appreciated. You can join the server here: or alternatively.

    - Anti

  2. #2
    Join Date
    May 2010

    Quote Originally Posted by AntiHero
    Other users are using TeamSpeak Client versions 3.0.5 and 3.0.6 without issue.
    Sound likes these specific users has to check their windows firewall (specifically the file transfer port - by default 30033)

  3. #3
    Join Date
    April 2012
    Boston, MA
    Hello florian_fr40, Thank you very much for your response. it seems no one else wants to touch this topic.

    After many hours of poking the server with a sharp stick I discovered the issue. The TS server was migrated from one host to another, and when the server was started on the new host it parsed the database and truncated some of the tables. The tables it truncated ended up being the ones that tell the server what icon belongs with what group/channel. So users who already had the icons loaded into their TeamSpeak client cache had no issues, but users without the cache (new windows/teamspeak installs) were unable to see the icons.

    Administrative users were unable to view any icons when trying to add icons to channels/groups due to this issue.

    I shut down the TeamSpeak server and then from the teamspeak installation directory I browsed to /files/virtualserver_1/internal/icons and ran the following command: rm -f *
    effectively removing all files from the directory, I then removed all avatars from the internal directory as well.

    I then started the server back up, cleared my teamspeak client cache, and added the icons back to their respective groups/channels.

    Problem solved. All users must clear their client caches, however the changes worked wonderfully.

    I hope perhaps someone with a similar issue will find this helpful. A fresh TeamSpeak server installation is always preferable, but sometimes with complex user groups it isn't the best (time friendly) solution.


    - Anti

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Custom Server Group Cannot Assign Channel Icons
    By mrhappypenguin in forum Permission System
    Replies: 0
    Last Post: July 26th, 2015, 12:25 AM
  2. Server Group Icons Not Showing
    By Newkirk in forum Windows
    Replies: 11
    Last Post: May 28th, 2013, 04:06 PM
  3. Custom Channel Group Icons
    By WNxAwp666 in forum Server Support
    Replies: 1
    Last Post: October 19th, 2011, 07:26 AM
  4. Server group icons not showing for others
    By nbtc971 in forum General Questions
    Replies: 5
    Last Post: August 25th, 2011, 03:25 PM
  5. Custom group icons dissapear after last update: how to fix
    By srinidhalaya in forum Skins / Icon & Sound Packs
    Replies: 5
    Last Post: February 11th, 2010, 07:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts