Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 4 of 4
  1. #1
    Join Date
    April 2012
    São Paulo

    Problem with licensekey.dat

    Firstly, I'd like to say that I have read some articles around this, but none of them could help me...
    My problem is: everytime I insert the licensekey.dat file into the folder and start the ts3server script, no one can join the server. The weird thing here is that it shows no error message...
    ALL the files on the folder are owned by the same user account, including the license file; It shows no error message... it says that the server has started normally. BUT, nobody, including me, can join the server...
    But if I remove or just move this file outta the folder and restart the server, it runs perfect! The problem is: I get only 32 slots. Yesterday, the server got full, and some people couldnt join, and they were complaining.

    I downloaded the files from my VPS and extracted them at home; I started the server without the licensekey file... it ran perfectly, without a problem... So I moved the license file to the server folder and started the server again. IT RAN PERFECT TOO! So that means the problem is with my VPS, right?

    And another thing: I know starting the scripts with the root user is not the right thing to do, but if I create another user and install the files into the new user's folder, no one can join the server either. Dunno why... but the client wont find the server files if they are not located in the public_html folder (or any folder outside the main user folders);

    Could any SSH expert help me uot with this? Either install the server files on another user's folder (and get this working) or help me out the slots problem?

    In the other threads I saw ppl asking about the owner permissions... I've already checked ls -al, and it shows that all the files are ownder by thesourc (the main user account, using public_html). I'm starting the files with root cause I cant access SSH with thesourc password... I tried using wget in SSH with root, so the files would all be owned by root... BUUUUUT, after the licensekey file is inserted, I get the same freakin' problem. Like I said before, if I create another user, the client wont be able to find the server;

    I've created these users: ts, ts3, ts3server, teamspeak and server... I cant get to access the server if the files are located at these users' folders.

    Looks like I got more than one problem, huh? ROFL

    I'm a little confused here cause if I download the files start the server with my computer, it runs perfectly... even with the licensekey and 512 slots...

    If anyone could help me out with this... I'd appreciate it;

  2. #2
    Join Date
    December 2009
    please post server log

  3. #3
    Join Date
    April 2012
    São Paulo
    God dammit, what the heck? The log folder is empty... why the heck is it empty?

    Let me ask another thing: if I make the server work perfectly, but a hole new server, clean (I mean, no rooms, no groups), can I import the database from the old one, and get all the groups, passwords and channels back? I tried exporting the libts3db files (both of them), but when I start the server with these new files, I get an error message saying that the database is damaged...

    EDIT: I got access to thesourc from SSH, hell yeah. But now, I cant 'kill' the server... I stop the script, but the server keeps on running... I even tried to stop from the query, but it says that the command was not found. When checking the server's status it says 'server seem to have died'... WDF? ROFL
    Last edited by thaalesalves; May 5th, 2012 at 09:35 PM.

  4. #4
    Join Date
    April 2012
    São Paulo
    I'm not in need of help anymore. I fixed all the problems.

    You guys can now close this thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. licensekey.dat problem
    By vakotm in forum Windows
    Replies: 4
    Last Post: May 9th, 2013, 05:23 PM
  2. Licensekey problem
    By teamspeak user71 in forum Server Support
    Replies: 1
    Last Post: October 5th, 2012, 04:01 PM
  3. [Resolved] Licensekey.dat Problem
    By gugaa in forum Windows
    Replies: 3
    Last Post: October 20th, 2011, 04:50 PM
  4. And another problem with licensekey.dat -.-
    By netshadow in forum Linux / FreeBSD
    Replies: 5
    Last Post: October 26th, 2010, 10:58 PM
  5. Problem with licensekey.dat
    By VoidShadow in forum Linux / FreeBSD
    Replies: 11
    Last Post: September 7th, 2010, 01:20 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts