Forum

Page 1 of 7 123 ... LastLast
Results 1 to 15 of 109

Hybrid View

  1. #1
    Join Date
    May 2012
    Posts
    4

    Lost my Admin / Don't have key. How can i create new privilege key (Token)

    Hi guys,

    I have the following problem: I recently reinstalled my OS as I got a new HD for my computer. However I forgot to save my Teamspeak user profile. Now I don't have admin rights on my server. My question is how to create a new token to verify my user account. Or can I just add my user id to the admin group somehow?

    I'm running a TS3 server on a Linux machine and have normal SSH access.

  2. #2
    Join Date
    January 2010
    Location
    Germany
    Posts
    2,029
    1. Connect to your Server using the regular TS3 Client.
    2. Goto Permissions -> Servergroups.
    3. Write down or memorize the Number in Parentheses behind the Server Group Name. (eg. "Server Admin (6)" => 6)
    4. Open a connection to the Serverquery using Putty or similar.
    5. Do the following in said Query Session:
      Code:
      login serveradmin <password>
      use port=<The port you used to connect using the TS3 Client>
      privilegekeyadd tokentype=0 tokenid1=<The Number you memorized in step 3> tokenid2=0
      ### Above Command will output a new Privilege Key! Copy it!
      quit
    6. Switch back to the TS3 Client and use the generated Privilege Key.
    7. Backup your TS3 Identity to some safe place!
    8. Thank me
    9. Include me in your Prayers
    10. Have fun.
    Last edited by dante696; July 5th, 2018 at 07:53 AM. Reason: replaced tokenadd with privilegekeyadd

  3. #3
    Join Date
    May 2012
    Posts
    4
    Thank you for your quick post! Unfortunately, I'm getting this error message:

    No utmp entry. You must exec "login" from the lowest level "sh"

    Also which password do you mean for serveradmin? One for teamspeak or the server password? Do I need root rights for that?

  4. #4
    Join Date
    January 2010
    Location
    Catalunya
    Posts
    2,350
    You get the password serveradmin when installing the server.

  5. #5
    Join Date
    May 2012
    Posts
    4
    Ah, NOW I got it!^^ The problem was, that I connected to the SERVER via SSH, not the TS3 query via Telnet. Also when I tried first, I used the standard port 23 in Putty, not 10011 like in this guide:
    http://forum.teamspeak.com/showthrea...859#post201859

    Once in I used the login password (saved that fortunately), I used your commands step by step to create a new token. Now my admin rights are back - thank you!

  6. #6
    Join Date
    January 2010
    Location
    Secret Base in Arctic Region
    Posts
    1,671
    If you used the command "servergroupaddclient sgid=6 cldbid=<your_id>" youd have your SA instantly back, no need for a token (Assuming "6" is the id of the SA group)

  7. #7
    Join Date
    July 2006
    Location
    business
    Posts
    7
    Quote Originally Posted by SilentStorm View Post
    1. Connect to your Server using the regular TS3 Client.
    2. Goto Permissions -> Servergroups.
    3. Write down or memorize the Number in Parentheses behind the Server Group Name. (eg. "Server Admin (6)" => 6)
    4. Open a connection to the Serverquery using Putty or similar.
    5. Do the following in said Query Session:
      Code:
      login serveradmin <password>
      use port=<The port you used to connect using the TS3 Client>
      tokenadd tokentype=0 tokenid1=<The Number you memorized in step 3> tokenid2=0
      ### Above Command will output a new Privilege Key! Copy it!
      quit
    6. Switch back to the TS3 Client and use the generated Privilege Key.
    7. Backup your TS3 Identity to some safe place!
    8. Thank me
    9. Include me in your Prayers
    10. Have fun.
    I just had the exact same problem as the thread starter and that solution worked perfectly. Thank you very much!

  8. #8
    Join Date
    December 2015
    Posts
    1
    Quote Originally Posted by SilentStorm View Post
    1. Connect to your Server using the regular TS3 Client.
    2. Goto Permissions -> Servergroups.
    3. Write down or memorize the Number in Parentheses behind the Server Group Name. (eg. "Server Admin (6)" => 6)
    4. Open a connection to the Serverquery using Putty or similar.
    5. Do the following in said Query Session:
      Code:
      login serveradmin <password>
      use port=<The port you used to connect using the TS3 Client>
      tokenadd tokentype=0 tokenid1=<The Number you memorized in step 3> tokenid2=0
      ### Above Command will output a new Privilege Key! Copy it!
      quit
    6. Switch back to the TS3 Client and use the generated Privilege Key.
    7. Backup your TS3 Identity to some safe place!
    8. Thank me
    9. Include me in your Prayers
    10. Have fun.
    Thank you for the help.
    My problem is that i don't have telnet on my server that i install ts3 server for security.
    Is it posible through ssh and how?

  9. #9
    Join Date
    June 2008
    Posts
    18,273
    No, we use telnet for the Query not SSH.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  10. #10
    Join Date
    May 2016
    Posts
    1
    Quote Originally Posted by SilentStorm View Post
    1. Connect to your Server using the regular TS3 Client.
    2. Goto Permissions -> Servergroups.
    3. Write down or memorize the Number in Parentheses behind the Server Group Name. (eg. "Server Admin (6)" => 6)
    4. Open a connection to the Serverquery using Putty or similar.
    5. Do the following in said Query Session:
      Code:
      login serveradmin <password>
      use port=<The port you used to connect using the TS3 Client>
      tokenadd tokentype=0 tokenid1=<The Number you memorized in step 3> tokenid2=0
      ### Above Command will output a new Privilege Key! Copy it!
      quit
    6. Switch back to the TS3 Client and use the generated Privilege Key.
    7. Backup your TS3 Identity to some safe place!
    8. Thank me
    9. Include me in your Prayers
    10. Have fun.
    Dear All,

    I run TS3 server on my NAS.
    I reinstalled my computer so I lost my admin rights.

    The instruction is clear for me. I could use Putty with Query port, but I do not know what is the login USERNAME and PASSWORD.
    When I have created my server I did not give password !

    Now I tried with different "username + password" combinations, but I got this error message back:

    login admin password
    error id=520 msg=invalid\sloginname\sor\spassword


    - I tried with NAS username like "admin" and its password: does not work.
    - I tried with TS3 nickname (what had token key) like "Barack_palinka": does not work.

    Where can I find the username and password for "login" command?

  11. #11
    Join Date
    April 2016
    Posts
    24
    Quote Originally Posted by SilentStorm View Post
    1. Connect to your Server using the regular TS3 Client.
    2. Goto Permissions -> Servergroups.
    3. Write down or memorize the Number in Parentheses behind the Server Group Name. (eg. "Server Admin (6)" => 6)
    4. Open a connection to the Serverquery using Putty or similar.
    5. Do the following in said Query Session:
      Code:
      login serveradmin <password>
      use port=<The port you used to connect using the TS3 Client>
      tokenadd tokentype=0 tokenid1=<The Number you memorized in step 3> tokenid2=0
      ### Above Command will output a new Privilege Key! Copy it!
      quit
    6. Switch back to the TS3 Client and use the generated Privilege Key.
    7. Backup your TS3 Identity to some safe place!
    8. Thank me
    9. Include me in your Prayers
    10. Have fun.

    If you haven't got admin permissions how you get a ServerQuery login and password to login in Query Session? Guest users have disabled this entry in Tools menu.

  12. #12
    Join Date
    September 2012
    Posts
    6,080
    Quote Originally Posted by WyRe90 View Post
    If you haven't got admin permissions how you get a ServerQuery login and password to login in Query Session? Guest users have disabled this entry in Tools menu.
    See here: http://forum.teamspeak.com/threads/48255
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  13. #13
    Join Date
    April 2016
    Posts
    24
    Quote Originally Posted by Chris View Post

    I'm not using ts3server_startscript.sh to start my server, I've installed this package from users repository https://aur.archlinux.org/packages/teamspeak3-server you can see packaging script in here https://aur.archlinux.org/cgit/aur.g...mspeak3-server

    that means I use systemd to start/stop my server and ts3server binary.

    Anyway ... that info https://support.teamspeakusa.com/ind...-query-account was helpful thankyou.
    Last edited by WyRe90; March 16th, 2017 at 02:55 PM.

  14. #14
    Join Date
    August 2012
    Posts
    1

    Exclamation Privilege Key

    Hello. I'm new to this install TS on Linux thing but i managed to do it and it's up and running.

    For now the Privilege key is not working and i deleted the token_guide.txt and restarted server for a new one and it wont appear. So how do i get a new key?

    Thanks!

    Thread was moved
    Last edited by dante696; August 14th, 2012 at 10:45 AM.

  15. #15
    Join Date
    January 2010
    Location
    Germany
    Posts
    2,029
    as the filename suggests that file just contains guides / documentation about the Privilege key Stuff...
    You will find your existing Privilege Key in the first logfile created. Make sure to copy & Paste it as it is way too long and difficult to type to be certain not to make any errors. Also note that Privilege Keys ARE case sensitive. If the key really doesn't work it has already been used and you'll find information about that in the logs as well.
    If you are an admin already you can just recreate a new one from within the client, otherwise you should Read this Post

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Lost Admin and deleted mail with privilege key
    By captain crazzy in forum Permission System
    Replies: 1
    Last Post: March 23rd, 2016, 10:19 AM
  2. lost all server admin privilege
    By Yankis in forum Permission System
    Replies: 1
    Last Post: August 3rd, 2015, 08:50 AM
  3. becoming an admin AGAIN. LOST MY PRIVILEGE KEY
    By singularity in forum Linux / FreeBSD
    Replies: 1
    Last Post: March 13th, 2013, 10:19 AM
  4. [Resolved] Lost admin privilege
    By Alvega in forum Server Support
    Replies: 3
    Last Post: September 11th, 2011, 09:44 PM
  5. Lost Server Admin / Need new privilege key/Token
    By Cockatiel in forum Server Support
    Replies: 3
    Last Post: July 11th, 2011, 03:05 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •