Forum

Page 1 of 2 12 LastLast
Results 1 to 15 of 16
  1. #1
    Join Date
    November 2010
    Location
    Germany
    Posts
    1

    The "unable to load database plugin library "libts3db_mysql.so"" Squeeze Way??

    Hi Guy´s

    i have a little question:

    I know there is need of the libmysqlclient.so.15 to run TS3 Server on
    a Linux machine.

    But under Debian Squeeze there is no libmysqlclient.so.15.

    You can´t get them with apt* there is no packet with this file.

    What is the right way for Future for TS3 under Squeeze ??

    Thanks a lot

    Bye

    Lex

  2. #2
    Join Date
    January 2010
    Location
    The Netherlands
    Posts
    8

    Lightbulb Fix libmysqlclient on Debian Squeeze

    It's quite easy to fix this problem, once you know the solution.
    All you have to do is download the package 'libmysqlclient15off' from packages.debian.org and install it.

    You can do so with the following commands:
    Code:
    wget http://ftp.nl.debian.org/debian/pool/main/m/mysql-dfsg-5.0/libmysqlclient15off_5.0.51a-24+lenny5_i386.deb
    sudo dpkg -i libmysqlclient15off_5.0.51a-24+lenny5_i386.deb
    After doing this, you can start your TeamSpeak3-server.

  3. #3
    Join Date
    June 2008
    Posts
    17,923
    http://www.q-leap.de:3333/debmirror/...enny5_i386.deb
    The fle has been deleted from all debian ftp's :-/
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  4. #4
    Join Date
    March 2012
    Posts
    18
    Quote Originally Posted by dante696 View Post
    http://www.q-leap.de:3333/debmirror/...enny5_i386.deb
    The fle has been deleted from all debian ftp's :-/
    Go here http://packages.debian.org/ru/lenny/libmysqlclient15off

    And select your arch and then a mirror

  5. #5
    Join Date
    May 2012
    Posts
    1

    Question Old MySQL Client Lib

    Hi,

    I try to use TS 3.0.3 Server with Mysql.
    After writing the two config files I get an error while starting:
    Code:
    2012-05-24 19:12:14.125462|CRITICAL|DatabaseQuery |   | unable to load database plugin library "libts3db_mysql.so", halting!
    After some time I find the problem.
    TS3 use the libmysqlclient15, but it is not longer in the repositorys from debian (and also some ubuntu versions).
    I find an old package here http://packages.ubuntu.com/hardy/amd...15off/download .
    Is it posible to upgrade the libts3db_mysql.so to libmysqlclient16 ?

    Greetings Barbers
    (I hope my english isn't as bad as i think)

  6. #6
    Join Date
    July 2002
    Location
    Germany
    Posts
    2,192
    Hi,

    we are actually working on a system that will allow you to use newer libmysqlclient libraries out of the box, without breaking compatibility for those old machines that still need libmysqlclient15. Have a close look at the next server release.

    Edit: This has been feature has been postponed due to some technical issues, it will not be in the next server release.
    Last edited by Peter; May 25th, 2012 at 10:24 AM.

  7. #7
    Join Date
    March 2011
    Location
    Worldwide
    Posts
    6
    Hi Barbers,

    I'd like to refer you to a solution I posted here some time ago, this will help:
    http://bit.ly/JEA88a

  8. #8
    Join Date
    July 2009
    Posts
    38
    Thanks for adding the .so/.deb package Peter .

    But in wich folder must I put this file and what must be the chmod's?
    Or can I upload it in e. g. /olddebs/lenny which I createt on my vServer in /root?

  9. #9
    Join Date
    June 2008
    Posts
    17,923
    "/usr/lib/libmysqlclient.so.15" This is the path under Ubuntu.

    Maybe these commands help you to copy the file and to reconfigure your system for the new libary file.
    Code:
    sudo cp libmysqlclient.so.15 /usr/lib/
    sudo ldconfig
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  10. #10
    Join Date
    August 2010
    Location
    Germany
    Posts
    8
    You guys should really fix this stuff QUICKLY. Right now people who restarted their teamspeak servers are fucked unless they are willing to downgrade to an older MySQL version which is usually NOT an opinion on a production system.

  11. #11
    Join Date
    September 2010
    Location
    Luxembourg
    Posts
    7

    Debian Squeeze "unable to load database plugin library "libts3db_mysql.so", halting!"

    Hi there,

    at the moment i am freaking out because i want to start my TS3 server...

    What I did:

    Last weekend, I set up a new Debian server (old one was Debian lenny) and i installed a Debian Squeeze.

    On my old server the TS3 server was running with mysql database without problems. Before setting up the new server i made a backup from my old TS3 installation.

    Now i want to start the TS3 server and i get the following message:

    Code:
    2012-06-19 19:15:08.893359|CRITICAL|DatabaseQuery |   | unable to load database plugin library "libts3db_mysql.so", halting!
    I already searched the forums and fount some "maybe solutions"... getting and installing the libmysqlclient15off, starting minimal startscript first etc...

    but nothing worked..

    my standart start command was the following:

    Code:
    ./ts3server_startscript.sh start
    in the old startscript from Debian lenny i used these parameters in line 5:

    Code:
    COMMANDLINE_PARAMETERS="${2} inifile=ts3server.ini dbplugin=ts3db_mysql dbpluginparameter=ts3db_mysql.ini dbsqlpath=sql/ dbsqlcreatepath=create_mysql/" #add any command line parameters you want to pass here
    i triede this also in the new installation and this:
    Code:
    COMMANDLINE_PARAMETERS="inifile=ts3server.ini"
    however the first script worked fine all the time...


    when i run
    Code:
    ldd libts3db_mysql.so
    i get
    Code:
    not a dynamic executable
    my ts3server.ini file:

    Code:
    machine_id=
    default_voice_port=9987
    voice_ip=0.0.0.0
    licensepath=
    filetransfer_port=30033
    filetransfer_ip=0.0.0.0
    query_port=10011
    query_ip=0.0.0.0
    query_ip_whitelist=query_ip_whitelist.txt
    query_ip_blacklist=query_ip_blacklist.txt
    dbplugin=ts3db_mysql
    dbpluginparameter=ts3db_mysql/
    dbsqlpath=sql/
    dbsqlcreatepath=create_mysql/
    dblogkeepdays=90
    logpath=logs/
    logquerycommands=0
    dbclientkeepdays=30
    my ts3db_mysql.ini:

    Code:
    [config]
    host=localhost
    port=3306
    username=ts3db-user
    password=password
    database=teamspeak3
    socket=
    How can i solve the problem with "unable to load database plugin library "libts3db_mysql.so", halting!"
    please help me

    Thx in advance and sorry for the bad english...


    Threads from 11 - 14 have been merged into this thread.
    Last edited by dante696; June 20th, 2012 at 11:17 AM.

  12. #12
    Join Date
    January 2010
    Location
    Germany
    Posts
    2,029
    TS3 Server unfortunately still requires an outdated Version of libmysqlclient (specifically the .15 one) which is not around anymore in (any?) newer Version/Distribution (that ought to mean something imho).

    Anyway in order to get the Server running with a MySQL Database you need to get your hands on a copy of libmysqlclient.so.15, seems it aint available in the official Squeeze Repos, but maybe this Post can help you.


    Threads from 11 - 14 have been merged into this thread.
    Last edited by dante696; June 20th, 2012 at 11:17 AM.

  13. #13
    Join Date
    September 2010
    Location
    Luxembourg
    Posts
    7
    Thank you for your answer, i'll test this debian source today...
    Yesterday i used anoter one, maybe this time it works.

    I'll let you know if i tested it.

    Greetz
    Smorod


    Threads from 11 - 14 have been merged into this thread.
    Last edited by dante696; June 20th, 2012 at 11:18 AM.

  14. #14
    Join Date
    September 2010
    Location
    Luxembourg
    Posts
    7
    Hi, i tried the how to you linked, but when i run:

    Code:
    aptitude update && aptitude install libmysqlclient15off
    Code:
    Hit http://debian.intergenia.de squeeze Release.gpg
    Ign http://debian.intergenia.de/debian/ squeeze/contrib Translation-en
    Ign http://debian.intergenia.de/debian/ squeeze/main Translation-en
    Ign http://debian.intergenia.de/debian/ squeeze/non-free Translation-en
    Hit http://debian.intergenia.de squeeze/updates Release.gpg
    Ign http://debian.intergenia.de/debian-security/ squeeze/updates/contrib Translation-en
    Ign http://debian.intergenia.de/debian-security/ squeeze/updates/main Translation-en
    Ign http://debian.intergenia.de/debian-security/ squeeze/updates/non-free Translation-en
    Hit http://debian.intergenia.de squeeze Release
    Hit http://debian.intergenia.de squeeze/updates Release
    Hit http://debian.intergenia.de squeeze/main Sources
    Hit http://debian.intergenia.de squeeze/contrib Sources
    Hit http://archive.debian.org lenny Release.gpg
    Ign http://archive.debian.org/debian/ lenny/contrib Translation-en
    Ign http://archive.debian.org/debian/ lenny/main Translation-en
    Hit http://debian.intergenia.de squeeze/non-free Sources
    Hit http://debian.intergenia.de squeeze/main amd64 Packages
    Hit http://debian.intergenia.de squeeze/contrib amd64 Packages
    Hit http://debian.intergenia.de squeeze/non-free amd64 Packages
    Hit http://debian.intergenia.de squeeze/updates/main Sources
    Hit http://debian.intergenia.de squeeze/updates/contrib Sources
    Hit http://debian.intergenia.de squeeze/updates/non-free Sources
    Hit http://debian.intergenia.de squeeze/updates/main amd64 Packages
    Hit http://debian.intergenia.de squeeze/updates/contrib amd64 Packages
    Hit http://debian.intergenia.de squeeze/updates/non-free amd64 Packages
    Ign http://archive.debian.org/debian/ lenny/non-free Translation-en
    Hit http://archive.debian.org lenny/volatile Release.gpg
    Ign http://archive.debian.org/debian-volatile/ lenny/volatile/contrib Translation-en
    Ign http://archive.debian.org/debian-volatile/ lenny/volatile/main Translation-en
    Ign http://archive.debian.org/debian-volatile/ lenny/volatile/non-free Translation-en
    Get:1 http://archive.debian.org lenny-backports Release.gpg [836 B]
    Ign http://archive.debian.org/debian-backports/ lenny-backports/contrib Translation-en
    Ign http://archive.debian.org/debian-backports/ lenny-backports/main Translation-en
    Ign http://archive.debian.org/debian-backports/ lenny-backports/non-free Translation-en
    Hit http://archive.debian.org lenny Release
    Hit http://archive.debian.org lenny/volatile Release
    Hit http://archive.debian.org lenny-backports Release
    E: Release file expired, ignoring http://archive.debian.org/debian-backports/dists/lenny-backports/Release (invalid since 80d 18h 55min 5s)
    Any ideas?


    Threads from 11 - 14 have been merged into this thread.
    Last edited by dante696; June 20th, 2012 at 11:18 AM.

  15. #15
    Join Date
    June 2008
    Posts
    17,923
    Quote Originally Posted by ThiefMaster View Post
    You guys should really fix this stuff QUICKLY. Right now people who restarted their teamspeak servers are fucked unless they are willing to downgrade to an older MySQL version which is usually NOT an opinion on a production system.
    This has nothing with a restart to do. This is the only way to use MYSql on FreeBSD / linux since beta 1 was released.


    Threads from 11 - 14 have been merged into this thread.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: October 17th, 2014, 02:33 AM
  2. Replies: 1
    Last Post: November 11th, 2013, 05:04 PM
  3. [Resolved] unable to load database plugin library "libts3db_mysql.so", halting!
    By PoL4K in forum Linux / FreeBSD
    Replies: 10
    Last Post: March 15th, 2012, 06:29 PM
  4. Replies: 4
    Last Post: January 26th, 2012, 07:26 AM
  5. Replies: 1
    Last Post: November 22nd, 2010, 04:25 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •