Forum

Results 1 to 11 of 11
  1. #1
    Join Date
    June 2012
    Posts
    3

    Teamspeak 3 Causing Lag spikes

    Hello guys, i recently went back to wow to play with my friend in his guild, as it does raid it has a teamspeak chat dedicated to the guild, problem is, whatever game im on Lol/diablo/wow and i have teamspeak up at the same time it causing lag spikes, and its fine when i turn it off.

    I have checked it time in and time out and it HAS to be a problem related with teamspeak or the server.
    I really need someone to help me out because i've been looking everywhere for people with similar problems and i cannot find it, and when i say this is a problem it is.

    I cant play any games whilst in teamspeak its unplayable, and i need to be in teamspeak for raids.

    ANY help regarding this situation would be nice i just need it fixed.

    ( if its any help i realised my packet loss can go up to 10% sometimes when someone speaks ).

  2. #2
    Join Date
    January 2010
    Location
    Germany
    Posts
    2,029
    Quote Originally Posted by Patchey View Post
    ( if its any help i realised my packet loss can go up to 10% sometimes when someone speaks ).
    Indicates your Internet is too slow to process the Game Data and the TS3 Voice Data at the same time. Either that or your CPU is too busy with the game and cannot process the Packets for TS3 fast enough.

  3. #3
    Join Date
    June 2012
    Posts
    3
    Thing is i've had the same internet and havnt had a problem with TS3 until now, and regarding my CPU, i normally have several game open/skype open etc without problems, i tried teamspeak with just wow and teamspeak itself, no skype or anything else and the problem remained there.

  4. #4
    Join Date
    June 2012
    Posts
    3
    Can i further express that my lag spikes are more than just lag spikes sometimes it even DC's me from the games, so its quite bad.

  5. #5
    Join Date
    January 2010
    Location
    El Prat de Llobregat (Barcelona, Spain)
    Posts
    2,698
    Try deactivating 'Echo cancelation' in the TS3:
    Settings --> Options -> Capture --> Uncheck 'Echo cancelation' and Apply

  6. #6
    Join Date
    February 2014
    Posts
    1
    I have the exact same problem, just not with WoW, but with LoL. It used to be fine, but few days ago it screwed up. Pls help me!!!

    EDIT: I can see that this post has over 9k views, but yet no solution had been brought to it. So does anyone even care about client support here?
    Last edited by rachero; February 28th, 2014 at 07:58 PM.

  7. #7
    Join Date
    October 2014
    Posts
    4
    I'm getting sick of finding this problem mentioned all over but there is never a solution. I guess everyone just starts using a new voice chat program.

  8. #8
    Join Date
    October 2014
    Posts
    4
    Quote Originally Posted by Kaaboose View Post
    I'm getting sick of finding this problem mentioned all over but there is never a solution. I guess everyone just starts using a new voice chat program.
    Still nothing? I've found it seems to fluctuate when the picture in team speak is changed. Sometimes i get nothing, sometimes i get tonns.

  9. #9
    Join Date
    March 2016
    Posts
    1
    Quote Originally Posted by Kaaboose View Post
    Still nothing? I've found it seems to fluctuate when the picture in team speak is changed. Sometimes i get nothing, sometimes i get tonns.


    i seem to have the same problem, i installed a traffic shaping program and it showedup that teamspeak 3 suddenly causes a lag spike and uses an enormous amount of bandwith, everytime this happens the image (in my case a gif) stoped playing and after the lag spike it played again, so i think to that the issue is caused by the image, best way to test is to remove the images and see what i does. I dont have this problem on every teamspeak server so i think it could be an issue at the host of the teamspeak server or even the connection to the server the image is stored on.

  10. #10
    Join Date
    March 2018
    Posts
    1
    Had the same problem, got really low FPS in games while having Teamspeak open on second monitor, minimizing Teamspeak solved the issue.

    I noticed this was due to the "News" ticker that is sliding on the bottom of the UI. Pressing the X that removes it solved my issues.

  11. #11
    Join Date
    September 2018
    Posts
    1

    TeamSpeak 3 messages causing fps drop ingame

    When im in a channel and someone writes any message (private or public) while im playing League Of Legends my fops drop like -40. I didnt test it in other games, and i neither have any idea of why this happen to me. So im here to claim for some help ^^.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: September 25th, 2015, 09:40 AM
  2. Teamspeak 3 server on NAS causes lag spikes.
    By Louarn in forum Server Support
    Replies: 4
    Last Post: May 1st, 2013, 01:39 PM
  3. Teamspeak 3 lag spikes
    By PyroTech03 in forum Windows
    Replies: 0
    Last Post: July 16th, 2012, 06:11 AM
  4. TS3 Causing random lagg spikes
    By Loader in forum Windows
    Replies: 2
    Last Post: March 11th, 2011, 03:08 PM
  5. Teamspeak lag spikes on debian
    By isack55 in forum Linux / FreeBSD
    Replies: 0
    Last Post: February 5th, 2011, 05:29 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •