Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 1 of 2 12 LastLast
Results 1 to 15 of 17
  1. #1
    Join Date
    June 2012
    Location
    Poland
    Posts
    15

    Solved Server List 3.0.6 (2012-06-21 06:43:35) on Linux

    When i'm update server for new version in linux os, my server is not available on Server List, in last version it's working jet. 3.0.5

    Sorry for my english, i hope any developer help me

  2. #2
    Join Date
    January 2010
    Location
    Germany
    Posts
    2,029
    Server List only shows 100 Servers at most, so you will have to use Filters to see your Server in the List.

    You also need to enable reporting to Weblist in the Server Settings (Right Click Servername -> Edit Virtual Server -> More -> Misc)

    Connection to the Weblist Server must not be blocked.

    And last but not least it can take a couple hours after starting the server for results to appear in the server list.

  3. #3
    Join Date
    June 2012
    Location
    Poland
    Posts
    15
    yes i have on this options, yes it's see 100 server but when type search in list didn't see him. http://imageshack.us/photo/my-images/811/78669418.jpg/

  4. #4
    Join Date
    June 2012
    Location
    Earth
    Posts
    181
    I too upgraded and have this issue. I was listed at the top of the Canadian list with only the country filter enabled before this update.

    Server: 24/7 Gamers Inn - CA West

    I've tried a few commands such as;


    use port=9987
    serveredit b_virtualserver_modify_weblist=1


    -AND-


    use sid=1 (How come 0 works when issuing this cmd also?)
    serveredit b_virtualserver_modify_weblist=1


    Alongside the Client interface -> Check mark under 'misc.' which I've tried.
    I've run pings/traceroute to germany, I seem to check out fine there;


    lsof -i :2010
    ts3server 5284 ****** 18u IPv4 118045 0t0 UDP voice.presension.com:41315->hardy.teamspeak.4players.de:2010

    host weblist.teamspeak.com
    weblist.teamspeak.com has address 194.97.114.3


    What else, well the client side filtering I have also tinkered with from 3 - 4 workstations, from basic filters / no filters to word search..
    I've now setup a 2nd server with a 2nd static IP just to see if it was one of my firewalls in the DMZ, but it too isn't listed under the weblist. I've since disabled the first server for now..
    No errors under the _0.log(s) (I've written a perl program that ports this to my syslog servers so I'm monitoring that beside me..)
    I've had a few clients connect when I first upgraded (from the WAN), but I think most of those used my DNS / bookmark.
    My server shows up fine under GameTracker.com and TSViewer.com..

    PS: This is my first post here, my apologies if I've started this under the wrong thread / board. My eyes are bugging out after going around in circles now for hours

    Thanks!
    Last edited by Scor9ioN; June 24th, 2012 at 11:14 PM.

  5. #5
    Join Date
    January 2010
    Location
    Germany
    Posts
    2,029
    If most of your Users use your DNS Name or Bookmark there is nothing preventing them from still doing so. Just because a Server doesn't show up on the Web Server List doesn't mean nobody can connect to it. It is just a way to find servers you never knew anything about or don't have the connection info for.

    Your Query Commands were all wrong and since you can just uncheck / check the checkbox in the Edit Server Dialog are not required either. use 0 works btw so that you can deselect (aka disconnect from) a virtual server without having to close the Telnet connection.


    As for the Weblist Issue, no clue seems alot recently though, maybe something is wrong with the Weblist server...

    I just enabled it on one of my Servers just to see if it will show up.

  6. #6
    Join Date
    June 2012
    Location
    Earth
    Posts
    181
    If most of your Users use your DNS Name or Bookmark there is nothing preventing them from still doing so. Just because a Server doesn't show up on the Web Server List doesn't mean nobody can connect to it. It is just a way to find servers you never knew anything about or don't have the connection info for.
    The reason I run two DNS servers and point to my other servers.. :/

    Your Query Commands were all wrong and since you can just uncheck / check the checkbox in the Edit Server Dialog are not required either. use 0 works btw so that you can deselect (aka disconnect from) a virtual server without having to close the Telnet connection.
    error id=0 msg=ok (51 ms)
    error id=0 msg=ok (47 ms)
    Total: 98 ms

    They all seem to work here?
    I was just curious as to why the following command works after switching over to sid=0
    serveredit b_virtualserver_modify_weblist=1

    I was wondering if serveredit b_virtualserver_modify_weblist=1 effected sid:0 or not, or if it's even effecting my virtual servers 1 or above..
    Scouring through this forum I found those query commands to check / uncheck the weblist.. My entire post here is only regarding the weblist and the fact that I'm not 'listed' any longer..


    As for the Weblist Issue, no clue seems alot recently though, maybe something is wrong with the Weblist server...

    I just enabled it on one of my Servers just to see if it will show up.
    ..This is my overall goal
    Last edited by Scor9ioN; June 24th, 2012 at 10:45 PM.

  7. #7
    Join Date
    June 2012
    Location
    Poland
    Posts
    15
    ok but i'm need add this permission in all groups or in only guest group and guest channel ? b_virtualserver_modify_weblist

    i'm say in last version ts3 linux 3.0.5 my server its seen in webserver list, but when im update it for 3.0.6 we don't see him

  8. #8
    Join Date
    June 2012
    Location
    Earth
    Posts
    181
    Quote Originally Posted by LS_ARRoW View Post
    ok but i'm need add this permission in all groups or in only guest group and guest channel ? b_virtualserver_modify_weblist

    i'm say in last version ts3 linux 3.0.5 my server its seen in webserver list, but when im update it for 3.0.6 we don't see him
    This particular variable seems to be located under 'perm_server_groups' with an entry for each SID you have created..
    So by either toggling the option from client-side; 'edit virtual server' -> 'misc' -> 'Enable reporting to server list' or with a query command such as b_virtualserver_modify_weblist=1, you're essentially just flipping the flag between 0/off or 1/on.. All my entries are at 1 myself & still my server doesn't respond to the weblist server..

  9. #9
    Join Date
    January 2010
    Location
    Germany
    Posts
    2,029
    nonono...

    You are mixing the Permission which enables Clients to change the Setting in the Virtual Server Settings with the actual Setting... (which is what I meant when I said all your Query Commands are wrong).

    the actual Setting itself is called virtualserver_weblist_enabled so to actually change the setting using the query it would be serveredit virtualserver_weblist_enabled=0 but as you already mentioned it's easier changed in the Client itself.
    The Reason this works on server 0 is that if you are modifying server 0 you are changing the default Value for newly created servers.

  10. #10
    Join Date
    June 2012
    Location
    Earth
    Posts
    181
    Thanks for pointing out that second variable SS, I never knew it existed

    Either way, fresh server, fresh install, fresh IP... I dunno if the file permissions have anything to do with it IMO.

  11. #11
    Join Date
    June 2012
    Location
    Poland
    Posts
    15
    for that use that's command ? how long i need wait for refresh webserver list for see him ?

    login serveradmin <password>
    use <sid>
    serveredit virtualserver_weblist_enabled=0

    error id=0 msg=ok (48 ms)
    error id=0 msg=ok (24 ms)
    error id=0 msg=ok (28 ms)
    Total: 100 ms

  12. #12
    Join Date
    June 2008
    Posts
    18,513
    You have to enable it first. 0 Means not activated in your case.
    serveredit virtualserver_weblist_enabled=1

    it takes about 10-12~minutes to until the weblist does refresh the serverlist.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  13. #13
    Join Date
    June 2012
    Location
    Poland
    Posts
    15
    ok i'm change it a few hour ago and didn't see him i don't know what is wrong i need restart server too ?

    login serveradmin ************
    use sid=1
    serveredit virtualserver_weblist_enabled=1

    error id=0 msg=ok (173 ms)
    error id=0 msg=ok (56 ms)
    error id=0 msg=ok (29 ms)
    Total: 258 ms

  14. #14
    Join Date
    January 2010
    Location
    Germany
    Posts
    2,029
    There was a Bug which prevents Servers running 3.0.6 from being listed in the Weblist.
    The Bug got fixed a couple hours ago and is available as PRE Release. If you really need your Server to be listed on the Weblist for whatever reason you can either downgrade to the 3.0.5 Version or upgrade to the 3.0.7-pre1 Version. Note that 3.0.7 is not a stable Release though.

  15. #15
    Join Date
    June 2012
    Location
    Poland
    Posts
    15
    Now it's working in Version:3.0.7-pre1 (2012-06-25 15:23:34) on Linux

    i hope it's new official version 3.0.7 will be fast update

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Server reporting to the server list LINUX
    By ToFran in forum Server Support
    Replies: 7
    Last Post: March 5th, 2014, 03:41 PM
  2. server 2012 Random DC
    By hMeco in forum Windows
    Replies: 0
    Last Post: August 21st, 2013, 05:55 PM
  3. Windows Server 2012 issues.
    By Reddax in forum Server Support
    Replies: 0
    Last Post: July 15th, 2013, 08:36 PM
  4. [Resolved] TS3 Server permid list... (LINUX)
    By Tiieto in forum Linux / FreeBSD
    Replies: 5
    Last Post: July 24th, 2011, 12:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •