Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 3 of 8 FirstFirst 12345 ... LastLast
Results 31 to 45 of 107
  1. #31
    Join Date
    October 2010
    Location
    Warsaw / Poland
    Posts
    296
    It should work just fine. Does your TS3 server start in sqlite3 mode? If so please uninstall installed libmysqlclient15off and try another one. Uninstall command is dpkg -P libmysqlclient15off

  2. #32
    Join Date
    January 2013
    Posts
    6
    I followed this tutorial all the way through, supplementing the "teamspeak" account with another account, the server loads when i use the command:

    su wasp -c '/home/wasp/teamspeak/ts3server_minimal_runscript.sh inifile=ts3server.ini'
    The issue i'm having is that when i exit PuTTY, it shuts the TS3 server down. Any idea how i can fix this so it continues running?

  3. #33
    Join Date
    September 2012
    Posts
    6,079
    you are using the wrong script, you should be using the proper startscript called ts3server_startscript.sh which would make your command like this
    Code:
    ./ts3server_startscript.sh start inifile=ts3server.ini
    you can of course use that in a su user -c statement or switch the user yourself then manually start it... You might have to adjust the path according to your environment of course.

  4. #34
    Join Date
    January 2013
    Posts
    6
    Quote Originally Posted by Chris View Post
    you are using the wrong script, you should be using the proper startscript called ts3server_startscript.sh which would make your command like this
    Code:
    ./ts3server_startscript.sh start inifile=ts3server.ini
    you can of course use that in a su user -c statement or switch the user yourself then manually start it... You might have to adjust the path according to your environment of course.
    Thanks, i've used that and it seems to be working now, haven't used Linux for a number of years now so i'm starting from scratch again .

  5. #35
    Join Date
    January 2013
    Posts
    2
    Everything goes good for me until I get to:

    Quote Originally Posted by ARCHI View Post
    [email protected]:~# su teamspeak -c '/home/teamspeak/teamspeak/ts3server_minimal_runscript.sh inifile=ts3server.ini'
    I get this message:
    Code:
    2013-01-23 13:10:36.129621|INFO    |ServerLibPriv |   | TeamSpeak 3 Server 3.0.6.1 (2012-06-29 07:59:05)
    2013-01-23 13:10:36.131250|INFO    |DatabaseQuery |   | dbPlugin name:    MySQL plugin, (c)TeamSpeak Systems GmbH
    2013-01-23 13:10:36.131432|INFO    |DatabaseQuery |   | dbPlugin version: 1
    2013-01-23 13:10:36.136568|ERROR   |DatabaseQuery |   | mysql_real_connect() failed with error: Access denied for user 'root'@'localhost' (using password: NO)
    2013-01-23 13:10:36.136722|CRITICAL|ServerLibPriv |   | Server() DatabaseError
    What am I doing wrong?

  6. #36
    Join Date
    September 2012
    Posts
    6,079
    you choose to use MySQL but neglected to supply the required information as to which MySQL user to use, the password for that user and probably even which database to use.

  7. #37
    Join Date
    January 2013
    Posts
    2
    I'm not sure where in the tutorial I messed up on or how to fix it. Could you point me in the right direction as how to fix it? Thank you.

  8. #38
    Join Date
    September 2012
    Posts
    6,079
    Quote Originally Posted by kennett View Post
    I'm not sure where in the tutorial I messed up on or how to fix it. Could you point me in the right direction as how to fix it? Thank you.
    somewhere in the following:
    Quote Originally Posted by ARCHI View Post
    Okay, MySQL Server should be running. Next...

    Code:
    [email protected]:~# mysql -h localhost -u root -p
    mysql> create database teamspeak;
    mysql> grant ALL on teamspeak.* to [email protected] identified by 'your_password_for_mysql_connection';
    mysql> exit

    Let's continue...
    Code:
    [email protected]:~# su teamspeak
    [email protected]:/root$ cd ~/teamspeak
    [email protected]:~/teamspeak$ nano ts3db_mysql.ini
    Now paste below text to your text editor and save it as ts3db_mysql.ini.
    [config]
    host=127.0.0.1
    port=3306
    username=teamspeak
    password=your_password_for_mysql_connection
    database=teamspeak
    socket=

  9. #39
    Join Date
    October 2010
    Location
    Warsaw / Poland
    Posts
    296
    Yeah it looks like you didn't provide password in "password" field ts3db_mysql.ini.

  10. #40
    Join Date
    February 2013
    Posts
    2
    Well, I followed every step and got it working, but I can't access the logs folder (says I don't have enough permission), and the key in privilegekey_guide.txt doesn't work either? Is there any way to retrieve the token or get myself server admin? I tried with query but it says login + password are wrong.
    Never had these problems when hosting on Win7.

  11. #41
    Join Date
    October 2010
    Location
    Warsaw / Poland
    Posts
    296
    You've probably started server as root, and so root created logs and you can't access it as normal user. Log in as root, then stop all teamspeak instances (killall -9 ts3server_linux_amd64/i386) and execute chown -hR tsuser:tsuser /path/to/teamspeak.

  12. #42
    Join Date
    February 2013
    Posts
    2
    Quote Originally Posted by ARCHI View Post
    You've probably started server as root, and so root created logs and you can't access it as normal user. Log in as root, then stop all teamspeak instances (killall -9 ts3server_linux_amd64/i386) and execute chown -hR tsuser:tsuser /path/to/teamspeak.
    Thanks for the quick answer, I can access the log files now, but they don't show any token nor server query login.

    Edit: Deleted everything and restarted the whole process from the start, got my token and server query login!

    ARCHI, thanks for your help
    Last edited by itskibo; February 11th, 2013 at 04:16 PM.

  13. #43
    Join Date
    March 2013
    Posts
    3
    So, I am lost.

    [email protected]:~$ su teamspeak -c '/home/teamspeak/teamspeak/ts3server_minimal_runscript.sh inifile=ts3server.ini'
    Password:
    2013-03-10 22:39:32.396995|INFO |ServerLibPriv | | TeamSpeak 3 Server 3.0.7 (2013-03-02 06:03:25)
    2013-03-10 22:39:32.538580|INFO |DatabaseQuery | | dbPlugin name: MySQL plugin, (c)TeamSpeak Systems GmbH
    2013-03-10 22:39:32.538889|INFO |DatabaseQuery | | dbPlugin version: 1
    2013-03-10 22:39:32.550150|CRITICAL|DatabaseQuery | | setSQLfromFile( file:sql/update_1.sql) failed
    [email protected]:~$
    If I run it in screen I don't see this output. I'm running on Ubuntu Server 12.10 64bit, and although I hate MySQL, I believe that its installed properly.

    [email protected]:~/teamspeak$ ldd libts3db_mysql.so
    linux-vdso.so.1 => (0x00007ffff9400000)
    libmysqlclient.so.15 => /usr/lib/libmysqlclient.so.15 (0x00007f9c70270000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f9c6ff68000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f9c6fc68000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f9c6fa50000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f9c6f690000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f9c6f470000)
    libcrypt.so.1 => /lib/x86_64-linux-gnu/libcrypt.so.1 (0x00007f9c6f230000)
    libnsl.so.1 => /lib/x86_64-linux-gnu/libnsl.so.1 (0x00007f9c6f010000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f9c6edf8000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f9c70880000)
    [email protected]:~/teamspeak$
    any input would be great.

  14. #44
    Join Date
    October 2010
    Location
    Warsaw / Poland
    Posts
    296
    It looks like your database is corrupted for some reason. I'd suggest deleting whole content of your database in MySQL and try again.

  15. #45
    Join Date
    March 2013
    Posts
    3
    Quote Originally Posted by ARCHI View Post
    It looks like your database is corrupted for some reason. I'd suggest deleting whole content of your database in MySQL and try again.
    sorry, how do i do that?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [DEBIAN] Trying to start teamspeak3 server with screen
    By Ghostaunt in forum Linux / FreeBSD
    Replies: 22
    Last Post: November 10th, 2013, 11:55 AM
  2. Replies: 2
    Last Post: January 11th, 2011, 07:39 AM
  3. Beta20 @ Debian server MySQL
    By kintaro in forum Linux / FreeBSD
    Replies: 12
    Last Post: April 2nd, 2010, 07:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •