Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Page 1 of 2 12 LastLast
Results 1 to 15 of 21
  1. #1
    Join Date
    March 2012

    I think I haven't been updating my TS3 server since forever, yes I got no idea how to

    Hey people!

    I think I first setup this TS3 server on my VPS at 12 september 2013 or something. Since then I haven't updated at all!

    Yes, I am the one in charge of it and I have been delaying this thing for such a long time!

    I want to update this, but I looked at the internet (ahem well I actually looked a few months back) and couldn't find anything about updating an existing TS3 server to a higher version (especially if it's RC) you can call me a dumbo or whatever you want to, I use computers pretty fine, tho since It's RC, I didn't want to do much (since RC's can have bugs etc, I was like "if it ain't broken, don't fix it") but now the clients on my server are getting bored of this message popping out and I am worried that we can face some compability issues at the upcoming versions. And yes, I have no friggun idea why I got the RC version at the first place! I had my VPS for the very first time, I was so excited, I probs didn't look what version I was downloading.

    TL;DR how do I update this TS3 server (using some RC1 version) to the latest version, on a linux VPS? Without friggun my server over or losing data (channels, groups, blah blah)

  2. #2
    Join Date
    June 2011
    You did not update your server for 4 (in words: four) years? Are you serious?
    If you care that little about security, stop hosting a server! Now! Additionally, if you don't want to read or use search feature, there is really no advice we can give you.

  3. #3
    Join Date
    March 2012
    Quote Originally Posted by numma_cway View Post
    You did not update your server for 4 (in words: four) years? Are you serious?
    If you care that little about security, stop hosting a server! Now! Additionally, if you don't want to read or use search feature, there is really no advice we can give you.
    No? Well I don't know if the server version is that old or not but all I know is that I installed the server at September 2013.

    The four years part is not correct (Well atleast imo)

    Unless the installation procedure I used had an outdated version or something..

    By the way, I already know how to install /update a ts3 server, the only problem is this is RC! So I must make sure nothing will get to wrong at the end.

  4. #4
    Join Date
    April 2011
    It's called backup. Before running an update you do a backup. And if something goes wrong you can use your backup.

  5. #5
    Join Date
    March 2012
    Yeah sure, thanks to both of you for helping.

  6. #6
    Join Date
    March 2012
    [email protected]:~/teamspeak3-server_linux-x86# unrar x teamspeakupdate.rar

    UNRAR 4.10 freeware Copyright (c) 1993-2012 Alexander Roshal

    Extracting from teamspeakupdate.rar

    sql/ban_delete.sql already exists. Overwrite it ?
    [Y]es, [N]o, [A]ll, n[E]ver, [R]ename, [Q]uit y

    Extracting sql/ban_delete.sql OK

    sql/ban_insert.sql already exists. Overwrite it ?
    [Y]es, [N]o, [A]ll, n[E]ver, [R]ename, [Q]uit a

    Extracting sql/ban_insert.sql OK
    Extracting sql/ban_list.sql OK
    Extracting sql/bindings_insert.sql OK
    Extracting sql/bindings_list.sql OK
    Extracting sql/binding_delete.sql OK
    Extracting sql/channel_delete.sql OK
    Extracting sql/channel_insert.sql OK
    Extracting sql/channel_server_list.sql OK
    Extracting sql/channel_update_parentid.sql OK
    Extracting sql/clientid_get_by_name_pw.sql OK
    Extracting sql/clientid_get_by_name_pw_serverid.sql OK
    Extracting sql/client_clear_traffic_stats.sql OK
    Extracting sql/client_count_by_serverid.sql OK
    Extracting sql/client_delete.sql OK
    Extracting sql/client_delete_prune.sql OK
    Extracting sql/client_get.sql OK
    Extracting sql/client_get_by_id.sql OK
    Extracting sql/client_get_by_name_or_uid.sql OK
    Extracting sql/client_get_by_serverid.sql OK
    Extracting sql/client_get_by_serverid_limit.sql OK
    Extracting sql/client_get_by_uid.sql OK
    Extracting sql/client_insert.sql OK
    Extracting sql/client_update_login_info.sql OK
    Extracting sql/client_update_name.sql OK
    Extracting sql/client_update_stats.sql OK
    Extracting sql/client_update_traffic_stats.sql OK
    Extracting sql/complain_delete.sql OK
    Extracting sql/complain_delete_all.sql OK
    Extracting sql/complain_delete_prune.sql OK
    Extracting sql/complain_get_by_serverid.sql OK
    Extracting sql/complain_insert.sql OK
    Creating sql/create_mariadb OK
    Extracting sql/create_mariadb/create_tables.sql OK
    Extracting sql/create_mariadb/drop_tables.sql OK
    Extracting sql/create_sqlite/create_tables.sql OK
    Extracting sql/create_sqlite/drop_tables.sql OK
    Extracting sql/custom_delete_by_clientid.sql OK
    Extracting sql/custom_get_by_id.sql OK
    Extracting sql/custom_get_by_ident.sql OK
    Extracting sql/custom_insert.sql OK
    Extracting sql/defaults.sql OK
    Extracting sql/groups_get.sql OK
    Extracting sql/groups_get_by_serverid.sql OK
    Extracting sql/groups_get_by_serverid_type.sql OK
    Extracting sql/group_delete.sql OK
    Extracting sql/group_id_get_by_name.sql OK
    Extracting sql/group_insert.sql OK
    Extracting sql/group_members_get_by_groupid.sql OK
    Extracting sql/group_members_get_by_id.sql OK
    Extracting sql/group_members_get_by_serverid.sql OK
    Extracting sql/group_member_delete.sql OK
    Extracting sql/group_member_delete_by_groupid.sql OK
    Extracting sql/group_member_detail_get_by_groupid.sql OK
    Extracting sql/group_member_get.sql OK
    Extracting sql/group_member_insert.sql OK
    Extracting sql/group_rename.sql OK
    Extracting sql/info_delete.sql OK
    Extracting sql/info_get_by_ident.sql OK
    Extracting sql/info_insert.sql OK
    Extracting sql/message_delete.sql OK
    Extracting sql/message_get_by_clientid.sql OK
    Extracting sql/message_get_unread_by_clientid.sql OK
    Extracting sql/message_insert.sql OK
    Extracting sql/message_list_by_clientid.sql OK
    Extracting sql/message_update_flag.sql OK
    Extracting sql/perm_delete_by_groupid.sql OK
    Extracting sql/perm_delete_by_permid.sql OK
    Extracting sql/perm_delete_by_serverid.sql OK
    Extracting sql/perm_get_by_id.sql OK
    Extracting sql/perm_get_by_serverid.sql OK
    Extracting sql/perm_insert.sql OK
    Extracting sql/perm_rename.sql OK
    Extracting sql/perm_update_get_groups.sql OK
    Extracting sql/properties_delete_by_id.sql OK
    Extracting sql/properties_delete_by_string_id.sql OK
    Extracting sql/properties_insert_by_id.sql OK
    Extracting sql/properties_insert_by_string_id.sql OK
    Extracting sql/properties_list_by_id.sql OK
    Extracting sql/properties_list_by_string_id.sql OK
    Extracting sql/server_clear_traffic_stats.sql OK
    Extracting sql/server_delete.sql OK
    Extracting sql/server_delete_get_qa_clients.sql OK
    Extracting sql/server_get_byid.sql OK
    Extracting sql/server_get_byport.sql OK
    Extracting sql/server_insert.sql OK
    Extracting sql/server_list.sql OK
    Extracting sql/server_list_by_machine_id.sql OK
    Extracting sql/server_snapshot_delete.sql OK
    Extracting sql/server_snapshot_delete_failed.sql OK
    Extracting sql/server_update_autostart.sql OK
    Extracting sql/server_update_machine_id.sql OK
    Extracting sql/server_update_port.sql OK
    Extracting sql/server_update_traffic_stats.sql OK
    Extracting sql/token_delete_by_key.sql OK
    Extracting sql/token_get_by_key.sql OK
    Extracting sql/token_insert.sql OK
    Extracting sql/token_list.sql OK
    Creating sql/updates_and_fixes OK
    Extracting sql/updates_and_fixes/convert_mysql_to_mariadb.sql OK
    Extracting sql/updates_and_fixes/mariadb_fix_latin_utf8.sql OK
    Extracting sql/update_12.sql OK
    Extracting sql/update_13.sql OK
    Extracting sql/update_14.sql OK
    Extracting sql/update_15.sql OK
    Extracting sql/update_16.sql OK
    Extracting sql/update_17.sql OK
    Extracting sql/update_18.sql OK
    Extracting sql/update_19.sql OK
    Extracting sql/update_20.sql OK
    Extracting sql/update_21.sql OK
    Extracting sql/update_22.sql OK
    Extracting sql/update_23.sql OK
    Extracting sql/update_database_version.sql OK
    Extracting sql/update_permissions_12.sql OK
    Extracting tsdns/README OK
    Extracting tsdns/tsdnsserver_linux_x86 OK
    Extracting tsdns/tsdns_settings.ini.sample OK
    Extracting tsdns/USAGE OK
    Extracting CHANGELOG OK
    Extracting OK
    Extracting OK
    Extracting LICENSE OK
    Extracting ts3server_linux_x86 OK
    Extracting OK
    Extracting OK
    Extracting doc/permissiondoc.txt OK
    Extracting doc/privilegekey_guide.txt OK
    Extracting doc/server_quickstart.txt OK
    Extracting doc/server_upgrade.txt OK
    Extracting doc/ts3_serverquery_manual.pdf OK
    Extracting doc/update_mysql_to_mariadb.txt OK
    Creating redist OK
    Extracting redist/ OK
    Extracting serverquerydocs/banadd.txt OK
    Extracting serverquerydocs/banclient.txt OK
    Extracting serverquerydocs/bandel.txt OK
    Extracting serverquerydocs/bandelall.txt OK
    Extracting serverquerydocs/banlist.txt OK
    Extracting serverquerydocs/bindinglist.txt OK
    Extracting serverquerydocs/channeladdperm.txt OK
    ***removed some of the messages due to char limit***
    All OK
    [email protected]:~/teamspeak3-server_linux-x86#
    [email protected]:~/teamspeak3-server_linux-x86# ./ start
    -bash: ./ Permission denied ***gave 777 after this***
    [email protected]:~/teamspeak3-server_linux-x86#
    [email protected]:~/teamspeak3-server_linux-x86# ./ start
    Do you have the right TS3 Server package for your system? You have: Linux x86_64, not Linux i386. found, but no server running. Possibly your previously started server crashed
    Please view the logfile for details.
    Starting the TeamSpeak 3 server
    ts3server_linux_x86 is not executable, trying to set it
    TeamSpeak 3 server started, for details please view the log file
    [email protected]:~/teamspeak3-server_linux-x86#

  7. #7
    Join Date
    June 2011
    Quote Originally Posted by Tamer View Post
    No? Well I don't know if the server version is that old or not but all I know is that I installed the server at September 2013.
    Installing a server software that was 3.5 years old when you did it doesn't make it any better. So please stop hosting a server. Thank you.

  8. #8
    Join Date
    March 2012
    Do not focus on that rather helping me out maybe? I do understand It is stupid and I agree with you. But the best is to update so wouldn't it be better? I was new to these things when I installed it, can you now focus on helping me out? Then we can start discussing if I should be hosting a server or not.

  9. #9
    Join Date
    March 2012
    Now listen to me carefully mr. numma_cway

    I tried f**king updating it alright? I really tried. I couldn't manage it. And yes that idiot whoever wrote the tutorial to set it up somewhere mentioned that it was an RC1 version, and while installing I didn't even look at the date or whatever you want to f**king call it. If I accidentally or maybe with no idea downloaded an old version YES this might be my fault or MAYBE It's because I didn't know It was like that?

    Look listen up, I have NEVER seen such a failure of assistance in my life anywhere in the internet, whereever I go people are willing to help eachother without god damn humiliating! Please put yourself in to my position, a guy who didn't know his server was outdated, comes here asking for help, some guy comes up and says he should not be hosting a server, if you were at my spot, would you actually stop hosting a server just because I told you? No you won't. Get to real, you won't.

    Now, be a human, help me out, oh if you don't want to, leave me alone. I bet there are more humane people at this forum who can actually help me out without humiliating me.

    It's not nice, It's not cool, I don't like it.

    Also, I am smart enough to take backups and try this on my own, I know the progress. I can remember now I tried doing this back at april 2014 but it didn't work, I gave up. Now I decided to try once more time, this time I came here up and asked.

    Yes I said I couldn't find anything on the internet, so I tried it on my own. It didn't work and as you can see I am getting an error and its not working!

  10. #10
    Join Date
    December 2004
    Did you read the update guide before trying an update?
    Also, where did you get the RAR ARCHIVE with update, to begin with?

  11. #11
    Join Date
    March 2012
    Well, I created it on my own. I got the .tar.gz and turned it in to a .rar because I noticed when I extract it, it extracts itself into a folder, so I removed that folder and added the archive elements itself to the archive, because then I had to move the folder elements manually in to the main server dir.

    I did the .rar on my own, just so its 1 step quicker to finish the job.

    I didn't read the update guide, no. Can you link it please?

  12. #12
    Join Date
    December 2004
    Quote Originally Posted by Tamer View Post
    I didn't read the update guide, no.
    Then "right now" is a good time to do so, before you get another comment concerning the state of the matter that fill the inside of your head.

  13. #13
    Join Date
    March 2012
    The problem is, I looked everywhere at the forum but couldn't find it.

    I checked stickied topics, nothing there. Tried searching for "server update" then couldn't find anything there too and it asked me to wait 80 seconds so I gave up.

  14. #14
    Join Date
    December 2004

  15. #15
    Join Date
    March 2012
    Quote Originally Posted by ANR Daemon View Post

    Btw I obviously tried these before. They didn't work, thats why I am here atm.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Servergroup haven't got a permission, but still can do it
    By Sebi94 in forum Permission System
    Replies: 6
    Last Post: March 12th, 2013, 08:36 PM
  2. Teamspeak server takes forever to load.
    By AgentExeider in forum Server Support
    Replies: 9
    Last Post: October 22nd, 2010, 04:58 AM
  3. Haven't upgraded in a while... need help.
    By Arterio in forum Server Support
    Replies: 10
    Last Post: June 3rd, 2010, 01:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts