Forum

Page 2 of 8 FirstFirst 1234 ... LastLast
Results 16 to 30 of 107
  1. #16
    Join Date
    May 2007
    Location
    Alabama
    Posts
    54
    WHy am I getting this error?

    CentOS 6.3

    [[email protected] teamspeak3-server_linux-amd64]$ ldd libts3db_mysql.so
    ./libts3db_mysql.so: error while loading shared libraries: /usr/lib64/libmysqlclient.so.15: file too short

  2. #17
    Join Date
    October 2010
    Location
    Warsaw / Poland
    Posts
    296
    Because packages linked in this tutorial are probably not compatible with centos itself. I'd suggest searching for compatible ones.

  3. #18
    Join Date
    November 2012
    Posts
    6
    Hello.

    I followed this tutorial, but when I try to connect to the server it says "Failed to connect to the server", that happens when it's offline.

    So I'm not sure if it is blocking the connection somehow or if something went wrong, cuz some values are weird like those "listening on 0.0.0.0:10011"

    I have a SS to help you see if it is correct or something is missing:

    http://s10.postimage.org/7l2c8e2bd/image.jpg

    Should I configure something else? I never used a TS3 server so not sure fi in this point of the tutorial I would be able to login in the TS normally.

    Edit 2: Look's like when I'm starting the server it is not starting for some reason.

    Thank you
    Last edited by maozao; November 29th, 2012 at 07:18 PM.

  4. #19
    Join Date
    October 2010
    Location
    Warsaw / Poland
    Posts
    296
    Hello.

    Your TS3 Server seems to work just fine. Check if your firewall/router accept listed ports in #1 post.

    Good Luck.

  5. #20
    Join Date
    November 2012
    Posts
    6
    I don't think so.

    I tried to run the .sh directly with those commands. (dont remember the file name now)

    ts3runscript.sh stop
    Server stopped.

    ts3runscript.sh start
    Server started.

    ts3runscript.sh status
    Ts3 server seems to have died

    So it just say that started but when I check the status it says "Ts3 server seems to have died".

  6. #21
    Join Date
    November 2012
    Posts
    6
    Now I could make it show me "Server is running" when start it, but when I look that the running services it doesn't show the main port that show run, the 9987

    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 0.0.0.0:10011 0.0.0.0:* LISTEN 1180/ts3server_linu
    tcp 0 0 127.0.0.1:3306 0.0.0.0:* LISTEN 767/mysqld
    tcp 0 0 0.0.0.0:30033 0.0.0.0:* LISTEN 1180/ts3server_linu
    tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 638/sshd
    tcp6 0 0 :::22 :::* LISTEN 638/sshd

  7. #22
    Join Date
    April 2011
    Location
    Germany
    Posts
    1,266
    May be the command parameters you specified filter UDP out. The main port for voice communication is UDP 9987. In your list above are only TCP ports listed. So may be your command filter UDP?!

    So may be you should try a "netstat -lnp" .... I think you used: "netstat -ltnp"

  8. #23
    Join Date
    November 2012
    Posts
    6
    Quote Originally Posted by Barungar View Post
    May be the command parameters you specified filter UDP out. The main port for voice communication is UDP 9987. In your list above are only TCP ports listed. So may be your command filter UDP?!

    So may be you should try a "netstat -lnp" .... I think you used: "netstat -ltnp"
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 0.0.0.0:10011 0.0.0.0:* LISTEN 1180/ts3server_linu
    tcp 0 0 127.0.0.1:3306 0.0.0.0:* LISTEN 767/mysqld
    tcp 0 0 0.0.0.0:30033 0.0.0.0:* LISTEN 1180/ts3server_linu
    tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 638/sshd
    tcp6 0 0 :::22 :::* LISTEN 638/sshd
    udp 0 0 0.0.0.0:9987 0.0.0.0:* 1180/ts3server_linu
    Active UNIX domain sockets (only servers)
    Proto RefCnt Flags Type State I-Node PID/Program name Path
    unix 2 [ ACC ] STREAM LISTENING 2816 598/acpid /var/run/acpid.socket
    unix 2 [ ACC ] STREAM LISTENING 2989 767/mysqld /var/run/mysqld/mysqld.sock

    Is that correct then ?

  9. #24
    Join Date
    October 2010
    Location
    Warsaw / Poland
    Posts
    296
    Now I'm nearly 100% sure that it's your or your server's network fault.

    Probably your provider doesn't allow UDP traffic or something similar. TS3 process works just fine, you can even get listened ports correctly. If so it's not a TS-related problem.

  10. #25
    Join Date
    November 2012
    Posts
    6
    I talked to my host and they said that the UDP inbound are blocked because of attacks, so it's really a server problem, thank you.

  11. #26
    Join Date
    December 2012
    Posts
    3
    Quote Originally Posted by Chris View Post
    ---snip---
    If you already have a MySQL server running you can just download and extract TeamSpeak, setup the configuration files for the TeamSpeak server to use the MySQL Server and you're pretty much done.
    NO you are not pretty much done.

    The 5.0x series of mysql is not a valid proposition for an up to date Linux system. Pulling a library from an older binary package for mysql that happens to be linked to an ABI incompatible openssl doesn't work!!!

    The proper fix would be for you (TeamSpeak Systems GmbH) to link the libts3db_mysql.so against more recent versions of the mysql client library (or better link it against each of the ABI incompatible mysql client libraries).

    I was asked if I could deploy a TS3 server on my private server for my guild and the answer I had to give them was 'NO, not until TeamSpeak Systems GmbH fixes their mysql incompatibility problems'

  12. #27
    Join Date
    September 2012
    Posts
    6,079
    Quote Originally Posted by dekeonus View Post
    the answer I had to give them was 'NO, not until TeamSpeak Systems GmbH fixes their mysql incompatibility problems'
    Or you know you could've answered "Yes" and use the default sqlite database.

    And if the MySQL Server is already running you are pretty much done, except for getting the lib if you happen to have a semi-recent version of MySQL server (which admittedly is not uncommon anymore by now) that doesn't ship with the 15 lib anymore.

    Either way fixing the libmysql dependency is on the ToDo list already.

  13. #28
    Join Date
    March 2009
    Location
    Berlin
    Posts
    4
    i have this Error:
    2012-12-14 16:01:29.680453|CRITICAL|DatabaseQuery | | unable to load database plugin library "liblibts3db_mysql.so", halting!

    ldd libts3db_mysql.so
    linux-vdso.so.1 => (0x00007fff1ab89000)
    libmysqlclient.so.15 => /usr/lib/libmysqlclient.so.15 (0x00007f22257e2000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f22254e2000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f22251e7000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f2224fd1000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f2224c14000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f22249f6000)
    libcrypt.so.1 => /lib/x86_64-linux-gnu/libcrypt.so.1 (0x00007f22247bd000)
    libnsl.so.1 => /lib/x86_64-linux-gnu/libnsl.so.1 (0x00007f22245a3000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f222438b000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f2225dee000)

    why don't started the server ?

  14. #29
    Join Date
    October 2010
    Location
    Warsaw / Poland
    Posts
    296
    If ldd doesn't report "not found" then all required libraries are fine. Check if you have latest updates by running apt-get update && apt-get dist-upgrade, also if it won't help then tell me what OS are you using, I mean version.

  15. #30
    Join Date
    March 2009
    Location
    Berlin
    Posts
    4
    the server has gemeledet "" then I installed libmysqlclient.so.15


    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=12.04
    DISTRIB_CODENAME=precise
    DISTRIB_DESCRIPTION="Ubuntu 12.04.1 LTS"

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [DEBIAN] Trying to start teamspeak3 server with screen
    By Ghostaunt in forum Linux / FreeBSD
    Replies: 22
    Last Post: November 10th, 2013, 11:55 AM
  2. Replies: 2
    Last Post: January 11th, 2011, 07:39 AM
  3. Beta20 @ Debian server MySQL
    By kintaro in forum Linux / FreeBSD
    Replies: 12
    Last Post: April 2nd, 2010, 07:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •