Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 9 of 9
  1. #1
    Join Date
    July 2007
    Location
    Germany
    Posts
    14

    Question Connection Problems with Server

    Teamspeak Client Debug Info:

    PHP Code:
    03.07.2012 23:01:38        Info    TeamSpeak 3 Client 3.0.7 (2012-06-21 06:34:59)    
    03.07.2012 23:01:38    Direct Sound    Debug    setting timer resolution to 1ms    
    03.07.2012 23
    :01:38    Query    Info    listening on 127.0.0.1:25639    
    03.07.2012 23
    :01:38    Windows Audio Session    Devel    DeviceDeleteList::waitForDeletes enter    
    03.07.2012 23
    :01:38    Windows Audio Session    Devel    DeviceDeleteList::waitForDeletes leave    
    03.07.2012 23
    :01:38    Input    Info    Direct Input monitoring enabled    
    03.07.2012 23
    :01:38    ClientUI    Info    Qt version4.7.2    
    03.07.2012 23
    :01:38    ClientUI    Info    Using configuration locationC:/Users/n3oth3on3/AppData/Roaming/TS3Client/ts3clientui_qt.conf    
    03.07.2012 23
    :01:38    Input    Info    Input device nameMaus    
    03.07.2012 23
    :01:38    Input    Info    Input device nameTastatur    
    03.07.2012 23
    :01:38    ClientUI    Info    Last update check wasDi 3. Jul 08:11:56 2012    
    03.07.2012 23
    :01:39    ClientUI    Info    Connect to server188.40.209.159    
    03.07.2012 23
    :01:39    ClientUI    Info    Checking blacklist    
    03.07.2012 23
    :01:39        Info    Trying to resolve blacklist server    
    03.07.2012 23
    :01:39        Info    creating2 000000000202FBB0    
    03.07.2012 23
    :01:39    ClientUI    Info    Blacklist check ok    
    03.07.2012 23
    :01:39    ClientUI    Info    Initiating connection188.40.xxx.xxx:9987 188.40.xxx.xxx    
    03.07.2012 23
    :01:39    Windows Audio Session    Devel    DeviceDeleteList::waitForDeletes enter    
    03.07.2012 23
    :01:39    Windows Audio Session    Devel    DeviceDeleteList::waitForDeletes leave    
    03.07.2012 23
    :01:39    Windows Audio Session    Debug    WAS::openDevice-enter    
    03.07.2012 23
    :01:39    Windows Audio Session    Debug    WAS Buffer size960    
    03.07.2012 23
    :01:39    Windows Audio Session    Debug    WAS::openDevice-leave    
    03.07.2012 23
    :01:39    Windows Audio Session    Debug    WAS::startDevice-enter    
    03.07.2012 23
    :01:39    Windows Audio Session    Debug    WAS::startDevice-leave    
    03.07.2012 23
    :01:39    Windows Audio Session    Devel    DeviceDeleteList::waitForDeletes enter    
    03.07.2012 23
    :01:39    Windows Audio Session    Devel    DeviceDeleteList::waitForDeletes leave    
    03.07.2012 23
    :01:39    Windows Audio Session    Debug    WAS::openDevice-enter    
    03.07.2012 23
    :01:39    Windows Audio Session    Debug    WAS Buffer size960    
    03.07.2012 23
    :01:39    Windows Audio Session    Debug    WAS::openDevice-leave    
    03.07.2012 23
    :01:39    PreProSpeex    Info    Speex versionspeex-1.2beta3    
    03.07.2012 23
    :01:39    Windows Audio Session    Debug    WAS::startDevice-enter    
    03.07.2012 23
    :01:39    Windows Audio Session    Debug    WAS::startDevice-leave    
    03.07.2012 23
    :01:39    Windows Audio Session    Debug    Got 2 or more rendering spaces in same loop 480 960 480    
    03.07.2012 23
    :01:39        Info    Blacklist server resolved    
    03.07.2012 23
    :01:39        Info    Data sent to blacklist server    
    03.07.2012 23
    :01:39    ClientUI    Info    Connect statusConnecting    
    03.07.2012 23
    :01:39        Info    Data received from blacklist server1,    
    03.07.2012 23:01:39    SCHandler    Warning    Got command data from unexpected IP/Portusing new IP    
    03.07.2012 23
    :01:39    SCHandler    Info    Expected answer from188.40.xxx.xxx:9987but received answer from188.40.xxx.xxx:9987    
    03.07.2012 23
    :01:39    SCHandler    Warning    Server changed IP, new IP188.40.xxx.xxx    
    03.07.2012 23
    :01:39    SCHandler    Warning    Got command data from unexpected IP/Portusing new IP    
    03.07.2012 23
    :01:39    SCHandler    Info    Expected answer from188.40.xxx.xxx:9987but received answer from188.40.xxx.xxx:9987    
    03.07.2012 23
    :01:39    SCHandler    Warning    Got command data from unexpected IP/Portusing new IP    
    03.07.2012 23
    :01:39    SCHandler    Info    Expected answer from188.40.xxx.xxx:9987but received answer from188.40.xxx.xxx:9987    
    03.07.2012 23
    :01:39    ClientUI    Info    Connect statusDisconnected    
    03.07.2012 23
    :01:39    ClientUI    Info    Disconnected or forced to leavewant autoreconnect 
    Server Log file:

    PHP Code:
    2012-07-03 23:01:39.853361|INFO    |VirtualServer |  1client disconnected 'xxx'(id:2reason 'reasonmsg=connection lost' 
    I have this Problem since some Days. When i will connect to my Server i must type a Password, but when i will enter the Server Password, the Server give me only the Anserver : Bad Password...

    Im thinking that my Server is banning me or? I reinstalled today the Server, but i have still the same Problem.

    Maybe its my Lizenze.dat?

    Need really help, dont know what to do now

    PHP Code:
    03.07.2012 23:15:53        Info    TeamSpeak 3 Client 3.0.7 (2012-06-21 06:34:59)    
    03.07.2012 23:15:53    Direct Sound    Debug    setting timer resolution to 1ms    
    03.07.2012 23
    :15:53    Query    Info    listening on 127.0.0.1:25639    
    03.07.2012 23
    :15:53    Windows Audio Session    Devel    DeviceDeleteList::waitForDeletes enter    
    03.07.2012 23
    :15:53    Windows Audio Session    Devel    DeviceDeleteList::waitForDeletes leave    
    03.07.2012 23
    :15:53    Input    Info    Direct Input monitoring enabled    
    03.07.2012 23
    :15:53    ClientUI    Info    Qt version4.7.2    
    03.07.2012 23
    :15:53    ClientUI    Info    Using configuration locationC:/Users/n3oth3on3/AppData/Roaming/TS3Client/ts3clientui_qt.conf    
    03.07.2012 23
    :15:53    Input    Info    Input device nameMaus    
    03.07.2012 23
    :15:53    Input    Info    Input device nameTastatur    
    03.07.2012 23
    :15:53    ClientUI    Info    Last update check wasDi 3. Jul 08:11:56 2012    
    03.07.2012 23
    :15:54    ClientUI    Info    Connect to server188.40.209.159    
    03.07.2012 23
    :15:54    ClientUI    Info    Checking blacklist    
    03.07.2012 23
    :15:54        Info    Trying to resolve blacklist server    
    03.07.2012 23
    :15:54        Info    creating2 0000000001F6FBB0    
    03.07.2012 23
    :15:54    ClientUI    Info    Blacklist check ok    
    03.07.2012 23
    :15:54    ClientUI    Info    Initiating connection188.40.xxx.xxx:9987 188.40.xxx.xxx    
    03.07.2012 23
    :15:54    Windows Audio Session    Devel    DeviceDeleteList::waitForDeletes enter    
    03.07.2012 23
    :15:54    Windows Audio Session    Devel    DeviceDeleteList::waitForDeletes leave    
    03.07.2012 23
    :15:54    Windows Audio Session    Debug    WAS::openDevice-enter    
    03.07.2012 23
    :15:54    Windows Audio Session    Debug    WAS Buffer size960    
    03.07.2012 23
    :15:54    Windows Audio Session    Debug    WAS::openDevice-leave    
    03.07.2012 23
    :15:54    Windows Audio Session    Debug    WAS::startDevice-enter    
    03.07.2012 23
    :15:54    Windows Audio Session    Debug    WAS::startDevice-leave    
    03.07.2012 23
    :15:54    Windows Audio Session    Devel    DeviceDeleteList::waitForDeletes enter    
    03.07.2012 23
    :15:54    Windows Audio Session    Devel    DeviceDeleteList::waitForDeletes leave    
    03.07.2012 23
    :15:54    Windows Audio Session    Debug    WAS::openDevice-enter    
    03.07.2012 23
    :15:54    Windows Audio Session    Debug    WAS Buffer size960    
    03.07.2012 23
    :15:54    Windows Audio Session    Debug    WAS::openDevice-leave    
    03.07.2012 23
    :15:54    PreProSpeex    Info    Speex versionspeex-1.2beta3    
    03.07.2012 23
    :15:54    Windows Audio Session    Debug    WAS::startDevice-enter    
    03.07.2012 23
    :15:54    Windows Audio Session    Debug    WAS::startDevice-leave    
    03.07.2012 23
    :15:54        Info    Blacklist server resolved    
    03.07.2012 23
    :15:54        Warning    Blacklist check error7    
    03.07.2012 23
    :15:54        Warning    Failed to write to blacklist server: Die Nachricht konnte nicht gesendet werden    
    03.07.2012 23
    :15:54    ClientUI    Info    Connect statusConnecting    
    03.07.2012 23
    :16:00    ClientUI    Info    Connect statusDisconnected    
    03.07.2012 23
    :16:00    ClientUI    Info    Failed to connect to serverwant autoreconnect 0    
    03.07.2012 23
    :16:03        Info    deleting 0000000001F6FBB0 

  2. #2
    Join Date
    October 2010
    Location
    Warsaw / Poland
    Posts
    296
    03.07.2012 23:01:39 Info Data received from blacklist server: 1,
    I don't know if this is what I think it is but check if your server isn't blacklisted, especially if you can connect to other servers from same client.

  3. #3
    Join Date
    January 2010
    Location
    Germany
    Posts
    2,029
    Nope thats just a normal response, if a server is blacklisted the message would be refusing to connect or something along those lines clearly stating the server being blacklisted.


    If the CLient says you need to enter a password and the server then reports bad password it's because someone changed the password or you did enter the wrong one.

    However you also have Issues with contacting the Blacklist Server
    Code:
    03.07.2012 23:15:54        Warning    Blacklist check error: 7     
    03.07.2012 23:15:54        Warning    Failed to write to blacklist server: Die Nachricht konnte nicht gesendet werden
    so either you did something to prevent connecting to the blacklist or the blacklist server had some issues (ie. was down that time).

  4. #4
    Join Date
    July 2007
    Location
    Germany
    Posts
    14
    When i restart the Server, i can connect for some minutes ... Thats somethink like the Server is banning me all the Time, but there is nothing on the Black or Ban-List.

    Edit:
    After 30 minutes, im kicked (connection lost). Dont know what to do now :S
    Last edited by n3oth3on3; July 4th, 2012 at 08:01 AM.

  5. #5
    Join Date
    October 2010
    Location
    Warsaw / Poland
    Posts
    296
    If you have some sort of firewall on the server (such as iptables) you could try to disable it for a few hours of testing.
    Also check if your dns'es work fine, for example if you can ping any non-IP address such as teamspeak.com

  6. #6
    Join Date
    July 2007
    Location
    Germany
    Posts
    14
    Disabled the Password on our Server, and the same Problem!

    PHP Code:
    04.07.2012 09:12:01        Info    TeamSpeak 3 Client 3.0.7 (2012-06-21 06:34:59)    
    04.07.2012 09:12:01    Direct Sound    Debug    setting timer resolution to 1ms    
    04.07.2012 09
    :12:01    Query    Info    listening on 127.0.0.1:25639    
    04.07.2012 09
    :12:01    Windows Audio Session    Devel    DeviceDeleteList::waitForDeletes enter    
    04.07.2012 09
    :12:01    Windows Audio Session    Devel    DeviceDeleteList::waitForDeletes leave    
    04.07.2012 09
    :12:01    Input    Info    Direct Input monitoring enabled    
    04.07.2012 09
    :12:02    ClientUI    Info    Qt version4.7.2    
    04.07.2012 09
    :12:02    ClientUI    Info    Using configuration locationC:/Users/n3oth3on3/AppData/Roaming/TS3Client/ts3clientui_qt.conf    
    04.07.2012 09
    :12:02    Input    Info    Input device nameMaus    
    04.07.2012 09
    :12:02    Input    Info    Input device nameTastatur    
    04.07.2012 09
    :12:02    ClientUI    Info    Last update check wasMi 4. Jul 07:48:41 2012    
    04.07.2012 09
    :12:03    ClientUI    Info    Connect to server188.40.xxx.xxx    
    04.07.2012 09
    :12:03    ClientUI    Info    Checking blacklist    
    04.07.2012 09
    :12:03        Info    Trying to resolve blacklist server    
    04.07.2012 09
    :12:03        Info    creating2 000000000211FBB0    
    04.07.2012 09
    :12:03    ClientUI    Info    Blacklist check ok    
    04.07.2012 09
    :12:03    ClientUI    Info    Initiating connection188.40.xxx.xxx:9987 188.40.xxx.xxx
    04.07.2012 09
    :12:03    Windows Audio Session    Devel    DeviceDeleteList::waitForDeletes enter    
    04.07.2012 09
    :12:03    Windows Audio Session    Devel    DeviceDeleteList::waitForDeletes leave    
    04.07.2012 09
    :12:03    Windows Audio Session    Debug    WAS::openDevice-enter    
    04.07.2012 09
    :12:03    Windows Audio Session    Debug    WAS Buffer size960    
    04.07.2012 09
    :12:03    Windows Audio Session    Debug    WAS::openDevice-leave    
    04.07.2012 09
    :12:03    Windows Audio Session    Debug    WAS::startDevice-enter    
    04.07.2012 09
    :12:03    Windows Audio Session    Debug    WAS::startDevice-leave    
    04.07.2012 09
    :12:03    Windows Audio Session    Devel    DeviceDeleteList::waitForDeletes enter    
    04.07.2012 09
    :12:03    Windows Audio Session    Devel    DeviceDeleteList::waitForDeletes leave    
    04.07.2012 09
    :12:03    Windows Audio Session    Debug    WAS::openDevice-enter    
    04.07.2012 09
    :12:03    Windows Audio Session    Debug    WAS Buffer size960    
    04.07.2012 09
    :12:03    Windows Audio Session    Debug    WAS::openDevice-leave    
    04.07.2012 09
    :12:03    PreProSpeex    Info    Speex versionspeex-1.2beta3    
    04.07.2012 09
    :12:03    Windows Audio Session    Debug    WAS::startDevice-enter    
    04.07.2012 09
    :12:03    Windows Audio Session    Debug    WAS::startDevice-leave    
    04.07.2012 09
    :12:03        Info    Blacklist server resolved    
    04.07.2012 09
    :12:03        Info    Data sent to blacklist server    
    04.07.2012 09
    :12:03    ClientUI    Info    Connect statusConnecting    
    04.07.2012 09
    :12:03        Info    Data received from blacklist server1,    
    04.07.2012 09:12:03    ClientUI    Info    Connect statusConnected    
    04.07.2012 09
    :12:03    ClientUI    Info    Connect statusEstablishing connection    
    04.07.2012 09
    :12:03    ClientUI    Info    Connect statusConnection established    
    04.07.2012 09
    :12:11        Info    deleting 000000000211FBB0    
    04.07.2012 09
    :27:01        Info    Memory usage36.76 MiB    
    04.07.2012 09
    :42:01        Info    Memory usage36.86 MiB    
    04.07.2012 09
    :57:01        Info    Memory usage36.41 MiB    
    04.07.2012 10
    :12:02        Info    Memory usage36.50 MiB    
    04.07.2012 10
    :27:02        Info    Memory usage36.52 MiB    
    04.07.2012 10
    :42:02        Info    Memory usage36.60 MiB    
    04.07.2012 10
    :43:50    ClientUI    Info    Connect statusDisconnected    
    04.07.2012 10
    :43:50    ClientUI    Info    Connection lostwant autoreconnect 1    
    04.07.2012 10
    :43:50    Bookmarks    Info    Disconnecttotal time5506 756783    
    04.07.2012 10
    :43:51    ClientUI    Info    Autoreconnecting    
    04.07.2012 10
    :43:51    ClientUI    Info    Connect to server188.40.xxx.xxx
    04.07.2012 10
    :43:51    ClientUI    Info    Checking blacklist    
    04.07.2012 10
    :43:51        Info    Trying to resolve blacklist server    
    04.07.2012 10
    :43:51        Info    creating2 0000000007724310    
    04.07.2012 10
    :43:51    ClientUI    Info    Blacklist check ok    
    04.07.2012 10
    :43:51    ClientUI    Info    Initiating connection188.40.xxx.xxx:9987 188.40.xxx.xxx    
    04.07.2012 10
    :43:51    ClientUI    Info    Connect statusConnecting    
    04.07.2012 10
    :43:51        Info    Blacklist server resolved    
    04.07.2012 10
    :43:51        Info    Data sent to blacklist server    
    04.07.2012 10
    :43:51    SCHandler    Warning    Got command data from unexpected IP/Portusing new IP    
    04.07.2012 10
    :43:51    SCHandler    Info    Expected answer from188.40.xxx.xxx:9987but received answer from188.40.209.136:9987    
    04.07.2012 10
    :43:51    SCHandler    Warning    Server changed IP, new IP188.40.xxx.xxx    
    04.07.2012 10
    :43:51    SCHandler    Warning    Got command data from unexpected IP/Portusing new IP    
    04.07.2012 10
    :43:51    SCHandler    Info    Expected answer from188.40.xxx.xxx:9987but received answer from188.40.209.136:9987    
    04.07.2012 10
    :43:51        Info    Data received from blacklist server1,    
    04.07.2012 10:43:51    SCHandler    Warning    Got command data from unexpected IP/Portusing new IP    
    04.07.2012 10
    :43:51    SCHandler    Info    Expected answer from188.40.xxx.xxx:9987but received answer from188.40.209.136:9987    
    04.07.2012 10
    :43:51    ClientUI    Info    Connect statusDisconnected    
    04.07.2012 10
    :43:51    ClientUI    Info    Disconnected or forced to leavewant autoreconnect 0    
    04.07.2012 10
    :43:56        Info    deleting 0000000007724310 
    Im running the Server without an server.ini, is this maybe the Problem?

  7. #7
    Join Date
    January 2010
    Location
    Germany
    Posts
    2,029
    The Server seems to be multi homed (ie. has multiple IP Addresses) which causes Problems with TeamSpeak as by default the Server is listening on any IP Address available and answering on any one of them but not necessarily the one the request came from.
    The Client Log clearly states that the client received unsolicited Responses from another IP than the one it is connected to. So you connect to 1.2.3.4 and are connected to your TS3 Server, but the server sends data to you from his secondary IP Address 2.3.4.1.
    To fix this create an ini File where you specify the IP Address the Server should use.
    Create a File called server.ini with the following content:
    Code:
    voice_ip=1.2.3.4
    query_ip=1.2.3.4
    filetransfer_ip=1.2.3.4
    of course you should replace 1.2.3.4 with the IP you want your Server to use.
    then run the server this way:
    Code:
    ./ts3server_startscript.sh start inifile=server.ini

  8. #8
    Join Date
    July 2007
    Location
    Germany
    Posts
    14
    Im back from Holidays, and the Server making still Problems. Now the Password Field is comming, and when im adding the Password, i became this:

    <10:37:28> Versuche zum Server auf 188.40.xxx.xxx zu verbinden
    <10:37:28> flood prevention, please try again later
    That is my server.ini

    Code:
    machine_id=
    default_voice_port=9987
    voice_ip=188.40.xxx.xxx
    licensepath=
    filetransfer_port=30033
    filetransfer_ip=188.40.xxx.xxx
    query_port=10011
    query_ip=188.40.xxx.xxx
    query_ip_whitelist=query_ip_whitelist.txt
    query_ip_blacklist=query_ip_blacklist.txt
    dbplugin=ts3db_sqlite3
    dbpluginparameter=
    dbsqlpath=sql/
    dbsqlcreatepath=create_sqlite/
    dbconnections=10
    logpath=logs
    logquerycommands=0
    dbclientkeepdays=30
    logappend=0
    All have the Same IP, thats right or?

  9. #9
    Join Date
    January 2010
    Location
    Germany
    Posts
    2,029
    Yeah your server.ini looks ok.

    The reason you cannot connect is because you are banned for flooding (spamming, connecting too often in a short period of time etc). You either really flooded the server (see above) or you played around with the Settings and made the server unusable in the process.

    Try and wait for like half an hour before trying to connect to the server again.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Own Server Connection Problems
    By picomaster in forum Windows
    Replies: 0
    Last Post: September 20th, 2015, 08:45 AM
  2. Ts3 server connection problems.
    By chuck111 in forum Server Support
    Replies: 1
    Last Post: June 25th, 2014, 10:33 PM
  3. New ts3 server , connection problems
    By niceboy in forum Server Support
    Replies: 0
    Last Post: August 13th, 2013, 09:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •