Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 2 of 2
  1. #1
    Join Date
    June 2007
    in a house.

    start_server: unable to open database after trying to start alternative way.

    Teamspeak 2 installed on my debian machine. (yes,2, not yet 3)
    starting with script works as a sharm.
    how ever, i am not willing to login ssh each time for maint or what ever.
    so i made a html based start system.
    works perfect on my other services (shoutcast, and some games)
    but when itry start TS2, i got a error starting deamon, aborted.
    and in TS log, i see got this
    -------------- log started at 11-07-12 17:36 -------------
    11-07-12 17:36:41,ALL,Info,server, Server init initialized
    11-07-12 17:36:41,ALL,Info,server, Server version: Linux
    11-07-12 17:36:41,ERROR,All,SQL, ExcecSQL Error: unable to open database file in query: PRAGMA default_syn$
    11-07-12 17:36:41,ERROR,All,SERVER, Start_Server: unable to open database
    --------------- log ended at 11-07-12 17:36 --------------

    i tried several stuff, but zip.
    the fun thing was, when i rented a *nix machine, same script used, and it worked there.
    so, where to look, www right, or ts rights ?

  2. #2
    Join Date
    June 2008
    Please check the permissions of the sql file.
    I can't help here, i used google to get such an answer for another tool.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] Can't open database
    By twprogrammers in forum Linux / FreeBSD
    Replies: 1
    Last Post: June 2nd, 2015, 10:00 PM
  2. Database is malformed db open()*
    By hunterpl in forum Server Support
    Replies: 4
    Last Post: June 3rd, 2011, 05:49 AM
  3. Database is malformed db open()*
    By hunterpl in forum Bug Reports [EN/DE]
    Replies: 1
    Last Post: May 30th, 2011, 03:28 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts