Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 11 of 11
  1. #1
    Join Date
    July 2008
    Location
    Canada
    Posts
    21

    Solved TS3 constantly crashing - Fillbuffer error

    QFSFileEngine:pen: No file name specified
    2012-07-23 19:00:37.875207|WARNING |GenericPlayback| | fillbuffer asked for more samples than ringbuffer can contain (7922 vs 4096)
    2012-07-23 19:00:47.884246|WARNING |GenericPlayback| | fillbuffer asked for more samples than ringbuffer can contain (4756 vs 4096)
    2012-07-23 19:00:49.141093|WARNING |GenericPlayback| | fillbuffer asked for more samples than ringbuffer can contain (4787 vs 4096)
    2012-07-23 19:00:49.329412|WARNING |GenericPlayback| | fillbuffer asked for more samples than ringbuffer can contain (4787 vs 4096)
    2012-07-23 19:00:57.893367|WARNING |GenericPlayback| | fillbuffer asked for more samples than ringbuffer can contain (4924 vs 4096)
    2012-07-23 19:01:05.831874|WARNING |GenericPlayback| | fillbuffer asked for more samples than ringbuffer can contain (5207 vs 4096)
    2012-07-23 19:01:17.912446|CRITICAL|GenericPlayback| | Assertion "samples * sizeof(short) <= maxRequestSize" failed at client/clientlib/sound/genericplayback.cpp:739;


    Good times - Debian squeeze 64 3.2-BPO kernel, latest version of TS3
    Last edited by unconnected; July 24th, 2012 at 01:42 AM.

  2. #2
    Join Date
    July 2008
    Location
    Canada
    Posts
    21
    Ah I found the cause.. A quick look into my syslog showed me this:

    Jul 23 19:07:44 vera kernel: [58944.119078] Write-error on swap-device (8:16:1556920)
    Jul 23 19:07:44 vera kernel: [58944.119212] Write-error on swap-device (8:16:256808)
    Jul 23 19:07:44 vera kernel: [58944.119230] Write-error on swap-device (8:16:256824)

    I was running my swap off a flash card and that was a bad idea apparently. Switched swap to my hard drive and this problem dissapeared. Unfortunately replaced by another but that's a different story

  3. #3
    Join Date
    June 2008
    Posts
    18,513
    Thank you for your feedback. This will help other users too, when this happens again
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  4. #4
    Join Date
    August 2012
    Location
    France
    Posts
    1

    Exclamation

    Unfortunately I get the very same crash with Ubuntu 12.04.
    And it is not related to not enough RAM or missing swap.
    My little guess is, the crashes becomes critical the longer is system uptime, and the sooner TeamSpeak crash.
    So something tells me there is some nasty bug in the ring-buffer allocation:
    May be memory fragmentation related, or large memory, or one of the developer let a wrong type casted pointer/counter in the amd64 version of ts3client and it mess with it when memory location becomes high

    Hardware:
    MB: Gigabyte Technology Co., Ltd..EX58-EXTREME.x.x.
    CPU: Socket 1366.Intel.Intel(R) Core(TM) i7 CPU.
    RAM: 24GB DDR3
    Sound: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
    GFX: NVIDIA Corporation GT200 [GeForce GTX 260] (rev a1)

    Software:
    3.2.0-27-generic #43-Ubuntu SMP Fri Jul 6 14:25:57 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
    TeamSpeak 3 Client 3.0.8.1 (2012-07-30 14:09:12)

    Crash logs:
    Teamspeak:
    Code:
    2012-08-04 01:53:35.454243|WARNING |GenericPlayback|   | fillbuffer asked for more samples than ringbuffer can contain (4316 vs 4096)
    2012-08-04 01:53:48.615259|CRITICAL|GenericPlayback|   | Assertion "samples * sizeof(short) <= maxRequestSize" failed at client/clientlib/sound/genericplayback.cpp:739;
    Syslog:
    Code:
    [94218.384989] ts3client_linux[14201]: segfault at 0 ip 00007fc4fdd6c2dc sp 00007fff94d4d970 error 6 in libQtGui.so.4[7fc4fda1d000+9b6000]

  5. #5
    Join Date
    June 2008
    Posts
    18,513
    A ticket for this was created in our ticket system.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  6. #6
    Join Date
    June 2002
    Location
    Netherlands
    Posts
    1,049
    leagris,

    I will fix the assert(crash) for the next release. But the underlying problem seems to be that your sound system is asking for very large amounts of sound data in 1 request. This will lead to sound data being missed and high latency.

    - Are you using alsa or pulse audio?
    - Is there anything special that you can tell me about your sound setup?
    - Please post a complete log of a crash session.

  7. #7
    Join Date
    August 2012
    Posts
    2
    Im having the exact same problem as leagris. It got to the point where it was so frustrating I came scouring the web for fixes, and found this thread. I agree with him longer system has been up the more likely it happens. And if it happens once, it happens pretty much non stop until I reboot. Very annoying. I find myself rebooting 3 times a day because of this.


    Aug 11 22:57:26: [ 3311.351371] ts3client_linux[2149]: segfault at 0 ip 00007fa0f3bbcf65 sp 00007ffff2dd61c0 error 4 in libQtGui.so.4[7fa0f3955000+9b6000]

  8. #8
    Join Date
    June 2002
    Location
    Netherlands
    Posts
    1,049
    tempz, for you the same question:
    - Are you using alsa or pulse audio?
    - Is there anything special that you can tell me about your sound setup?
    - Please post a complete log of a crash session.

    Also, can you notice that your friends are laggy. I mean, does sound seem to arrive way later than it should?

  9. #9
    Join Date
    August 2012
    Posts
    2
    Quote Originally Posted by nwerensteijn View Post
    tempz, for you the same question:
    - Are you using alsa or pulse audio?
    - Is there anything special that you can tell me about your sound setup?
    - Please post a complete log of a crash session.

    Also, can you notice that your friends are laggy. I mean, does sound seem to arrive way later than it should?
    Hey just as a follow up I fixed this by removing pulse audio and running on alsa. I've been stable for about a week on alsa.

  10. #10
    Join Date
    June 2002
    Location
    Netherlands
    Posts
    1,049
    Ok thank you for the followup.

  11. #11
    Join Date
    June 2008
    Posts
    18,513
    This crash should be fixed with our latest client 3.0.9.2. But an error will be printed into your client log.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ts3 in overwolf is crashing constantly
    By Firejubjub in forum Client Support
    Replies: 1
    Last Post: August 8th, 2013, 08:40 AM
  2. [Resolved] TS3 crashing, disk I/O error
    By serano in forum Linux / FreeBSD
    Replies: 2
    Last Post: March 20th, 2012, 09:09 PM
  3. [Solved] Server Crashing (I/O Error)
    By Ek0nomik in forum Server Support
    Replies: 1
    Last Post: October 2nd, 2010, 08:16 AM
  4. suddenly server is crashing with error
    By GTXGaming in forum Server Support
    Replies: 1
    Last Post: April 12th, 2010, 02:04 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •