Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 1 of 2 12 LastLast
Results 1 to 15 of 17
  1. #1
    Join Date
    January 2010
    Location
    Utah
    Posts
    2

    unable to load database plugin library, halting!

    I am trying to install TS3 on a Fedora 11 server and I get this error message when I try to start it: "unable to load database plugin library, halting!"

    Code:
    teamspeak3-server_linux-x86]# ./ts3server_linux_x86 dbplugin=ts3db_mysql dbsqlcreatepath=create_mysql/
    TeamSpeak Server 3.0.0-beta16 [Build: 9929]
    (c)TeamSpeak Systems GmbH
    
    Logging started
    2010-01-26 17:47:35.758731|INFO    |ServerLibPriv |   | Server Version: 3.0.0-beta16 [Build: 9929]
    2010-01-26 17:47:35.798730|CRITICAL|DatabaseQuery |   | unable to load database plugin library, halting!
    I followed the instructions found here: http://forum.teamspeak.com/showthread.php?t=47011

    ts3server.ini
    Code:
    machine_id=
    default_voice_port=9987
    voice_ip=174.143.149.20
    liscensepath=
    filetransfer_port=30033
    filetransfer_ip=174.143.149.20
    query_port=10011
    query_ip=174.143.149.20
    dbplugin=ts3db_mysql
    dbpluginparameter=ts3db_mysql.ini
    dbsqlpath=sql/
    logpath=logs
    logquerycommands=1
    ts3db_mysql.ini
    Code:
    host='127.0.0.1'
    port='3306'
    username='teamspeak'
    password=' ***HIDDEN*** '
    database='ts3'
    socket=
    Can anyone tell if I have overlooked something? Thanks!

  2. #2
    Join Date
    January 2009
    Location
    Talca, Chile
    Posts
    14
    I have the same problem but I work with CentOS.

    Any idea?..

    That libraries depends ts3 ?

  3. #3
    Join Date
    December 2009
    Location
    Portugal
    Posts
    492
    Hi

    I also ran into this issue in my Ubuntu Karmic box. I googled and i found this:
    http://forum.teamspeak.com/showthread.php?t=46762

    All i did was install the missing library (libmysqlclient.so.15) and then it loaded without any issues.

    Regards

  4. #4
    Join Date
    January 2009
    Location
    Talca, Chile
    Posts
    14
    I create a simbolic link to libmysqlclient.so.15 into root directory of ts3. but doesn't work.

    /usr/lib/mysql/libmysqlclient.so.15

    ln -s libmysqlclient.so.15 /home/ts3/libmysqlclient.so.15

    ?

    I am reviewing libraries one by one.
    Last edited by Dn.LaG; January 27th, 2010 at 02:21 AM.

  5. #5
    Join Date
    December 2009
    Location
    Portugal
    Posts
    492
    I wouldn't say that creating a link would solve the issue. The library has to be properly installed so the mysql can recognize it.

    Run the following command and post the result here:
    ldd libts3db_mysql.so

  6. #6
    Join Date
    January 2010
    Location
    Utah
    Posts
    2
    Quote Originally Posted by Jonybat View Post
    Hi
    All i did was install the missing library (libmysqlclient.so.15) and then it loaded without any issues.
    I'll try that later today and see if it works.

    I ended up running sqlite instead and it started right up, I'd prefer to use MySQL.

    Thanks!

  7. #7
    Join Date
    March 2009
    Location
    USA
    Posts
    20
    using FC11 as well, I had to install additional client libraries for mysql (being that the mysql that FC11 has by default is too new for the library that TS3 is built against).

    if you do the
    Code:
    ldd libts3db_mysql.so
    and the output has a line like
    Code:
    libmysqlclient.so.15 => not found
    instead of something like
    Code:
    libmysqlclient.so.15 => /usr/lib/libmysqlclient.so.15
    you will also need to install the additional mysql client libraries. If you have i585 this is the correct rpm to install, if however you are x86_64, this is the one you want to install.
    Last edited by aeular; January 29th, 2010 at 09:02 PM. Reason: added more information

  8. #8
    Join Date
    March 2009
    Location
    French
    Posts
    51
    Hello,

    I have the same problem being passed to the Beta 16 ....

    ts3server.ini:
    Code:
    machine_id =
    default_voice_port = 9987
    voice_ip = 0.0.0.0
    licensepath =. /
    filetransfer_port = 30,033
    filetransfer_ip = 0.0.0.0
    query_port = 10,011
    query_ip = 0.0.0.0
    query_ip_whitelist = query_ip_whitelist.txt
    dbplugin = ts3db_mysql
    dbpluginparameter = ts3db_mysql.ini
    dbsqlpath = sql /
    dbsqlcreatepath = create_mysql /
    logpath = log
    logquerycommands = 1
    ts3db_mysql.ini:
    Code:
    [config]
    host = localhost
    port = 3306
    username = my_user
    password = my_pass
    database = my_table
    socket =
    I run teamspeak:

    Code:
    ./ts3server_linux_x86-inifile ts3server.ini
    The result:
    TeamSpeak Server 3.0.0-beta16 [Build: 9929]
    (c) TeamSpeak Systems GmbH

    Logging started
    2010-01-29 23:39:49.450277 | INFO | ServerLibPriv | | Server Version: 3.0.0-be TA16 [Build: 9929]
    2010-01-29 23:39:49.450691 | INFO | DatabaseQuery | | dbPlugin name: SQLite 3 plugin, (c) TeamSpeak Systems GmbH
    2010-01-29 23:39:49.450767 | INFO | DatabaseQuery | | dbPlugin version: 3.6.21
    Code:
    ldd libts3db_mysql.so
    linux-gate.so.1 => (0xffffe000)
    libmysqlclient.so.15 => /usr/lib/libmysqlclient.so.15 (0xb7ea1000)
    libstdc + +. so.6 => /usr/lib/libstdc + +. so.6 (0xb7db3000)
    libm.so.6 => /lib/i686/cmov/libm.so.6 (0xb7d8c000)
    libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7d7f000)
    libc.so.6 => /lib/i686/cmov/libc.so.6 (0xb7c24000)
    libpthread.so.0 => /lib/i686/cmov/libpthread.so.0 (0xb7c0b000)
    libcrypt.so.1 => /lib/i686/cmov/libcrypt.so.1 (0xb7bd9000)
    libnsl.so.1 => /lib/i686/cmov/libnsl.so.1 (0xb7bc0000)
    libz.so.1 => /usr/lib/libz.so.1 (0xb7baa000)
    /lib/ld-linux.so.2 (0xb8099000)

    but by testing as follows:
    ./ts3server_linux_x86 dbplugin = ts3db_mysql dbsqlcreatepath = create_mysql /

    it works then my problem is solved :P

  9. #9
    Join Date
    February 2010
    Location
    Germany
    Posts
    1
    I have had the same problem.
    I'm running debian linux with pd-admin. in this case the mysql files are not located at the standard path.
    I created a system link the following way:
    Code:
     ln -s /usr/local/pd-admin2/lib/mysql/libmysqlclient.so.15 /usr/lib/libmysqlclient.so.15
    now the Teamspeak Server was able to load the file but not to connect...
    so lets move on to the next error

  10. #10
    Join Date
    June 2010
    Location
    russia, Moscow
    Posts
    5

    libmysqlclient.so.15 for FreeBSD x64 help

    Hi, i have problem for start TS3 server on FreeBSD 9.0 x64

    error :
    local# ./ts3server_freebsd_amd64 dbplugin=ts3db_mysql dbsqlcreatepath=create_mysql/
    2012-07-14 23:08:24.334689|INFO |ServerLibPriv | | TeamSpeak 3 Server 3.0.6.1 (2012-06-29 07:59:05)
    2012-07-14 23:08:24.342999|CRITICAL|DatabaseQuery | | unable to load database plugin library "libts3db_mysql.so", halting!

    local# ldd libts3db_mysql.so
    libts3db_mysql.so:
    /libexec/ld-elf.so.1: /lib/libts3db_mysql.so: Unexpected inconsistency: dependency libmysqlclient.so.15 not found
    libts3db_mysql.so: exit status 1



    i cant find libmysqlclient.so.15 for x64 BSD

  11. #11
    Join Date
    December 2009
    Location
    Germany
    Posts
    32
    Would be great of a solution about this, 'cause i have the same problem under opensuse 11.4

    libmysqlclient15 is not avail only 16.

  12. #12
    Join Date
    June 2010
    Location
    Germany
    Posts
    2
    Here you can find a solution for Debian Squeez

    Edit: maffi requested a link change
    Last edited by CSchmidt; September 9th, 2014 at 10:41 AM.

  13. #13
    Join Date
    December 2009
    Location
    Germany
    Posts
    32
    Don't like this, 'cause old package on new system can make big trouble.

  14. #14
    Join Date
    January 2010
    Location
    Germany
    Posts
    2,029
    The only choice you have is to somewhere get a copy of libmysqlclient.so.15 so it can and will be used by ts3, or to use another Database System (eg. sqlite). Unfortunately there is no other option at the moment. Don't like it either but it is how it is.

  15. #15
    Join Date
    December 2009
    Location
    Germany
    Posts
    32
    Tryed but that wont work. Mybe different MYSQL Versions are running. Lib 15 runs with 5.0 and lib 16 with 5.1. I'm not the freak but it seems that this different version wont work together under linux openSuse 11.4 There is no lib 15 version i tryed with 11.1 and i get a socket error. Thats all so bad. Why there no reaktions from a developer of the ts3 server.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: October 17th, 2014, 03:33 AM
  2. Replies: 1
    Last Post: November 11th, 2013, 06:04 PM
  3. [Resolved] unable to load database plugin library "libts3db_mysql.so", halting!
    By PoL4K in forum Linux / FreeBSD
    Replies: 10
    Last Post: March 15th, 2012, 07:29 PM
  4. Replies: 3
    Last Post: April 29th, 2010, 09:36 PM
  5. Replies: 3
    Last Post: February 5th, 2010, 06:54 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •