Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 5 of 5
  1. #1
    Join Date
    August 2012
    Posts
    3

    3.0.7 Keybindings not recognized after connecting to server

    Hello,

    as the title suggests, my keybindings don't work after I connect to a server on 3.0.7. (I use 3.0.7 for ACRE mod in ARMA2).

    Whenever I launch the client, it works, but once I connect to any server, it doesn't. This is with and without running the program as administrator. If I disconnect from the server, my keybindings still don't work for the remainder of the session. (Ie keybindings don't work at all until I close and reopen the program.) I also tried to rebind the functions while the current ones aren't working and the client wouldn't let me. The client would not recognize any button on the keyboard except for the mouse buttons and esc to cancel the keybinding.

    My current keybindings are NUM1 for push-to-talk and NUM2 for toggle speaker mute (I use the Razer Naga if that helps anything).

    I tried my current keybindings on 3.0.6 in a server and they worked there.

    Thanks,
    Utaki

  2. #2
    Join Date
    June 2008
    Posts
    18,513
    Client 3.0.7 is outdated and the server version has nothing to do with your keybinds.
    Please make sure ,that your hotkey profile is set in your favourites.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    August 2012
    Posts
    3
    So I updated teamspeak 3 to 3.0.8 and had the same problem; however when I updated to 3.0.8.1, the problem was gone. This leads me to suspect the ACRE plugin is to blame because when the ACRE plugin isn't compatible, the buttons work, but when the ACRE plugin is active, the buttons don't work. I'll look into the plugin.

    Also, by favourites do you mean the bookmarked hotkey profiles? I made bookmarks for specific servers and made new profiles, all this selected, but it didn't fix the problem.

  4. #4
    Join Date
    August 2012
    Posts
    1
    I'm having the exact same problem with 3.0.8, also using ACRE mod. Before connecting to any server, keys work fine, afterwards they all stop, even after disconnecting and trying other servers or anything really.

    One thing you didn't mention that's wierd: when i go to test mic, I push to talk during test and nothing shows up, it doesn't register that I'm pushing the button. If I try to change my push to talk, nothing happens either, it doesn't recognize me pushing ANY keys whatsoever. But for some reason, it does recognize me push escape to cancel the prompt. I can still type in chat, but the rest of the keyboard for all other functions is completely disabled. I'm not sure how or if it relates to ACRE because I see almost no users at all using 3.0.8.1 in any ACRE teamspeak.

    Also, if I disable the ACRE plugin, I still get the problem.

    Changing input method to either keyboard & mouse or direct had no effect, nor did reinstalling.

    edit: after reinstalling, changing input to keyboard & mouse only seems to work..
    Last edited by Ghazi364; August 2nd, 2012 at 08:15 AM.

  5. #5
    Join Date
    August 2012
    Posts
    3
    Thanks Ghazi364!

    I fixed it thanks to your suggestion. Instead of "keyboard and mouse only", though, "Direct Input" was the one that worked for me.

    Maybe I'll run into you sometime in ACE.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Not Possible to Set Keybindings
    By Thaumasurge in forum Windows
    Replies: 0
    Last Post: December 3rd, 2014, 11:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •