Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 2 of 2
  1. #1
    Join Date
    August 2012

    Solved Remote client wont connect to server - fine local. Server Query fine remote.

    Hi all,

    I'm trying to get TeamSpeak 3 up and running on a new win2k8 box.
    I've been following THIS guide on how to get it up and running.

    I've forwarded all of the following ports and verified them using portForwarder:



    However, I am unable to connect to the server remotely using the client.
    I CAN connect with server query remotely without issue.

    The server is a multi-IP server, with the static IPs: /
    To ensure it wasn't a problem with multi-IP, I added "" to the server command prompt (and also in the server config file..)

    on querying the serverlist via the serverquery protocol, I get the following info:

    virtualserver_id=1 virtualserver_port=9988 virtualserver_status=online virtualserver_clientsonline=1 virtualserver_queryclientsonline=1 virtualserver_maxclients=32 virtualserver_uptime=163 virtualserver_name=TeamSpeak\s]I[\sServer virtualserver_autostart=1 virtualserver_machine_id
    error id=0 msg=ok

    I also can't see anything of obvious use in the logs:

    2012-08-06 14:42:15.209093|INFO |ServerLibPriv | | TeamSpeak 3 Server (2012-06-29 07:59:05)
    2012-08-06 14:42:15.210070|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2012-08-06 14:42:15.210070|INFO |DatabaseQuery | | dbPlugin version: 3.7.3
    2012-08-06 14:42:15.210070|INFO |DatabaseQuery | | checking database integrity (may take a while)
    2012-08-06 14:42:15.279406|WARNING |Accounting | | Unable to find valid license key, falling back to limited functionality
    2012-08-06 14:42:15.320421|INFO |FileManager | | listening on
    2012-08-06 14:42:15.415148|INFO |CIDRManager | | updated query_ip_whitelist ips:,
    2012-08-06 14:42:15.416125|INFO |Query | | listening on

    2012-08-06 14:42:15.415148|INFO |VirtualServer | 1| listening on

    ANY help on this would be wonderful, as I'm going bananas trying to figure out what's stopping this from working :/


    I take it back entirely!

    The client isn't even connecting on the SAME machine as the server.
    I've tried both IP addresses ( and "localhost"
    and each time it's just "trying to connect to server..." - "Failed to connect to server".

    How do I find out more logging info from the client as to what happened? (or didnt)


    ok - think I've found the reason maybe?
    seems the server thinks I should be connecting on port 9987:

    06/08/2012 15:42:35 ClientUI Info Initiating connection:

    but the log (and serverquery) says the server is on 9988:

    2012-08-06 15:06:57.420960|INFO |VirtualServer | 1| listening on

    Any clue on why this occurs.. and how the heck I fix it?



    Resolved it by using this tool:

    and deleting the "default" virtual server, and manually re-creating one on the right port.

    I'd be interested to know why TS3 managed to get itself confused - anyone have some thoughts?
    Last edited by dante696; August 7th, 2012 at 09:11 AM. Reason: please edit your post, , when nobody else has replied yet.

  2. #2
    Join Date
    July 2006
    Quote Originally Posted by Esskay93 View Post
    I'd be interested to know why TS3 managed to get itself confused - anyone have some thoughts?
    On first launch the teamspeak3 server creates a virtualserver on port 9987 unless specified otherwise in server.ini. It must have been you or someone with access to your serverinstance to change this port to 9988.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: July 2nd, 2015, 12:08 AM
  2. [Resolved] Can't connect to my own server (pc works fine)
    By k0uta in forum Android
    Replies: 4
    Last Post: August 27th, 2014, 01:19 PM
  3. Replies: 4
    Last Post: July 19th, 2013, 02:07 PM
  4. [Resolved] Edit virtual server password via remote query
    By krackle in forum Server Support
    Replies: 26
    Last Post: March 25th, 2012, 03:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts