Forum

Results 1 to 2 of 2
  1. #1
    Join Date
    August 2012
    Posts
    1

    Question Creative Fatal1ty USB Headset microphone issue

    Alright, so when I plug in the headset to windows, the "on" light indicator comes on (the red light), but once I open teamspeak and try to use the microphone, it turns off. I've tried using the different capture modes in teamspeak. I've had this issue a *loong* time ago and fixed it, so I know it's possible to be fixed, just not sure how. This is on windows 7 x64.

    Appreciate any help given. This is driving me up the wall!

  2. #2
    Join Date
    June 2008
    Posts
    18,409
    Is there anything in the log?
    I guess the red light is always on or is it on, whe nthe microphone is activated? Maybe the windows sound mixer needs to configured, for this?
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Low Sound from TeamSpeak only when using Fatal1ty Headset
    By FunkyBryan in forum Client Support
    Replies: 1
    Last Post: April 3rd, 2012, 10:49 AM
  2. X-Fi Titanium Fatal1ty Champion Series FP Mic issue
    By Bayerisch.Qc in forum Windows
    Replies: 5
    Last Post: October 13th, 2010, 07:03 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •