Page 4 of 4 FirstFirst ... 234
Results 46 to 55 of 55
  1. #46
    Join Date
    October 2013
    I've been having this issue as well. I'm currently running 3.0.13. I do not use a joystick and have still been having this issue. I even have a program that forces the monitors to turn off and TS turns them back on in less than a second. So there is a bug in there by default.

    However, After reading through this forum I found that a slight modification off dante696's method worked. The way it worked for me was to go to Settings>Options>Hotkeys and then change the drop down box on the bottom right to keyboard and mouse only. Not sure why Default causes issues but at least I won't wake up to my monitors anymore due to this issue. Anyways, maybe my comment will help someone else with the same issue.

  2. #47
    Join Date
    October 2013
    I have tried this way but do not have the direct input mode all I have is Default or Keyboard , Mouse ............ It waasnt a problem till the last 2 or 3 updates of teamspeak...........

    Quote Originally Posted by dante696 View Post
    Ok i can reproduce that with my Logitech Extreme 3D Pro and Default enabled under Hotkeys.
    The problem is, that these joysticks from Logitech are to old and do not support XInput.
    I bought my jostick, when XP was the current operation system and they still sell that joystick without XInput support.

    There are only 3 workarounds:
    1. Unplug such old devices
    2. Go into Settings > Options > Hotkeys and then set Direct Input instead (Default)
    Windows will remove Direct Input and we can not say whe nthis will happen. There will be a day, when we also have to remove Direct Input support.
    3. Find a driver for that Joystick/Gamepad with Xinput support.

    I mark this thread as resolved
    There is nothing we can do here

  3. #48
    Join Date
    September 2012
    Just want to chime in here.

    First of all this IS a TEAMSPEAK BUG! Simply saying [No Bug] doesn't change that.
    Secondly, it isn't just the logitech stick that causes this, because I don't have that stick. It is either my X52 or my USB mouse doing it on my system.

    I find it very interesting that T/S has gone out of its way to ignore this issue. First they wouldn't even admit that there was an issue, then, after a USER troubleshot the problem for them and found the issue FOR THEM, they proceeded to find a way to continue to ignore it with some claptrap about direct input.

    I use TrackIR which, i'm pretty sure uses direct input and it doesn't cause me this issue, only T/S does. These developers are real pieces of work.

    One thing that I find works as a WORKABLE workaround, since T/S seems determined not to anything to fix their software, is to lock the station, (Windows + L), this allows the system to sleep after the set time and you can keep t/s running.

    Don't even get me started on the sorry implementation of server management coupled with the sorry instructions on how to do it...aaahhh teamspeak 2, how I miss you.

  4. #49
    Join Date
    June 2014
    i`ve got the same problem
    i tried everything: but the only solution to get my screensaver available is to close teamspeak

    teamspeak 3 in the last version

  5. #50
    Join Date
    February 2016
    Yes I know this thread is kinda old, but seems it's easier to post here than make a new one to be ignored.. :P

    Windows 10 - Same Issue..

    When I had Win7, no problems at all, screensaver worked, monitors switched off.. Everything was great!

    When I had Win8.1, no problems, all same as above..

    When I got Win10, the screen saver stopped working, and the monitors stayed on.. I couldn't find the issue, I just hit the power button on the monitors of I left them on overnight..

    Until.. Yesterday, when I restarted my modem, I accidently close Teamspeak, turned the modem off, when downstairs to do my dinner..

    Came back up to turn the modem back on, and hey presto, my screen saver had activated.. So I left it with the modem on, and TS not running, checked a bout 15 mins later, my monitors had gone into standby..

    So now I knew it was a Teamspeak issue, now I don't have a joystick, just a 360 controller, which I bought a couple months after GTA V came out on pc, so not that old either (and I had the issue BEFORE that anyway)..

    So I can confirm, it IS a TS issue, somehow it DOES stop the screen saver working, and monitors going into standby..

    Maybe now, they will admit it's a problem, as like the last poster, I have to close TS in order for the system to sleep, and as the owner/admin of the TS server I use, I do like to be there if I'm needed, I normally would sit in an AFK channel, so I can still get pokes/text messages.

  6. #51
    Join Date
    June 2008
    I can't reproduce what you say about Windows 10. My Screen turns of after x minutes.
    I had a wireless XBox 360 Gampead connected and tried without any connected gamepad both had the same result.

    We do not see this as no bug from our side, as long active hardware / drivers force the pc to stay on.
    Last edited by dante696; February 29th, 2016 at 10:19 AM.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  7. #52
    Join Date
    April 2012
    This is definitely a widespread issue and not isolated to a few people. There is already multiple threads in this forum alone, then with all the other forums on the Internet reporting the same, end users with different computer setups, it points to the the software itself.

    One must realize that most people affected won't sign up to a forum and post their experience and in turn they live with this bug in silence.

    I currently have this issue. I do not have any joystick installed, nor game pad for that matter.

    For my monitors not going to sleep I resolved it by changing within settings > options the hot key settings down the bottom right, selecting keyboard and mouse only (changing from default).

    Obviously this is a band aid fix as I own a joystick but just haven't pulled it out of the cupboard since setting up this new PC. Once I install it, including the software I am going to be disappointed when I can't use a hot key on it to talk to fellow clan members whilst flying a chopper for example.

    I note, as many others have, as soon as I close Team speak, all my power settings return to normal functionality. Monitors turn off and then later the computer goes to sleep. I understand if the computer won't go to sleep whilst in TS as the audio request keeps it operational but monitors should still sleep if you walk off for a period.

    I just wanted to add my 2 cents. Just because you can't replicate it doesn't mean a bug doesn't exist. This same problem happened on my old computer (windows 7 - i7 920) and now on this PC (i7 4790k) with a fresh install of windows 10.

    I just hope it gets resolved in the future as older revisions didn't have this issue. I am on version fwiw.

  8. #53
    Join Date
    November 2016
    Hello all.
    For a month I have a joystick ravcore javelin
    Unfortunately when joy is connected to the computer does not work blanking monitor
    When I disconnect joy blanking work as expected.
    It is not the fault of joy because as ts3 is off blanking also works.
    I do not know what to do, the computer I have often left turned on 24/7 and no blanking display is inconvenient for what I have to disconnect the joy when I finish playing.
    I think that this is a bug teamspek because it is the only application that is causing the problem.
    There are some advice before rozjadę USB socket from the constant plugging and unplugging joy?

    (sorry for my english used translator)

  9. #54
    Join Date
    July 2009
    Win10 screensaver Bug exists.
    To Fix choose "keyboard and mouse only" in Hotkeys (bottom right).

    To reproduce just run TS3 as Administrator.

  10. #55
    Join Date
    December 2017
    Quote Originally Posted by Ron1n View Post
    Win10 screensaver Bug exists.
    To Fix choose "keyboard and mouse only" in Hotkeys (bottom right).

    To reproduce just run TS3 as Administrator.
    THIS! Exactly this helped me to get it working again.
    Previously I had to quit teamspeak every time i wanted my displays to go into standby.

    So this DOES indeed look like it IS a teamspeak bug. I only changed this point and it suddenly worked. I cannot tell you how happy i am

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [No Bug] TS3 won't let computer go into screensaver
    By tethlah in forum Windows
    Replies: 20
    Last Post: September 3rd, 2017, 03:00 AM
  2. [Resolved] Teamspeak 3 disables my media player's global hotkeys?
    By chaosglory in forum Windows
    Replies: 0
    Last Post: April 19th, 2015, 01:41 PM
  3. All Teamspeak sound disables itself (error origin known)
    By BetaAlien in forum Bug Reports [EN/DE]
    Replies: 5
    Last Post: May 16th, 2012, 07:27 AM
  4. Stop screensaver activating
    By PirateEggs in forum General Questions
    Replies: 1
    Last Post: March 19th, 2012, 10:45 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts