Forum

Results 1 to 7 of 7
  1. #1
    Join Date
    December 2007
    Posts
    238

    Solved client does not log tsdns srv record connection fails

    Client 1.0.8.1 on Windows 7 does not log unsuccessful connections to tsdns servers, if these are offline.

    I set up a srv record with _tsdns. If the tsdns server is online, the client logs about his dns resolve and the redirect to the tsdns server and the redirect from tsdns server to ts3 server. But if the tsdns server is offline, nothing is logged about it.

    However everything is logged about _udp redirects.

  2. #2
    Join Date
    July 2006
    Posts
    1,600
    As far as I remember srv support was added in client version 3.0.8, please update to at least this version.
    If you are using the correct version and the teamspeak client still does not find your srv records then you will haver to check you dns settings including the srv records.

    Linux:
    Code:
    host -t SRV _tsdns._tcp.subdomain.yourdomain.de
    host -t SRV _ts3._udp.subdomain.yourdomain.de

  3. #3
    Join Date
    December 2007
    Posts
    238
    I am Sorry. Ofcause I have the newest Version. The DNS settings are right. Tsdns redirection works. I want to submit the Bug, that there is no Log concerning the Tsdns Server, if it is offline.

  4. #4
    Join Date
    July 2002
    Location
    Germany
    Posts
    2,192
    Hi,

    show me the log you get, the log you expect and why you expect it (similar log from _ts3. srv entry?)

  5. #5
    Join Date
    December 2007
    Posts
    238
    Hey Peter, thank you for your respond; maxi too.

    What I get, if tsdns server is online
    05.09.2012 18:43:36 ClientUI Info Connect status: Connecting
    05.09.2012 18:43:42 ClientUI Info Connect status: Disconnected
    05.09.2012 18:43:42 ClientUI Info Failed to connect to server, want autoreconnect = 0
    05.09.2012 18:45:38 ClientUI Info Connect to server: elradon.mydomain.net
    05.09.2012 18:45:38 ClientUI Info Trying to resolve elradon.mydomain.net
    05.09.2012 18:45:38 Info DNS resolve successful, "elradon.mydomain.net "=46.38.242.62
    05.09.2012 18:45:38 Info SRV DNS resolve unsuccessful for "_ts3._udp.elradon.mydomain.net"
    05.09.2012 18:45:38 Info SRV TSDNS found at "_tsdns._tcp.elradon.mydomain.net"=>"my-tsdns-server.net:41144" and queried successfully. Result: my-teamspeak-server.net:9987
    05.09.2012 18:45:38 ClientUI Info Lookup finished: my-teamspeak-server.net 9987 elradon.mydomain.net 1 0
    05.09.2012 18:45:38 ClientUI Info Resolve successful: my-teamspeak-server.net:9987
    05.09.2012 18:45:38 ClientUI Info Blacklist check ok
    05.09.2012 18:45:38 ClientUI Info Initiating connection: my-teamspeak-server.net:9987 elradon.mydomain.net
    05.09.2012 18:45:38 ClientUI Info Connect status: Connecting
    05.09.2012 18:45:38 ClientUI Info Connect status: Connected
    05.09.2012 18:45:38 ClientUI Info Connect status: Establishing connection
    05.09.2012 18:45:38 ClientUI Info Connect status: Connection established
    05.09.2012 18:45:39 Info DNS resolve successful, "blacklist.teamspeak.com"=80.190.225.139
    What I get, if I stop the tsdns server
    05.09.2012 18:47:55 ClientUI Info Connect to server: elradon.mydomain.net
    05.09.2012 18:47:55 ClientUI Info Connect status: Disconnected
    05.09.2012 18:47:55 ClientUI Info Disconnected or forced to leave, want autoreconnect = 0
    05.09.2012 18:47:55 ClientUI Info Connecting to next server...
    05.09.2012 18:47:55 ClientUI Info Connect to server: elradon.mydomain.net
    05.09.2012 18:47:55 ClientUI Info Trying to resolve elradon.mydomain.net
    05.09.2012 18:47:55 Info SRV DNS resolve unsuccessful for "_ts3._udp.elradon.mydomain.net"
    05.09.2012 18:47:55 Info DNS resolve successful, "elradon.mydomain.net"=46.38.242.62
    05.09.2012 18:47:56 ClientUI Info Lookup finished: 46.38.242.62 9987 elradon.mydomain.net 0 0
    05.09.2012 18:47:56 ClientUI Info Resolve successful: 46.38.242.62:9987
    05.09.2012 18:47:56 ClientUI Info Blacklist check ok
    05.09.2012 18:47:56 ClientUI Info Initiating connection: 46.38.242.62:9987 elradon.mydomain.net
    05.09.2012 18:47:56 Info DNS resolve successful, "blacklist.teamspeak.com"=80.190.225.139
    05.09.2012 18:47:56 ClientUI Info Connect status: Connecting
    What I think is missing:
    05.09.2012 18:47:55 Info SRV TSDNS unsuccessfull for "_tsdns._tcp.elradon.mydomain.net"
    OR
    05.09.2012 18:45:38 Info SRV TSDNS found at "_tsdns._tcp.elradon.mydomain.net"=>"my-tsdns-server.net:41144" and queried unsuccessfully. Result: no result.
    05.09.2012 18:45:39 Info SRV TSDNS found at "_tsdns._tcp.elradon.mydomain.net"=>"my-tsdns-server-second-one.net:41144" and queried successfully. Result: my-teamspeak-server.net:9987
    I came to this "problem", because I am experimenting with using not only one, but two tsdns server. But testing the system is bit complicated without these "type" of log.

    Why I expect these logs? For _udp this "type" of log is shown:
    05.09.2012 18:45:38 Info SRV DNS resolve unsuccessful for "_ts3._udp.elradon.mydomain.net"

  6. #6
    Join Date
    July 2002
    Location
    Germany
    Posts
    2,192
    Some more logging added for cases where a tsdns srv record exists but the tsdns server at the specified address can't be queried.
    You think my answer is stupid ? Read This:
    http://www.catb.org/~esr/faqs/smart-...ons.html#intro

    In a world without fences and walls - who needs windows and gates ?

  7. #7
    Join Date
    December 2007
    Posts
    238
    Hey Peter,

    thank you for building this in. I am sure it will help people set up their tsdns servers. At least it will help me

    I am glad to get the new client - waiting on betachannel.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. TsDNS A Record help.
    By mgalahub in forum Linux / FreeBSD
    Replies: 3
    Last Post: September 9th, 2014, 02:47 PM
  2. [Evaluation] Client resolves tries to find TSDNS SRV-RR and finds Catch-All-IN-Record
    By maxi1990 in forum Bug Reports [EN/DE]
    Replies: 2
    Last Post: March 4th, 2014, 03:44 PM
  3. Replies: 2
    Last Post: September 11th, 2013, 09:30 AM
  4. Replies: 0
    Last Post: August 4th, 2013, 01:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •