Forum

Results 1 to 9 of 9
  1. #1
    Join Date
    October 2012
    Posts
    6

    Solved Fedora 17 - Teamspeak 3 Issues

    I've been google'ing away for about 4 hours now and I haven't found anything. I've tried every solution I could find and none of them have worked. Here's my problem - when I try to run the ts3 start script from the terminal, I get this error:

    ./ts3client_linux_x86: symbol lookup error: /usr/lib/libQtGui.so.4: undefined symbol: _ZN23QCoreApplicationPrivate19app_compile_versionE


    Can anyone help me?

  2. #2
    Join Date
    September 2012
    Posts
    6,080
    What client version are you trying to use?
    Read the following thread too, maybe it can help you:
    http://forum.teamspeak.com/showthread.php/64697

  3. #3
    Join Date
    October 2012
    Posts
    6
    Thank you for the reply - I saw that thread earlier. The problem is I can't even launch teamspeak, it's when I try to launch it in terminal I got the aforementioned error. Also - I'm running the latest Linux version.

  4. #4
    Join Date
    September 2012
    Posts
    6,080
    I just noticed you are attempting to launch the binary directly. You have to start the client by executing the ts3client_runscript.sh file instead of directly running the binary.

    If you are still getting errors post output of ldd ts3client_linux_x86

  5. #5
    Join Date
    October 2012
    Posts
    6
    I've been using the .sh all along. Here's the output of ldd

    linux-gate.so.1 => (0x00534000)
    libQtCore.so.4 => /usr/lib/qt47/libQtCore.so.4 (0x001b6000)
    libQtGui.so.4 => /usr/lib/libQtGui.so.4 (0x00765000)
    libQtNetwork.so.4 => /usr/lib/qt47/libQtNetwork.so.4 (0x00535000)
    libresolv.so.2 => /usr/lib/libresolv.so.2 (0x00440000)
    librt.so.1 => /usr/lib/librt.so.1 (0x00459000)
    libdl.so.2 => /usr/lib/libdl.so.2 (0x00462000)
    libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00467000)
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00659000)
    libm.so.6 => /usr/lib/libm.so.6 (0x00481000)
    libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x004ac000)
    libc.so.6 => /usr/lib/libc.so.6 (0x188ed000)
    libz.so.1 => /usr/lib/libz.so.1 (0x004c9000)
    libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0x004df000)
    libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x10207000)
    libpng15.so.15 => /usr/lib/libpng15.so.15 (0x450a4000)
    libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x44eb1000)
    libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x004e2000)
    libSM.so.6 => /usr/lib/libSM.so.6 (0x461a5000)
    libICE.so.6 => /usr/lib/libICE.so.6 (0x461b0000)
    libXi.so.6 => /usr/lib/libXi.so.6 (0x4510a000)
    libXrender.so.1 => /usr/lib/libXrender.so.1 (0x44e1d000)
    libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0x44e7b000)
    libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x452fb000)
    libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x4535e000)
    libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0x44e75000)
    libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x18586000)
    libXext.so.6 => /usr/lib/libXext.so.6 (0x44e09000)
    libX11.so.6 => /usr/lib/libX11.so.6 (0x0f5cc000)
    libssl.so.10 => /usr/lib/libssl.so.10 (0x1e290000)
    libcrypto.so.10 => /usr/lib/libcrypto.so.10 (0x12618000)
    /lib/ld-linux.so.2 (0x00744000)
    libffi.so.5 => /usr/lib/libffi.so.5 (0x44ac5000)
    libuuid.so.1 => /usr/lib/libuuid.so.1 (0x11f00000)
    libexpat.so.1 => /usr/lib/libexpat.so.1 (0x44e86000)
    libxcb.so.1 => /usr/lib/libxcb.so.1 (0x174fa000)
    libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0x0df49000)
    libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0x04c1b000)
    libcom_err.so.2 => /usr/lib/libcom_err.so.2 (0x0c7f1000)
    libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0x05ceb000)
    libXau.so.6 => /usr/lib/libXau.so.6 (0x44caa000)
    libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0x20ba3000)
    libkeyutils.so.1 => /usr/lib/libkeyutils.so.1 (0x46002000)
    libselinux.so.1 => /usr/lib/libselinux.so.1 (0x44943000)
    Last edited by Varren; October 18th, 2012 at 07:37 PM.

  6. #6
    Join Date
    September 2012
    Posts
    6,080
    The client for some reason is using the wrong Qt Libraries.
    If you are using the runscript.sh this should usually not happen, as there is a line in there that says
    Code:
    export LD_LIBRARY_PATH=".:$LD_LIBRARY_PATH"
    to make sure that it loads the Qt Libraries from the TeamSpeak client folder.

  7. #7
    Join Date
    October 2012
    Posts
    6
    Any suggestions on what I should do next?

  8. #8
    Join Date
    September 2012
    Posts
    6,080
    Code:
    export LD_LIBRARY_PATH="."
    ./ts3client_runscript.sh

  9. #9
    Join Date
    October 2012
    Posts
    6
    Fixed - thank you! I edited the .sh in gedit too.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fedora 17 install - libpng12.so.0 issues
    By KroniK907 in forum Linux
    Replies: 1
    Last Post: October 28th, 2013, 03:19 AM
  2. Installing teamspeak 3 on Fedora 14
    By itsonme in forum Linux
    Replies: 7
    Last Post: May 27th, 2011, 07:26 PM
  3. installing teamspeak 3 client on fedora
    By itsonme in forum Linux
    Replies: 5
    Last Post: April 24th, 2011, 09:28 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •