Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 7 of 7
  1. #1
    Join Date
    October 2012
    Posts
    7

    Teamspeak3 server is intermittently unavailable

    While I can always connect as localhost, sometimes I cannot connect via the Internet. Everything worked well Tuesday night of this week, but on Wednesday, and now today, neither myself nor my friends can connect to the TS3 server. I can ping the WAN IP, so there is no problem there. In the past I've been able to re-boot my server PC, but that has stopped working. From the log file I am seeing an error message "WARNING | Accounting | | Unable to find valid license key, falling back to limited functionality." But my understanding is that TS3 is free and I do not need to buy a license? I saw an old thread on this topic but I can't even find a licensekey.dat file, so I'm not sure if that is the issue.

    Any help would be much appreciated.

    TS version 3.0.6.1
    Windows Vista Ultimate (6.0, Build 6002)
    Sound card is integrated on an Asus P6T motherboard, HdAudio.sys driver
    DirectX 11
    The error message is simply "Failed to connect to server."

  2. #2
    Join Date
    October 2012
    Posts
    7
    I keep seeing suggestions regarding the ts3server.ini and licensekey.dat files, but I cannot find those files. Where do they typically reside?

  3. #3
    Join Date
    September 2012
    Posts
    6,079
    They don't exist in the first place by default.
    Also that line about the missing licensekey is just a warning that informs you the server is running with limited functionality, it is not an error and the server will work fine without a licensekey.

    As for your problem, please make sure that your server machine still has the same internal ip address and that the port forwarding rules in the router are still accurate.

  4. #4
    Join Date
    October 2012
    Posts
    7
    OK, I need even more help-where do I check on the internal ip address? I think the router port forwarding is still working (and again, everything was fine on Tuesday night):

    Allowed Applications Application Type Protocol Port Number(s) Public IP
    TS10011 - TCP 10011
    99.179.165.152
    TS30033 - TCP 30033
    99.179.165.152
    TS9987 - UDP 9987
    99.179.165.152

    Thanks,

    Todd

  5. #5
    Join Date
    October 2012
    Posts
    7
    I'm now having the same issue on my Windows 7 machine. Rebooting sometimes works, but is there any way I can avoid this? You said it's not an error, but no one coming in from the Internet can connect to the server if it's in "limited functionality" mode. So essentially it doesn't work. How can I avoid having the license key not detected which causes the server to revert to this limited functionality mode?

    Thanks again for your help.

  6. #6
    Join Date
    January 2010
    Location
    El Prat de Llobregat (Barcelona, Spain)
    Posts
    2,698
    Quote Originally Posted by Todd S. View Post
    I'm now having the same issue on my Windows 7 machine. Rebooting sometimes works, but is there any way I can avoid this? You said it's not an error, but no one coming in from the Internet can connect to the server if it's in "limited functionality" mode. So essentially it doesn't work. How can I avoid having the license key not detected which causes the server to revert to this limited functionality mode?
    This warning appears when your are using the server as is, without any license, that allows 32 slots.
    Code:
    2012-12-08 10:56:07.985938|INFO    |ServerLibPriv |   | TeamSpeak 3 Server 3.0.6.1 (2012-06-29 07:59:05)
    2012-12-08 10:56:08.215938|INFO    |DatabaseQuery |   | dbPlugin name:    SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2012-12-08 10:56:08.215938|INFO    |DatabaseQuery |   | dbPlugin version: 3.7.3
    2012-12-08 10:56:08.230938|INFO    |DatabaseQuery |   | checking database integrity (may take a while)
    2012-12-08 10:56:08.349938|WARNING |Accounting    |   | Unable to find valid license key, falling back to limited functionality
    2012-12-08 10:56:08.533938|INFO    |FileManager   |   | listening on 0.0.0.0:30033
    2012-12-08 10:56:08.534938|INFO    |VirtualSvrMgr |   | executing monthly interval
    2012-12-08 10:56:08.583938|INFO    |VirtualSvrMgr |   | reset virtualserver traffic statistics
    2012-12-08 10:56:08.901938|INFO    |CIDRManager   |   | updated query_ip_whitelist ips: 127.0.0.1, 
    2012-12-08 10:56:08.903938|INFO    |Query         |   | listening on 0.0.0.0:10011
    2012-12-08 10:56:26.104938|INFO    |GetWanIP      |   | WAN ip: ---.---.---.---
    The limited functionallity points to the allowed number of slots, limited to 32, but this doesn't mean people can't connect.

    If people from internet can't connect that uses to be a port-forwarding issue. Please, verify that Chris said in post #3:
    make sure that your server machine still has the same internal ip address and that the port forwarding rules in the router are still accurate. Also, the server must have a static local IP or if it is automatic the router must assign it always the same local IP using the PC's MAC address.

    Also, important, in the router port 9987 --> UDP only

    It's supposed your PC only have an IP.

    And if the portforwarding is correct but your router has firewall try to deactivate it. Usually the router firewall has rules or options related with 'flood' or DoS that limit the UDP traffic.

  7. #7
    Join Date
    October 2012
    Posts
    7
    Thank you. I investigated further regarding the port forwarding and there seems to be an issue with a phantom entry on my router. Therefore, I have determined this is on my end and I need to contact AT&T Uverse for support (God help me).

    This request for further help is withdrawn. I appreciate you guys taking the time to help. (But I have a new issue to post on the client side.)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: September 1st, 2014, 08:38 PM
  2. Replies: 4
    Last Post: March 5th, 2013, 03:43 PM
  3. Server Query Group perms unavailable
    By Heliguy in forum Permission System
    Replies: 0
    Last Post: November 24th, 2010, 11:54 AM
  4. Server process intermittently showing with top
    By JakkFrosted in forum Linux / FreeBSD
    Replies: 2
    Last Post: December 27th, 2009, 12:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •