Forum

Results 1 to 10 of 10
  1. #1
    Join Date
    October 2012
    Posts
    2

    Teamspeak stops recognizing push to talk key when I go into any game/steamwindow

    I have had this issue come up only a little bit ago (seems after the last client update). But I use CAPS LOCK as my push to talk key and I have for the past 6 years. All of a sudden now TS does not recognize me pressing that (or any other) button if I open a game like Mechwarrior Online (even before a match) or even just the steam window. It works in the League of Legends client (before a match) and works fine while i'm in chrome. Also works fine while I have teamspeak open obviously, but anything else and it stops. It also works fine if I put on voice activation all round, but I can't be the only one having this issue. I read a previous thread here where it was an issue with the identities but that didn't seem to fix it at all.

  2. #2
    Join Date
    October 2012
    Location
    New Jersey, USA
    Posts
    6
    McSniffles, I found a work around to work for me. Run your TeamSpeak client as Administrator. Right click on the application or shortcut and Run as Administrator. That seemed to have worked for me running Windows 7. Hopefully that works for you

  3. #3
    Join Date
    October 2012
    Posts
    1

    Unable to do in game chat.

    This started happening yesterday after the update. I am no longer able to chat with clan members while I am in game. The chat only works if I have the TS program open on my screen. Whenever I go off of the application like into a game or into another program my PTT key no longer works. I have not changed any settings in my TS or my game. What could this be?

  4. #4
    Join Date
    September 2012
    Posts
    6,079
    I cannot reproduce this, hotkeys work in any application.
    Try the different options for the hotkey detection in settings -> options -> hotkeys above the apply button.

  5. #5
    Join Date
    June 2012
    Posts
    3

    Angry Dear Me

    Quote Originally Posted by Chris View Post
    I cannot reproduce this, hotkeys work in any application.
    Try the different options for the hotkey detection in settings -> options -> hotkeys above the apply button.
    That is not an answer, that is a bull excuse. if you get reports from multiple people, you have to ask how to reproduce the problem so you can identify it.
    In my Group, Every single person who upgraded to this version has 2 problems,
    1: There original privledges are gone, and I have to reset them. and
    2: They can not talk while in game..

    For helpful information.
    I use a Mac, and no problem so far.
    All are using Windows 7.
    We are all using World of Tanks for our Game.

    Hope this helps, and no more escuses please.

    Regards
    Cyberience

  6. #6
    Join Date
    October 2012
    Posts
    2
    Quote Originally Posted by Chris View Post
    I cannot reproduce this, hotkeys work in any application.
    Try the different options for the hotkey detection in settings -> options -> hotkeys above the apply button.
    Start an Application with an Admin Account (some Games sadly force you to use it)
    Start Ts3 as a normal User, this way you can reproduce it.

    (Win7-64Bit)

  7. #7
    Join Date
    October 2012
    Posts
    2
    Quote Originally Posted by RjaKotari View Post
    McSniffles, I found a work around to work for me. Run your TeamSpeak client as Administrator. Right click on the application or shortcut and Run as Administrator. That seemed to have worked for me running Windows 7. Hopefully that works for you
    This seemed to work. I just used the start menu to open ts and ran it as an administrator, that seemed to work. Thanks!

  8. #8
    Join Date
    October 2012
    Location
    New Jersey, USA
    Posts
    6
    No problem Glad it worked, hopefully the TS Team will find a proper fix for the issue in the meantime.

  9. #9
    Join Date
    September 2012
    Posts
    6,079
    Quote Originally Posted by SoonMumbleUser View Post
    Start an Application with an Admin Account (some Games sadly force you to use it)
    Start Ts3 as a normal User, this way you can reproduce it.

    (Win7-64Bit)
    This doesn't work since Windows doesn't delegate the key presses to non-elevated processes if an application that runs elevated has the focus.

  10. #10
    Join Date
    November 2012
    Posts
    1
    Quote Originally Posted by Chris View Post
    This doesn't work since Windows doesn't delegate the key presses to non-elevated processes if an application that runs elevated has the focus.
    That's the only way I can get TS to work with MWO on my PC (Win8-64Bit). Once I turn off 'run as administrator', it stops working with MWO.

    [edit]
    Nevermind. I see that this has already been addressed.
    Last edited by Spookymonster; November 26th, 2012 at 05:39 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. TS3 Stops recognizing hotkeys after shortwhile
    By ShinKuma in forum Windows
    Replies: 0
    Last Post: October 28th, 2014, 02:24 AM
  2. Push-To-Talk Randomly Stops Working
    By sprintcupfan24 in forum Client Support
    Replies: 0
    Last Post: April 30th, 2014, 05:28 AM
  3. Push-To-Talk randomly stops responding.
    By Celebrim in forum Client Support
    Replies: 1
    Last Post: May 23rd, 2011, 01:11 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •