Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Page 3 of 3 FirstFirst 123
Results 31 to 33 of 33
  1. #31
    Join Date
    December 2012
    I tried the solution quoted and still no joy. Of course the shop wont take back the brand new logitech USB headset, so I am completely stumped. I think this is a teamspeak problem as it can detect the logiotech equipment it just can't work with it.

    Quote Originally Posted by Astraa View Post

    I had the same issue as you have, I have solved mine by booting into windows 8 in safe mode and installing TS from their with admin rights.

    I firmly believe its to do with the security levels now in Windows 8 at default installations, because with the UAC on normal and the other checks it does, it prevents this from being run.

    Installing runtime libraries
    Execute: C:\Users\name\AppData\Local\Temp\nspBECD.tmp\vcred ist_x86.exe /q:a /c:"msiexec /i vcredist.msi /qn"

    Everything before that is in the TS directory but installing runtime libraries is in windows direct, so it makes sense that the windows protection did not let it and you don't see this because of the command line used, if im not mistaken "/qn" means "quite no report"

    I could be wrong, but mine now works fine. I also installed in on my other machine which uses a Plantronics BT Headset same result, under normal install it would not pick up that ANY sound device was there, sure it would show it but not activate it, until I went into Safe Mode and installs with admin rights, now it works also.

    I hope this works for others and that if it is the issue at hand that the TS developers sort it out for us all

  2. #32
    Join Date
    January 2013
    In playback devices right click on the headset. Click properties. Click advanced. Set to 16bit (FM Radio Quality). this fixed all the problems for me

  3. #33
    Join Date
    January 2013
    I have the Afterglow wireless headset and I dont get any sound when its plugged in but games and everything else i get sound.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 12
    Last Post: July 26th, 2019, 09:58 PM
  2. Windows: Bluetooth headset kills all sound
    By DumSkidderik in forum Windows
    Replies: 0
    Last Post: September 11th, 2014, 10:03 PM
  3. Replies: 6
    Last Post: August 15th, 2013, 08:38 PM
  4. Low Sound from TeamSpeak only when using Fatal1ty Headset
    By FunkyBryan in forum Client Support
    Replies: 1
    Last Post: April 3rd, 2012, 09:49 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts