Forum

Results 1 to 6 of 6
  1. #1
    Join Date
    November 2012
    Posts
    4

    Having to switch playback devices in options menu

    Hello,

    I have had this issue for many many months:

    I currently have and xfi fatality sound card installed and running windows 7 64 bit. The issue? If i open ts3 and run it before i open my browser/ game it mutes the game and sound. For example I can still play in game but with no sound and hear my clanmates in ts3 when they speak. I can also watch the youtube videos etc but without any sound. All my drivers are up to date.


    I have done some troubleshooting of my own and the default settings do not work. I can leave playback mode as automatically find best one. I have 3 options for playback device:

    default
    SPDIF OUT (2-CREATIVE SB XFI)
    SPEAKERS (2-CREATIVE SB XFI)

    I found that I can launch my game/ internet browser (doesnt matter i have tried with all and other games and still have the issue) I can hear my clanmates in ts3 speaking when my playback device is SPEAKERS (2-creative sb xfi) but the game will launch without sound. If i launch the game while i have the playback device as SPDIF OUT (2-screative sb xfi) then I will have sound in game but cannot hear my clanmates until i switch the playback device back to SPEAKERS. Although my clanmates can still hear me.

    Another bug I found is that I will have my playback device as SPEAKERS (2-creative sb xfi) and I will click on play sound test feature and it will not play until i switch to a different channel.

    any help is greatly appreciated.... its been driving me crazy the past few months.

    update:

    i went into sound options for windows 7 and disabled the SPDIF OUT feature, still having issues though.. after some more trouble shooting i click on the play test sound and still wont hear it until I change channels then it will play at the same time as "switched channels" is said.
    Last edited by Chris; November 27th, 2012 at 09:54 AM.

  2. #2
    Join Date
    November 2012
    Posts
    4
    so now everytime i launch ts3, after opening it initially i have to change my playback device before launching my game/youtube/browser for it to not mute my sound.

  3. #3
    Join Date
    September 2012
    Posts
    6,079
    Try and disable all the plugins in your TeamSpeak client and make sure your windows sound settings are properly configured.
    You might want to disable the "Applications can take exclusive control" checkbox and make sure TeamSpeak uses specified devices instead of the defaults.

  4. #4
    Join Date
    November 2012
    Posts
    4
    did all that specified and still having the same issue.

  5. #5
    Join Date
    September 2012
    Posts
    6,079
    If you disabled the exclusive control in windows and games are still muted then there is most likely something wrong in the driver settings somewhere...

  6. #6
    Join Date
    November 2012
    Posts
    4
    roger, i will continue to trouble shoot and look into the drivers.. thanks again..will post when i find the issue

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Failed to use playback / capture devices
    By KayJay in forum General Questions
    Replies: 0
    Last Post: July 15th, 2013, 04:52 PM
  2. Can't change Playback and Capture devices in TS3
    By kaszak696 in forum Client Support
    Replies: 0
    Last Post: August 4th, 2010, 08:42 PM
  3. Invalid playback/input devices?
    By Lodestone in forum Client Support
    Replies: 6
    Last Post: January 23rd, 2010, 08:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •