Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 7 of 7
  1. #1
    Join Date
    November 2012
    Posts
    7

    Server iptables issue need help pls

    client can't connect to port 9987 of the server with iptables running.

    Server is on CentOS

    anyhelp on this would be appreciated thank.

    Getting this error on the server:

    TS3ANetwork::Send failed error: 1" from the server console when trying to connect

  2. #2
    Join Date
    November 2012
    Posts
    7
    This is web server and dns server any help would be great,

  3. #3
    Join Date
    September 2012
    Posts
    6,079
    If all ports are dropped by default in your configuration you need to open the required TeamSpeak Ports. Google should be able to help you out on how to open ports in iptables.

  4. #4
    Join Date
    November 2012
    Posts
    7
    Quote Originally Posted by cat /etc/sysconfig/iptables | grep -P '9987|30033|10011|2010|41144|2008'
    -A INPUT -p tcp -m tcp --dport 10011 -j ACCEPT
    -A INPUT -p tcp -m tcp --dport 41144 -j ACCEPT
    -A INPUT -p tcp -m tcp --dport 30033 -j ACCEPT
    -A INPUT -p tcp -m tcp --dport 10011 -j ACCEPT
    -A INPUT -p udp -m udp --dport 9987 -j ACCEPT
    -A OUTPUT -p tcp -m tcp --dport 2008 -j ACCEPT
    -A OUTPUT -p udp -m udp --dport 2010 -j ACCEPT
    The ports are all open, but the client is crashing when I try to connect now.

    I can telnet into the serverquery and filetransfer ports with no problem. The server completes the accounting process as well so we can scratch 2008 off the list. We aren't using TSDNS, so scratch that one off. There are no clients connecting to the weblist port, and that is second-priority at the moment anyway. The only port acting up here is 9987.

  5. #5
    Join Date
    September 2012
    Posts
    6,079
    Maybe your provider blocks UDP traffic, or limits it?
    Also if the client crashed please upload any crash dumps in a zip file to this thread

  6. #6
    Join Date
    November 2012
    Posts
    7
    Quote Originally Posted by Chris View Post
    Maybe your provider blocks UDP traffic, or limits it?
    Also if the client crashed please upload any crash dumps in a zip file to this thread
    its not the provider as turning off the iptables lets it work.

  7. #7
    Join Date
    November 2012
    Posts
    7
    The issue turned out to be CSF, which was installed with WHM. Following the directions at http://sachinpradeeplinux.wordpress....s-rule-to-csf/ I made /etc/csf/csfpre.sh.

    Code:
    #!/bin/sh
    iptables -A INPUT -p tcp -m tcp --dport 10011 -j ACCEPT 
    iptables -A INPUT -p tcp -m tcp --dport 41144 -j ACCEPT 
    iptables -A INPUT -p tcp -m tcp --dport 30033 -j ACCEPT 
    iptables -A INPUT -p tcp -m tcp --dport 10011 -j ACCEPT 
    iptables -A INPUT -p udp -m udp --dport 9987 -j ACCEPT 
    iptables -A OUTPUT -p tcp -m tcp --dport 2008 -j ACCEPT 
    iptables -A OUTPUT -p udp -m udp --dport 2010 -j ACCEPT

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. iptables settings for linux server
    By Munday in forum Linux / FreeBSD
    Replies: 7
    Last Post: October 22nd, 2013, 08:13 PM
  2. Replies: 3
    Last Post: November 27th, 2012, 12:15 PM
  3. Iptables udp 9987
    By BitUnique in forum Linux / FreeBSD
    Replies: 2
    Last Post: February 9th, 2010, 04:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •