Forum

Page 1 of 8 123 ... LastLast
Results 1 to 15 of 114
  1. #1
    Join Date
    September 2011
    Posts
    1

    Error - Failed to convert string nan to float

    Read THIS before posting and reading!!
    Posts without answers will be ignored from now on...



    Hi there,

    Here it is ... I have just update my TS 3 and i can't connect to any server... it says : Failed to convert string nan to float

    I have a Windows 7 - 64 bit
    I would appreciate some help from you guys, cause im out of ideas.. ty a lot
    Last edited by dante696; July 4th, 2014 at 07:22 AM.

  2. #2
    Join Date
    June 2008
    Posts
    18,151
    What client did you use before the update?
    Where do you get that message??
    Can you connect?
    What Plugins do you use?
    What are your device names under Settings > Options > Capture/Playback?
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    January 2012
    Posts
    2

    Post Failed to convert string to float nan

    Hello I'm french
    My team speak no longer works there are marked Failed to convert string to float nan I demende to tell me how to fix it thank you and goodbye.

    http://img812.imageshack.us/img812/4114/capturecjw.png

    *** Thread Merged ***
    Last edited by MiNiGreg13; January 22nd, 2012 at 10:45 AM.

  4. #4
    Join Date
    May 2010
    Posts
    6,310
    Hello

    Please answer to the dante696's questions.

  5. #5
    Join Date
    January 2012
    Posts
    2
    Never done it to me for 1 year after the fact that I connect to a server
    My devices are audio windows session then down internal microphone push-to-talk

  6. #6
    Join Date
    December 2012
    Posts
    5

    Error - Failed to convert string nan to float

    Hello!

    I have just downloaded the 64 bit version of the Teamspeak 3 Client and every time I try to connect to any server the client crashes and I get an error message saying: "Failed to convert string nan to float". Since I have no idea what that means I could really use your help!
    Thanks in advance!

  7. #7
    Join Date
    June 2008
    Posts
    18,151
    Can you show us the client log, when it happens?
    I'ts to hard to say, where it does crash for you.

    This is the path for the log folder
    Code:
    %appdata%\TS3Client
    Last edited by dante696; December 18th, 2012 at 07:27 AM.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  8. #8
    Join Date
    December 2012
    Posts
    5
    Here is the log as you requested!
    Attached Files Attached Files

  9. #9
    Join Date
    June 2008
    Posts
    18,151
    Thank you and what audio device do you use and does your client auto connect on start to one or more servers?
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  10. #10
    Join Date
    December 2012
    Posts
    5
    I use an ordinary headset and no my client does not auto connect to any server on start!

  11. #11
    Join Date
    June 2008
    Posts
    18,151
    But this headset is connected to a soundcard. This soundcard has a device name Or even an USB headset has a name?
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  12. #12
    Join Date
    December 2012
    Posts
    5
    I use a Realtek High Definition Audio Controller and a Creative Draco HS-850 Headset! Hope this helps

  13. #13
    Join Date
    June 2008
    Posts
    18,151
    More informations always help to understand your situation.
    One last question, is your driver Up-to-date?

    This is the latest driver: "Realtek High Definition Audio Driver R2.70"
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  14. #14
    Join Date
    December 2012
    Posts
    5
    It now is, didn't help though!

  15. #15
    Join Date
    June 2008
    Posts
    18,151
    I had a small conversation with our developers about your problem. But it's still not clear where it is coming from.

    We need to know What hapens:
    1. when you connect to the server without a capture or/and playback profile
    1.1. Please open your bookmark manager and press more. Now set your capture profile to none, then apply and connect to the server.
    1.2. Repeat the step and set your playback profile to none and then connect to a server.

    2. when you enable both profiles and try to change your capture and playback mode under Settings > Options > Playback/Capture
    2.1 Connect once with Direct Sound set
    2.2 Connect once with Windows Audio Session set

    3. What is your capture and playback setting in Windows itself?
    Right-click the speaker icon in your tray -> on playback devices
    Click image for larger version. 

Name:	playback.png 
Views:	1866 
Size:	77.2 KB 
ID:	7251
    Now double-click your active speaker and change to tab "advanced"
    Click image for larger version. 

Name:	playback2.png 
Views:	3343 
Size:	104.7 KB 
ID:	7248

    3.1. Repeat step 3 with your active recording device and tell us the settings.

    4. when you start your client without any configuration?
    Open %appdata%/TS3Client and then rename the file called settings.db to backup.db.
    Now start the client and try to connect to a server.
    Click image for larger version. 

Name:	appdata.png 
Views:	1277 
Size:	27.7 KB 
ID:	7250
    Last edited by dante696; December 19th, 2012 at 03:37 PM.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •