Forum

Page 3 of 5 FirstFirst 12345 LastLast
Results 31 to 45 of 69
  1. #31
    Join Date
    November 2012
    Posts
    7

    Can't bind mouse (4,5,6,7,8,9...) buttons

    Alright, so I'm a dual booter, and an avid TeamSpeak user. In my Windows partition, I use my front side button (browser forward) as my push to talk. it's out of the way, my hand is always on it, and it's not too often that I've just gone back on my browser so it would mess me up.

    So I installed Ubuntu again the other day and installed TeamSpeak 3 and tried to set it up, and I simply cannot use my side buttons as push to talk. I can in Mumble, and they take me forward and back in my broswer, but in the TeamSpeak window, I click to bind PTT button, and it just will not recognize them.

    Is there a way for me to personally fix this? if not, I'd LOVE to see an update to add this funcionality.

    Also, as a side note, please get TeamSpeak 3 in the Ubuntu Software Center. Or at the very least, give us a PPA.
    Last edited by iBurley; September 22nd, 2014 at 01:10 AM.

  2. #32
    Join Date
    November 2012
    Posts
    7
    Why so many views and no comments? Somebody has to know something about this!

  3. #33
    Join Date
    March 2013
    Posts
    3
    I have same problem.
    Ubuntu 12.10
    Mouse: A4TECH XL-760H (Mouse 3, Mouse 4 doesn't work)

    Version of TS3:
    3.0.10 (27.2.13 16:08) [Stable] on Linux

  4. #34
    Join Date
    November 2009
    Location
    No
    Posts
    37
    Sorry for the necro, but this seemed to be the most relevant thread after searching around and then seeing an actual TS3 team member requesting information -

    I'd love to get the other mouse buttons working, as they all work fine in other applications on my system. Since someone already mentioned above a place to view some code, here is my attempt at finding something useful. Mumble currently handles this without an issue, so their approach might be worth looking at. Not sure if this particular file is relevant, but here it is:

    https://github.com/mumble-voip/mumbl...rtcut_unix.cpp

    Obviously I'm not advocating copying anyone elses work, but looking at how similar projects approach certain things can be very educational.

  5. #35
    Join Date
    May 2013
    Posts
    1

    Mouse 4 / Mouse 5 not working.

    Hey.

    I did some search on this, I only found some 2-3 years topics which said that this is tried to be fixed, but never managed to fix it. Is there anyway to get them work? At least mine doesn't work, (Logitech G400). The buttons work fine on Mumble, so they should work at least. Someone mentioned somewhere some "btnx", but apparently that didn't help anyone so I didn't bother to search for it.

    so: does anyone know if theres a way to get them work?

    I'm running Ubuntu 12.10 64 Bit, TeamSpeak 3.0.10.1.

  6. #36
    Join Date
    May 2013
    Posts
    5
    It's doesn't matter which mouse button u try to assign, if there is higher than MOUSE BUTTON 3 it doesn't work. Why? I don't know - probably not implemented or just blocked. My mouse work perfectly using all wheels and buttons except TeamSpeak (linux amd64 ver 3.0.10.1). For developers: PLEASE, FIX IT.

    I think that everyone has the same problem. PLEASE DEVELOPERS FIX IT.

    I've tried to force TS (amd64, 3.0.10.1, linux) to work "push-to-talk" with MOUSE BUTTON 5, but in my opinion it disabled, or unimplemented yet. I think it's a bug, because the same TS under w7 work with the same mouse and mouse works perfectly (side buttons) under every other application under Linux.
    Last edited by Chris; May 27th, 2013 at 08:35 AM.

  7. #37
    Join Date
    September 2012
    Posts
    6,079
    We'll look into this.

  8. #38
    Join Date
    June 2013
    Posts
    1
    my left ctrl dont work to bind to anymore what shuld i do?

  9. #39
    Join Date
    March 2013
    Posts
    3
    How it looks so far? I'd like to help.

    Having the latest version of Pulseaudio (4.0), Ubuntu 13.04.

    I having this problem only on TS, 'cos on Mumble mouse side buttons working as well.

  10. #40
    Join Date
    September 2012
    Posts
    6,079
    If there is anything new to report we would update this thread.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  11. #41
    Join Date
    May 2013
    Posts
    5
    Any progress?

  12. #42
    Join Date
    August 2013
    Posts
    1
    Quote Originally Posted by jesepi View Post
    Sorry for the necro, but this seemed to be the most relevant thread after searching around and then seeing an actual TS3 team member requesting information -

    I'd love to get the other mouse buttons working, as they all work fine in other applications on my system. Since someone already mentioned above a place to view some code, here is my attempt at finding something useful. Mumble currently handles this without an issue, so their approach might be worth looking at. Not sure if this particular file is relevant, but here it is:

    https://github.com/mumble-voip/mumbl...rtcut_unix.cpp

    Obviously I'm not advocating copying anyone elses work, but looking at how similar projects approach certain things can be very educational.
    I would also like for this to work

  13. #43
    Join Date
    September 2013
    Posts
    1

    [3.0.12] Forward/Back mouse buttons are not valid PTT hotkey options

    Hello,

    I am unable to set buttons 4 or 5 of my Logitech G5 mouse (the back and forward buttons) to the PTT hotkey for teamspeak3. I am running teamspeak3 on Arch Linux 64 bit. I can confirm that the back and forward keys work properly in the X server, because "xev" reports mouse button events when pressing or releasing the mouse buttons 4 and 5.

    I am able to map any of the first three buttons to the PTT key, but buttons 4 and 5 are not recognized.

    I am able to map the back and forward keys in teamspeak3 in Windows.

    Please let me know if there is any additional information I can provide to assist in resolving this issue.

    Cheers!

  14. #44
    Join Date
    September 2013
    Posts
    1
    Quote Originally Posted by jesepi View Post
    Sorry for the necro, but this seemed to be the most relevant thread after searching around and then seeing an actual TS3 team member requesting information -

    I'd love to get the other mouse buttons working, as they all work fine in other applications on my system. Since someone already mentioned above a place to view some code, here is my attempt at finding something useful. Mumble currently handles this without an issue, so their approach might be worth looking at. Not sure if this particular file is relevant, but here it is:

    https://github.com/mumble-voip/mumbl...rtcut_unix.cpp

    Obviously I'm not advocating copying anyone elses work, but looking at how similar projects approach certain things can be very educational.
    Steam is really pushing for Linux to be a thing, and I am certainly tired of Windows. I hope the TeamSpeak team can figure out how to get this to work soon. Can't stand having to use mouse button 3 to talk in-game when 4 and 5 are so much more convenient.

  15. #45
    Join Date
    May 2013
    Posts
    5
    It's about year since first bug report and still nothing? Is that so hard to solve? How can I help You with this problem?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Can't Bind Mouse Buttons
    By JReese in forum Windows
    Replies: 28
    Last Post: January 3rd, 2013, 03:21 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •