Forum

Results 1 to 9 of 9
  1. #1
    Join Date
    February 2013
    Posts
    2

    Installation on Ubuntu 12.04 64bits

    Hi Guys,
    I really need your help here. I'm trying to install TS2, but with no success at all. I always get the ./setup.data/installer/installer: symbol lookup error: ./setup.data/installer/installer: undefined symbol: initPAnsiStrings
    error. I've installed additional libraries, but nothing change. Could you please help me out? What am I missing here?

    Thanks in advance

  2. #2
    Join Date
    February 2008
    Location
    Germany, Schorndorf
    Posts
    186
    try to install it manually like described in the readme file

    Code:
    manual install:
    copy the contents of setup.data/image to the directory where you want to 
    install ts2. Then edit the "teamspeak" script. replace %installdir% with 
    the directory where you installed teamspeak to.
    regards

  3. #3
    Join Date
    February 2013
    Posts
    2
    Hi,
    it is exactly what I did. But it comes to that error once I try to launch it.

  4. #4
    Join Date
    February 2008
    Location
    Germany, Schorndorf
    Posts
    186
    You got an error message from the installer when you install it manually ???

    pls follow the manual install instruction
    1. copy all files from folder /setup.data/image to the directory where you want
    2. edit file teamspeak and replace %installdir% with the name of the directory

    start teamspeak with edited sript named teamspeak

  5. #5
    Join Date
    April 2014
    Posts
    3
    Did the OP ever get TS2 running on Ubuntu 12.04?

    I followed the manual install instructions but am greeted with "symbol lookup error: ~/TeamSpeak2RC2/TeamSpeak.bin: undefined symbol: initPAnsiStrings" when attempting to run TeamSpeak.sh.

    I searched the forum and tried several of the "hack arounds" to no avail.

    Simple question really, does TS2 support Ubuntu 12.04 64bit? If so, what are the pre-reqs?

    Sent from my HTC6500LVW using Tapatalk
    Last edited by dante696; April 4th, 2014 at 07:18 AM.

  6. #6
    Join Date
    February 2008
    Location
    Germany, Schorndorf
    Posts
    186
    Hi,

    download package from https://packages.debian.org.debian.o...peg62/download
    extract files from folder /usr/lib/i386-linux-gnu/ into Teamspeak folder

  7. #7
    Join Date
    April 2014
    Posts
    3
    Quote Originally Posted by Dabulator View Post
    Hi,

    download package from https://packages.debian.org.debian.o...peg62/download
    extract files from folder /usr/lib/i386-linux-gnu/ into Teamspeak folder
    Hi Thanks for the reply. That link was broken but I downloaded libjpeg62 from this link: https://packages.debian.org/squeeze/...peg62/download

    Installed with dpkg, attempted to run TeamSpeak but receive the same error: "symbol lookup error: /home/tempadmin/TeamSpeak2RC2/TeamSpeak.bin: undefined symbol: initPAnsiStrings"

    Also tried copying the libjpeg62 libs from usr/lib (where dpkg installed) to usr/lib32, to no avail.

  8. #8
    Join Date
    February 2008
    Location
    Germany, Schorndorf
    Posts
    186
    hi, you does not need to install the package, on the package you will find different files in the library.
    extract file libjpeg.so.62.0.0 to teamspeak folder. rename it to libjpeg.so.62 or create a symlink
    i used the package from wheezy with libjpeg.so.62 link and libjpeg.so.62.0.0 file

  9. #9
    Join Date
    April 2014
    Posts
    3
    Quote Originally Posted by Dabulator View Post
    hi, you does not need to install the package, on the package you will find different files in the library.
    extract file libjpeg.so.62.0.0 to teamspeak folder. rename it to libjpeg.so.62 or create a symlink
    i used the package from wheezy with libjpeg.so.62 link and libjpeg.so.62.0.0 file
    Oops I had downloaded the squeezw packages, wheezy worked when placing the libs in the TS folder.

    Thank you!
    Last edited by eddiedee; April 6th, 2014 at 01:19 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] Help needed - TS3 x86 installation on Ubuntu 11.10 (oneiric)
    By jagermeister in forum Linux / FreeBSD
    Replies: 3
    Last Post: October 24th, 2011, 08:09 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •