i run window sp2 and when i try to connect to 85.121.201.141 between 9 am to 5 or 6 pm it works perfect! but when i try to connect after 7 pm i get (<22:58:55> Failed to connect to server)
- i checked firewall and disabled it
- i reinstalled ts3
- removed windows and installed it again (Norton ghost)
- i tried with port forwarding too
but nothing works.. it's just i can connect during mornings only... and here is the Client Log:

17/02/2013 22:58:43 Info TeamSpeak 3 Client 3.0.9.2 (2012-10-29 10:00:43)
17/02/2013 22:58:43 Direct Sound Debug setting timer resolution to 1ms
17/02/2013 22:58:43 SoundDevManager Info Not loading wasapi sound backend windowsaudiosession_win32.dll
17/02/2013 22:58:43 Query Info listening on 127.0.0.1:25639
17/02/2013 22:58:43 Info *** Time [SERVERVIEWMANAGER]: 156
17/02/2013 22:58:43 Input Info Default monitoring enabled
17/02/2013 22:58:43 Info *** Time [MAINWINDOW]: 485
17/02/2013 22:58:43 Info *** Time [INIT]: 485
17/02/2013 22:58:43 ClientUI Info Qt version: 4.7.2
17/02/2013 22:58:43 ClientUI Info Using configuration location: C:\Documents and Settings\Nabil\Application Data\TS3Client\settings.db
17/02/2013 22:58:44 ClientUI Info Last update check was: Sun 17. Feb 11:06:34 2013
17/02/2013 22:58:49 ClientUI Info Connect to server: 85.121.201.141
17/02/2013 22:58:49 ClientUI Info Blacklist check ok
17/02/2013 22:58:49 ClientUI Info Initiating connection: 85.121.201.141:9987 85.121.201.141
17/02/2013 22:58:49 Info DNS resolve successful, "blacklist.teamspeak.com"=176.9.148.78
17/02/2013 22:58:49 PreProSpeex Info Speex version: speex-1.2beta3
17/02/2013 22:58:49 ClientUI Info Connect status: Connecting
17/02/2013 22:58:55 ClientUI Info Connect status: Disconnected
17/02/2013 22:58:55 ClientUI Info Failed to connect to server, want autoreconnect = 0
17/02/2013 23:07:52 ClientUI Info Connect to server: 85.121.201.141
17/02/2013 23:07:52 ClientUI Info Blacklist check ok
17/02/2013 23:07:52 ClientUI Info Initiating connection: 85.121.201.141:9987 85.121.201.141
17/02/2013 23:07:52 Info DNS resolve successful, "blacklist.teamspeak.com"=176.9.148.78
17/02/2013 23:07:53 ClientUI Info Connect status: Connecting
17/02/2013 23:07:58 ClientUI Info Connect status: Disconnected
17/02/2013 23:07:58 ClientUI Info Failed to connect to server, want autoreconnect = 0

some1 help please :)