Forum

Results 1 to 15 of 15
  1. #1
    Join Date
    December 2009
    Location
    Hungary
    Posts
    404

    [Not possible]Needed Private textmessage power is ignored.

    Hi,

    Please help me understand whats wrong with the following situation.

    I'd like to disable private messaging in "Default Channel". In other words I don't want to allow sending private message to anybody on the server from "Default channel". I set up "Channel Permission" -> Private message power to 0 and raised Needed private textmessage on all server groups (including Guest). However it is still possible to send private message from default channel. Please look at the screenshot. Test 1 -> sender, Test2 -> receiver.

    Test1 can message to Test2. Thank you for your explanation.
    Attached Images Attached Images  
    Last edited by Slater; March 23rd, 2013 at 03:24 PM.

  2. #2
    Join Date
    December 2009
    Location
    Hungary
    Posts
    404
    Can you please help me with this issue?

  3. #3
    Join Date
    January 2010
    Location
    Catalunya
    Posts
    2,350
    It seems you've found a bug

    In Permissions Overview, all looks well:
    i_client_private_textmessage_power
    in server group = 10
    in default channel = 0
    total = 0
    but in fact, total = 10, because it takes the server group value.

    Edit: Maybe the value is resolved, in the target channel, instead source channel.
    Last edited by Jordi; March 14th, 2013 at 06:18 PM.

  4. #4
    Join Date
    January 2010
    Location
    El Prat de Llobregat (Barcelona, Spain)
    Posts
    2,698
    Quote Originally Posted by Slater View Post
    Can you please help me with this issue?
    Did this work before or is it the first time you try it?

  5. #5
    Join Date
    December 2009
    Location
    Hungary
    Posts
    404
    I've opened a thread 1 yeag ago(!) but it was not answered. I couldn't locate it and now I really need to disable private chat coming from Default channel.

  6. #6
    Join Date
    January 2010
    Location
    El Prat de Llobregat (Barcelona, Spain)
    Posts
    2,698
    Quote Originally Posted by Slater View Post
    I've opened a thread 1 yeag ago(!). I couldn't locate it and now I really need to disable private chat coming from Default channel.
    With this information I've searched a little and I think this is "the thread", and it's marked as "Solved":
    http://forum.teamspeak.com/showthrea...-doesn-t-apply

    -->Jordi's last words:
    And check in the server group, where they come from these members.
    b_client_skip_channelgroup_permissions are disabled

  7. #7
    Join Date
    December 2009
    Location
    Hungary
    Posts
    404
    I can't set "b_client_skip_channelgroup_permissions" for Guests since I operate channels for guilds and they have many channel groups (ranks). Previos thread was not solved this is why opened this one. Thanks for finding it btw. The problem (bug) still exists. (permission overview dialog shouldn't display wrong values either)

  8. #8
    Join Date
    December 2009
    Location
    Hungary
    Posts
    404
    I just tried if I enable "Skip channelgroup permissions" on Guest server group, Guests still can send private messages from Deafult Channel (where private textmessage power is -1)

  9. #9
    Join Date
    January 2010
    Location
    Catalunya
    Posts
    2,350
    It seems that there is an answer to this problem.

  10. #10
    Join Date
    December 2009
    Location
    Hungary
    Posts
    404
    Sorry, but the answer is wrong. It doesn't matter if I set "Skip channel permissions" on server group. It doesn't matter how "Private Textmessage Power" is set on a channel. I'm starting to give up this thing. Guests STILL CAN send out private messages from default channel however it's disabled in "Channel Permissions" (-1).
    Attached Images Attached Images  
    Last edited by Slater; March 19th, 2013 at 11:29 AM.

  11. #11
    Join Date
    December 2009
    Location
    Hungary
    Posts
    404
    Here are the related permissions on my server for Guests.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Channel.jpg 
Views:	118 
Size:	33.0 KB 
ID:	7873   Click image for larger version. 

Name:	ServerGuest.jpg 
Views:	86 
Size:	39.8 KB 
ID:	7874   Click image for larger version. 

Name:	GuestChannelGroup.jpg 
Views:	80 
Size:	32.5 KB 
ID:	7875  

  12. #12
    Join Date
    January 2010
    Location
    Catalunya
    Posts
    2,350
    Quote Originally Posted by Slater View Post
    Sorry, but the answer is wrong.
    I am not referring to you but to the support group.

    EDIT:

    While the issue is not resolved, maybe you could fix it:
    Server group "Guest" i_client_private_textmessage_power value = -1
    And give options to send messages in the channel groups.

    Forget the channels, because it appears that the permission is resolved in the target channel, not at source channel.
    Last edited by Jordi; March 19th, 2013 at 11:47 PM.

  13. #13
    Join Date
    December 2009
    Location
    Hungary
    Posts
    404
    I was told that it is not possible to deny/grant global permissions via Channel Permissions since channel permissions are local permissions. So this thread can be locked. Setting "Private Textmessage Power" to "-1" for a channel is valid only in that channel. Global permissions are "Client Permissions" and "Server Groups" only.

    If this is the case, "Permission Overview" dialog should be reworked since the values are obviously misleading.

    I hope devs will find a way in the future to deny/grant global permissions via "Channel Permissions" or something like that.
    Last edited by Slater; March 20th, 2013 at 01:01 PM.

  14. #14
    Join Date
    January 2010
    Location
    Catalunya
    Posts
    2,350
    Quote Originally Posted by Jordi View Post
    While the issue is not resolved, maybe you could fix it:
    Server group "Guest" i_client_private_textmessage_power value = -1
    And give options to send messages in the channel groups.
    Forget the channels, because it appears that the permission is resolved in the target channel, not at source channel.
    I referred to the channel groups, to allow permission.

  15. #15
    Join Date
    December 2009
    Location
    Hungary
    Posts
    404
    Quote Originally Posted by Jordi View Post
    I referred to the channel groups, to allow permission.
    I know that, but its just a messy workaround not the real solution. Thx anyway.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: February 24th, 2014, 06:13 PM
  2. [No Bug] Power and needed power permissions
    By florian_fr40 in forum Permission System
    Replies: 14
    Last Post: November 7th, 2011, 09:09 PM
  3. [No Bug] Power and needed power permissions
    By florian_fr40 in forum Bug Reports [EN/DE]
    Replies: 2
    Last Post: January 24th, 2011, 08:37 AM
  4. Need textmessage power
    By SiJAYS_S in forum Suggestions and Feedback
    Replies: 2
    Last Post: November 3rd, 2010, 03:21 PM
  5. Replies: 18
    Last Post: August 17th, 2010, 11:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •