Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 5 of 5

Thread: TSDNS problem

  1. #1
    Join Date
    December 2009
    Location
    Poland
    Posts
    83

    TSDNS problem

    I want to change user who runs tsdns. I have removed /dev/shm/*, changed owner:group for files but when I run then it does not load entries from config.
    Code:
    Scanned tsdns_settings.ini, number of entries: 0
    When I starts with old user then it works.
    Code:
    Scanned tsdns_settings.ini, number of entries: 120

  2. #2
    Join Date
    September 2012
    Posts
    6,079
    Make sure the user you intend to run the tsdns server as has access to the tsdns_settings.ini

  3. #3
    Join Date
    January 2013
    Location
    Kazan City
    Posts
    5
    I also have a problem. Once connected, the client in the log warning
    14.03.2013 10:17:51 StringHelp Warning Invalid UTF-8 string passed to function, returning as-is
    14.03.2013 10:17:51 StringHelp Warning Invalid UTF-8 string passed to function, returning as-is
    14.03.2013 10:17:51 Warning getaddrinfo error: ������ - ��� ��������� ������, ����������� �� ����� ���������� ����� ����, � ����������, ��� ��������� ������ �� ������� ������ �� ������������ �������.

  4. #4
    Join Date
    September 2012
    Posts
    6,079
    @ighostx:
    Maybe your tsdns_settings.ini is corrupted, redo it from scratch. If it contains UTF-8 characters make sure the file is saved with UTF8 encoding.

  5. #5
    Join Date
    December 2009
    Location
    Poland
    Posts
    83
    I have found a solution. When I start the tsdns with command /home/tsdns/tsdnsserver_linux_amd64 then it does not load the entries. But when I change dir and run directly ./tsdnsserver_linux_amd64 then it works.
    Last edited by Dream; September 23rd, 2014 at 04:00 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. TSDNS problem
    By Andevi97 in forum Windows
    Replies: 5
    Last Post: September 22nd, 2014, 06:49 PM
  2. Big Problem, TSDNS
    By Tryton in forum Server Support
    Replies: 2
    Last Post: December 2nd, 2013, 03:15 PM
  3. Replies: 0
    Last Post: August 4th, 2013, 02:52 PM
  4. TSDNS problem
    By Tiranous in forum Client Support
    Replies: 3
    Last Post: July 21st, 2011, 01:53 AM
  5. TSDNS problem
    By erikz in forum Linux / FreeBSD
    Replies: 4
    Last Post: June 15th, 2011, 08:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •