Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 7 of 7
  1. #1
    Join Date
    March 2013
    Posts
    4

    Question virtualserver_min_client_version problem

    I have a ts3 server installed in a linux ubuntu server. Well, most things are working well, but there's one problem I cannot pass through no matter how much time I waste trying to solve it. When I connect to ServerQuery using Telnet, login and select the server, I typed serverinfo in order to view my server properties. Well, it seemed that the value of virtualserver_min_client_version was 1352194969, which I don't want that way.

    So I used serveredit to change its value to a one reasonable one (because of this many friends of mine can't enter ts3 via mobile or using slightly outdated ts3 clients). Once apparently changed (typed serverinfo again), I restarted the server. The problem is, when I wanted to be sure that the variable of my server was permanently changed, I figure out that the value was in its default value again...
    And it does everytime I restart, so no chances for me to modify it.

    If anyone know why is it doing this, I would appreciate the help, thanks.

  2. #2
    Join Date
    September 2012
    Posts
    6,079
    what server version are you using?
    What system is the server running on?
    Do permanent channels survive a server restart?

  3. #3
    Join Date
    March 2013
    Posts
    4
    -I'm running TeamSpeak3 server version 3.0.7.1
    -I have a dedicated Linux Ubuntu Desktop 64bits 12.04 (yes, a bit strange, but it is a desktop)
    -Yep, permanent channels stay there no matter how many restarts I do.

  4. #4
    Join Date
    March 2013
    Posts
    4
    Well, I think the problem is that I installed the x86 version server in a x64 machine. Don't even know how it was actually partially working. My entire fault, sorry for the inconvenience, problem solved. What a mistake...

    Thanks!

  5. #5
    Join Date
    September 2012
    Posts
    6,079
    still the 3.0.7.1 server will require the latest client (at least 3.0.10) no matter what min_client_version you specify.

  6. #6
    Join Date
    March 2013
    Posts
    4
    So which server version do I need to allow min_client_version to be 14326 (for example) and allowing clients as it should?

  7. #7
    Join Date
    September 2012
    Posts
    6,079
    the question is why would you want to allow clients that old?
    Any platform has support for the 3.0.7 server, so there is no need really.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] virtualserver_min_client_version for pc and mobile clients.
    By Nicocaps in forum Suggestions and Feedback
    Replies: 17
    Last Post: April 27th, 2015, 09:15 AM
  2. Virtualserver_min_client_version
    By BlackMoon in forum Server Support
    Replies: 6
    Last Post: October 31st, 2012, 08:31 PM
  3. Replies: 5
    Last Post: August 21st, 2010, 02:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •