Forum

Page 1 of 2 12 LastLast
Results 1 to 15 of 21
  1. #1
    Join Date
    April 2013
    Posts
    8

    Question Server does crash on start (customtime.cpp:115;)

    Hello everybody,

    i want create a Teamspeak3 Server, but i got this error. I followed this tutorial

    Code:
     (it is from me)
    2013-04-04 16:02:16.038830|CRITICAL|Time          |   | Assertion "m_instance != __null" failed at common/time/customtime.cpp:11                            5;
    I already created some new TeamSpeak3 Server, but always the same mistake.
    If I start the Ts3 Server with the User "root", the Ts3 starts, without any Error.
    But, if I start the Server with an user like "ts", i get this error. I already asked google, i got 4 answers, 2 in an other language, and the other 2 cant fix the problem.

    Sorry for my bad English, I know it sucks, but Iam from Germany.

  2. #2
    Join Date
    April 2011
    Location
    Germany
    Posts
    1,266
    You should consider mounting shared memory, or if it is mounted it needs to be writeable to the "ts" user.
    Or as an other option you might want to get a valid license.

    You might want to read this: http://support.teamspeakusa.com/inde...rticle/View/51

  3. #3
    Join Date
    April 2013
    Posts
    8
    I had read this, and i followed it, but it dont fixed it.

  4. #4
    Join Date
    April 2011
    Location
    Germany
    Posts
    1,266
    It would be useful to have the full error log, not just one line. That one line suggests it's a shared memory issue.

  5. #5
    Join Date
    April 2013
    Posts
    8
    That is the Full error -_-'
    If i start the Server with the root User, I dont get any error.

  6. #6
    Join Date
    September 2012
    Posts
    6,080
    Please provide the full error log (entire _0.log from the latest crash).

  7. #7
    Join Date
    April 2011
    Location
    Germany
    Posts
    1,266
    Quote Originally Posted by Felixuss View Post
    That is the Full error -_-'
    If i start the Server with the root User, I dont get any error.
    I still bet it is a shared memory issue. But as Chris and I have pointed out, post the full error log, please.
    Also as written in this post are you sure that your "ts" user is allowed to write to shared memory.

  8. #8
    Join Date
    April 2013
    Posts
    8
    Hey Guys,
    today I can not start the Server as root. So I cant use my TeamSpeak3 Server.

    Here is the full Error Log:


    2013-04-05 09:56:37.071591|INFO |ServerLibPriv | | TeamSpeak 3 Server 3.0.7.1 (2013-03-18 10:56:27)
    2013-04-05 09:56:37.071991|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2013-04-05 09:56:37.072031|INFO |DatabaseQuery | | dbPlugin version: 3.7.3
    2013-04-05 09:56:37.072296|INFO |DatabaseQuery | | checking database integrity (may take a while)
    2013-04-05 09:56:37.114234|WARNING |Accounting | | Unable to find valid license key, falling back to limited functionality
    2013-04-05 09:56:37.614449|ERROR |Accounting | | local accounting reports an already running instance, instance will shutdown
    2013-04-05 09:56:37.614536|ERROR |ServerLibPriv | | Server() error while starting servermanager, error: instance limit reached
    2013-04-05 09:56:37.614589|CRITICAL|Time | | Assertion "m_instance != __null" failed at common/time/customtime.cpp:115;


    But I do not use any other TeamSpeak3 Server on my vServer.

  9. #9
    Join Date
    September 2012
    Posts
    6,080
    Code:
    2013-04-05 09:56:37.614449|ERROR |Accounting | | local accounting reports an already running instance, instance will shutdown
    2013-04-05 09:56:37.614536|ERROR |ServerLibPriv | | Server() error while starting servermanager, error: instance limit reached
    There is already another instance running, check "ps -aux | grep ts3server"
    Without a license you can only run a single instance

  10. #10
    Join Date
    April 2013
    Posts
    8
    I know, but I dont run a second instance.

  11. #11
    Join Date
    September 2012
    Posts
    6,080
    The server says otherwise, so either you are running a second instance or you don't have proper access to shared memory as Barungar suggested.
    Post output of ps aux|grep ts3

  12. #12
    Join Date
    April 2011
    Location
    Germany
    Posts
    1,266
    You might also want to add the output of: ls -al /dev/ |grep shm and mount |grep shm
    So we can check, if /dev/shm has the correct right structure

  13. #13
    Retzugil Guest
    I'm having the same issue, when running TS3 at startup. I have already tried the suggestion by Barungar yet I'm still getting the same error.

    Full Error Log:
    Code:
    2013-04-13 21:43:24.418104|INFO    |ServerLibPriv |   | TeamSpeak 3 Server 3.0.7.1 (2013-03-18 10:56:27)
    2013-04-13 21:43:24.419253|INFO    |DatabaseQuery |   | dbPlugin name:    SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2013-04-13 21:43:24.419406|INFO    |DatabaseQuery |   | dbPlugin version: 3.7.3
    2013-04-13 21:43:24.420141|INFO    |DatabaseQuery |   | checking database integrity (may take a while)
    2013-04-13 21:43:24.477325|INFO    |SQL           |   | db_CreateTables() tables created
    2013-04-13 21:43:24.883766|WARNING |Accounting    |   | Unable to find valid license key, falling back to limited functionality
    2013-04-13 21:43:25.384227|ERROR   |Accounting    |   | local accounting reports an already running instance, instance will shutdown
    2013-04-13 21:43:25.384413|ERROR   |ServerLibPriv |   | Server() error while starting servermanager, error: instance limit reached
    2013-04-13 21:43:25.384488|CRITICAL|Time          |   | Assertion "m_instance != __null" failed at common/time/customtime.cpp:115;
    ps aux|grep ts3:
    Code:
    justin[~]$ ps aux|grep ts3
    justin    2567  0.0  0.1   2476   604 pts/0    S+   15:59   0:00 grep ts3
    ls -al /dev/|grep shm:
    Code:
    justin[~]$ ls -al /dev/|grep shm
    drwxrwxrwt   2 root root          40 Apr 18 15:48 shm
    mount |grep shm:
    Code:
    justin[~]$ mount |grep shm
    tmpfs on /dev/shm type tmpfs (rw)
    tmpfs on /dev/shm type tmpfs (rw)
    Any suggestions for me?
    I'm using the following code in "/etc/rc.d/rc.local" to start my server (maybe theres an issue there):
    Code:
    sudo -u justin /home/justin/Documents/teamspeak3-server/ts3server_startscript.sh start
    Edit: I can run the server alright when I manually run it through the terminal, however it gives me the errors listed above when I try to run it on system startup.
    Last edited by Retzugil; April 19th, 2013 at 01:26 AM.

  14. #14
    Join Date
    April 2011
    Location
    Germany
    Posts
    1,266
    Perhaps the shared memory is not fully intialized when the rc.local gets to the teamspeak script.
    And if you start the script manual the boot is completed so shm is fully mounted.

    Check if it is possbile to auto start teamspeak at a little later time.

  15. #15
    Join Date
    December 2012
    Location
    Bavaria, DE
    Posts
    120
    mad
    ldd ts3server_startscript.sh
    and then you look http://packages.ubuntu.com/de/
    when you havent a package

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 8
    Last Post: March 9th, 2015, 10:58 PM
  2. Error customtime.cpp:115 / NPL out of date
    By pascalvp in forum Linux / FreeBSD
    Replies: 1
    Last Post: October 25th, 2013, 06:41 PM
  3. Replies: 0
    Last Post: May 4th, 2011, 02:22 AM
  4. TS 3 Crash at start
    By ETc|#.Jay.# in forum Windows
    Replies: 2
    Last Post: December 21st, 2009, 11:33 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •