Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 1 of 1
  1. #1
    Join Date
    April 2013

    TS-Client ALSA Capture-Device Custom config

    Hello there.
    I've found a Bug in the Capture Device Setting.

    I will use ALSA with dsnoop and dmix settings to use the Audio-Streams from (and to) my Headset in several Programs (such like Skype, Audacity and my VoIP-Telephone Program). But i would like to hear Music and Movies through my standard PCI-Soundcard.

    My Problem is that Teamspeak takes the whole USB-Headset-Device for himself and doesn't allow any other Program to use it (of course only when it runs), so I set up a well nicely working Setting for my /etc/asound.conf file.

    pcm.headset {
            type plug
            slave.pcm {
                    type asym
                    playback.pcm {
                            type dmix
                            # Now, need to specify a number to identify the shared memory area
                            # where this dmix plugin will do its mixing.  This is meaningless,
                            # it just needs to be unique.
                            ipc_key 4321
                            #When naming that shared-memory area, don't add the current user's
                            #ID in there, so that other users can find it.
                            ipc_key_add_uid false
                            # Allow other users in my group to access that area so they can
                            # also open this device.  This is especially important if you want
                            # to put this device into a global configuration file.
                            ipc_perm 0660
                            slave.pcm "hw:CARD=Headset"
                    capture.pcm {
                            # According to the dmix Plugin, the dsnoop plugin can be configured.
                            type dsnoop
                            ipc_key 2304
                            ipc_key_add_uid false
                            ipc_perm 0660
                            slave.pcm "hw:CARD=Headset"
            hint {  
                    show on
                    description "My Headset DMIX"
    ctl.headset {
            type hw
            card "CARD=Headset"
    (tested with 'arecord -D headset -c 1 -r 44100 -f S16_LE - | aplay -D headset -c 1 -r 44100 -f S16_LE -' and skype (doing several echo-test) and audacity capture the whole thing, while my media-player plays music (all this stuff shots to the defined headset Device))

    The User-specified target-device "headset" is well working at Teamspeak, but the user-specified source-device (for capturing) "headset" will not working.
    If i add the next rule to my asound.conf (without touching the other rules) then it works in teamspeak. So it is assumed that teamspeak use the "Default" Capture-Device Setting (the Playback has worked before, so no Problem there), when Custom config is set.
    pcm.!default {
            type plug 
            pcm.slave "headset"
    ctl.!default {
            type hw
            card "CARD=Headset"
    At the Attachment you can see which user-defined configuration for Capture-Devices i mean.

    I found this Bug at Teamspeak 3.0.10 at 'Linux 3.8.4-gentoo #1 SMP PREEMPT x86_64 AuthenticAMD GNU/Linux'

    At Teamspeak-client it also didn't work.
    Attached Images Attached Images  
    Last edited by Shen Long; April 12th, 2013 at 07:36 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Using of custom capture device
    By Bambr in forum General Questions
    Replies: 0
    Last Post: September 6th, 2014, 01:46 PM
  2. Custum Capture Device(s) with Default Playback Device
    By Mike Holland in forum General Questions
    Replies: 0
    Last Post: July 3rd, 2014, 04:18 PM
  3. Replies: 1
    Last Post: April 19th, 2011, 07:47 PM
  4. Replies: 1
    Last Post: January 27th, 2011, 01:54 PM
  5. Replies: 16
    Last Post: March 28th, 2010, 01:26 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts