Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 3 of 3
  1. #1
    Join Date
    May 2013
    Posts
    2

    Solved Mouse moves automatically

    Hi, Whenever I open teamspeak 3, my cursor drifts to the top left of my screen, and continues to do so when I move it back down. When I finally manage to close teamspeak 3, my cursor stops.

    I run windows 7, downloaded the most recent version, "TeamSpeak3-Client-win64-3.0.10.1". And my Mouse is a Logitech G5.

    I'm wondering if anyone could assist me.
    Thank you

  2. #2
    Join Date
    September 2012
    Posts
    6,079
    make sure your drivers are up to date.
    post a full client log (can be found in %AppData%\TS3Client\logs )

  3. #3
    Join Date
    May 2013
    Posts
    2
    The mouse started moving at about 15:01:41, the time when a log appears.

    2013-05-06 14:53:17.400109|INFO | | | TeamSpeak 3 Client 3.0.10.1 (2013-04-04 08:33:04)
    2013-05-06 14:53:17.473114|DEBUG |Direct Sound | | setting timer resolution to 1ms
    2013-05-06 14:53:17.531117|INFO | | | *** Time [SPAWN_EVENTCONVERTER]: 131
    2013-05-06 14:53:17.652124|INFO |Query | | listening on 127.0.0.1:25639
    2013-05-06 14:53:17.812133|INFO | | | *** Time [PLUGINS]: 281
    2013-05-06 14:53:18.158153|INFO | | | *** Time [MAINWINDOW_ACTIONS]: 149
    2013-05-06 14:53:18.254158|DEVELOP |Windows Audio Session| | DeviceDeleteList::waitForDeletes - enter
    2013-05-06 14:53:18.254158|DEVELOP |Windows Audio Session| | DeviceDeleteList::waitForDeletes - leave
    2013-05-06 14:53:18.370165|INFO | | | *** Time [SERVERVIEW]: 122
    2013-05-06 14:53:18.379165|INFO | | | *** Time [SERVERVIEWMANAGER]: 208
    2013-05-06 14:53:18.391166|INFO |Input | | Default monitoring enabled
    2013-05-06 14:53:18.420168|INFO | | | *** Time [MAINWINDOW]: 1217
    2013-05-06 14:53:18.420168|INFO | | | *** Time [INIT]: 1217
    2013-05-06 14:53:18.459170|INFO |ClientUI | | Qt version: 4.8.3
    2013-05-06 14:53:18.459170|INFO |ClientUI | | Using configuration location: G:/Programs/TeamSpeak 3 Client II/config/settings.db
    2013-05-06 14:53:18.921196|INFO |ClientUI | | Last update check was: Mon May 6 14:29:56 2013
    2013-05-06 15:01:41.005914|DEVELOP |Windows Audio Session| | DeviceDeleteList::waitForDeletes - enter
    2013-05-06 15:01:41.005914|DEVELOP |Windows Audio Session| | DeviceDeleteList::waitForDeletes - leave
    2013-05-06 15:01:41.155923|DEVELOP |Windows Audio Session| | DeviceDeleteList::waitForDeletes - enter
    2013-05-06 15:01:41.155923|DEVELOP |Windows Audio Session| | DeviceDeleteList::waitForDeletes - leave

    in this Second log file, the time the mouse starts moving is upon Loadup

    2013-05-06 15:07:23.661513|INFO | | | TeamSpeak 3 Client 3.0.10.1 (2013-04-04 08:33:04)
    2013-05-06 15:07:23.675514|DEBUG |Direct Sound | | setting timer resolution to 1ms
    2013-05-06 15:07:23.700515|INFO |Query | | listening on 127.0.0.1:25639
    2013-05-06 15:07:23.927528|DEVELOP |Windows Audio Session| | DeviceDeleteList::waitForDeletes - enter
    2013-05-06 15:07:23.927528|DEVELOP |Windows Audio Session| | DeviceDeleteList::waitForDeletes - leave
    2013-05-06 15:07:23.941529|INFO | | | *** Time [SERVERVIEWMANAGER]: 127
    2013-05-06 15:07:23.952529|INFO |Input | | Default monitoring enabled
    2013-05-06 15:07:23.971531|INFO | | | *** Time [MAINWINDOW]: 313
    2013-05-06 15:07:23.971531|INFO | | | *** Time [INIT]: 313
    2013-05-06 15:07:23.978531|INFO |ClientUI | | Qt version: 4.8.3
    2013-05-06 15:07:23.978531|INFO |ClientUI | | Using configuration location: G:/Programs/TeamSpeak 3 Client II/config/settings.db
    2013-05-06 15:07:24.483560|INFO |ClientUI | | Last update check was: Mon May 6 14:29:56 2013
    2013-05-06 15:07:35.248176|DEVELOP |Windows Audio Session| | DeviceDeleteList::waitForDeletes - enter
    2013-05-06 15:07:35.248176|DEVELOP |Windows Audio Session| | DeviceDeleteList::waitForDeletes - leave
    2013-05-06 15:07:35.398184|DEVELOP |Windows Audio Session| | DeviceDeleteList::waitForDeletes - enter
    2013-05-06 15:07:35.398184|DEVELOP |Windows Audio Session| | DeviceDeleteList::waitForDeletes - leave

    Edit:
    I found the cause of this issue, and it has to do with my joystick program and teamspeak 3. Whenever both programs are run simultaneously, my mouse moves drifts.

    I was just thinking, I saw a post about the joystick not being recognized as a separate device. My joystick is set up to send mouse signals when I twist it. When I run the joystick program in a way that does not send mouse signals, both programs run without issues.
    Last edited by Chris; May 7th, 2013 at 10:56 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] Request TP moves Avatar
    By Jomant in forum Android
    Replies: 2
    Last Post: December 3rd, 2014, 08:30 AM
  2. Log files should record client moves
    By PatPeter in forum Suggestions and Feedback
    Replies: 0
    Last Post: February 19th, 2013, 08:07 AM
  3. Replies: 9
    Last Post: December 10th, 2012, 01:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •