Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 2 of 2
  1. #1
    Join Date
    May 2013
    Posts
    1

    Unhappy CentOS Linux & VPS Issues

    Hi guys,

    I am new to teamspeak 3 and tried setting it up on my new VPS hosted by HostGtor. For the most part, query and ftp ports work fine. I am having a lot of issues with the 9987 UDP port. If I do a 'netstat -lnp | grep ts3' command it will give me all 3 ports with 2 listening and 1 not listening (9987).

    Truth be told I really do know what IP address I should be using--is it my primary name server IP? My domain IP (which is my primary name server IP)? My secondary name server IP?

    Also, is the server password always empty to begin with? I read a bunch of guides and whatnot and some never mention how you get it and some say it's in an 'email'. The only email I have ever received while buying an Annual Activation License was my billing username and pw. Did something bug out and I missed a 'welcome' email with my server info? I reallly just need help grasping anything, and sorry for the lack of screenshots, I will provide them once I get off work (and learn how to use them in forums).

    From the guides, this is what I've done over and over again.

    1. Download compressed file package for ts3 64bit.
    2. Create a new user /home/ts3user.
    3. Install package in /home/ts3user.
    4. Change group and owner to ts3user for everything in the package.
    5. Create a ts3server.ini file.
    6. Use your server's ip address (primary name server) instead of 0.0.0.0
    7. Modify ts3server_startscript.sh and include 'inifile=ts3server.ini' in the COMMANDLINE param (with $2)
    8. Run ./ts3server_startscript.sh start
    9. Record serveradmin pw, record token.
    10. Open client. Connect using server ip:9987 with no password (I don't even know what this part is all about. What is the password??)

    Connection Fails. Checking log, 9987 is listening aka Virtual Server Manager. However, when I check the processes, it's not listening.

    Could this be a firewall issue? Like I said, I am new to CentOS Linux so I can't tell how everything works..Thanks for reading up to this point and helping!

  2. #2
    Join Date
    September 2012
    Posts
    6,079
    The server password is always empty by default yes.
    You can set one in the client when you edit the virtual server and everyone (except those who have b_virtualserver_join_ignore_password) who connects to the server will have to enter this password to be able to connect.

    If the server is running and no errors are reported in either the _0.log or the _1.log and you still cannot connect when using the correct IP address then this might be firewall related yes.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. TS3 on CentOS Setup Issues
    By GvnrRickPerry in forum Linux / FreeBSD
    Replies: 8
    Last Post: September 10th, 2015, 12:47 AM
  2. Issues setting up server on CentOS 7 VPS
    By mangusbrother in forum Linux / FreeBSD
    Replies: 4
    Last Post: November 16th, 2014, 05:29 AM
  3. Linux CentOS
    By Joele25 in forum Linux / FreeBSD
    Replies: 1
    Last Post: April 4th, 2014, 08:29 AM
  4. [Resolved] Issues connecting to a running server. CentOS
    By Morthawt in forum Linux / FreeBSD
    Replies: 9
    Last Post: July 25th, 2012, 11:53 AM
  5. Linux server on Centos VPS
    By DarKZONE in forum Linux / FreeBSD
    Replies: 2
    Last Post: April 19th, 2011, 11:55 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •