Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 1 of 4 123 ... LastLast
Results 1 to 15 of 54
  1. #1
    Join Date
    September 2012
    Posts
    6,079

    [PreRelease] TeamSpeak 3 Server 3.0.8

    We are proud to announce that the newest server release version 3.0.8 is available for beta testing.
    Most notably, this server release contains improved protection against DoS attacks, the high CPU Usage accompanied by that and also allows for virtual servers to be moved between running instances without triggering the "running elsewhere" accounting error that would previously shut the virtual server down again.
    It also includes the ability to disable query password bruteforce protection for whitelisted IP addresses through a new command line parameter.

    Please note that Client 3.0.11 is required to be able to connect to servers running this version


    Full Changelog below:
    Code:
    === Server Release 3.0.8 25 Jul 2013
     ! Changed the platform string for the Mac OsX platform from "MacOSX" to "OS X"
     ! new login protocol. Old clients can not connect to this server version.
     + added new commandline parameter "query_skipbruteforcecheck" to disable any protection for whitelisted Ip addresses for the ServerQuery interface
     + added some protection against DOS attacks and cpu usage during login
     + query logins now always log the account name used.
     + Moving virtual server between instances should now not trigger the "running elsewhere" accounting error.
     - fixed a hang on virtual server shutdown
     - fixed race condition on pending connections
     - other various bug fixes
    Please go here to download the server.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  2. #2
    Join Date
    May 2007
    Location
    Eastern NC
    Posts
    1,801
    I guess the update requires additional (newer) things..
    Code:
    ./ts3server_linux_amd64: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by ./ts3server_linux_amd64)
    Server is running CentOS 6.4 and yum reports that latest version of glibc.x86_64 is already installed.

    Code:
     strings /usr/lib/libstdc++.so.6 | grep GLIBC
    GLIBCXX_3.4
    GLIBCXX_3.4.1
    GLIBCXX_3.4.2
    GLIBCXX_3.4.3
    GLIBCXX_3.4.4
    GLIBCXX_3.4.5
    GLIBCXX_3.4.6
    GLIBCXX_3.4.7
    GLIBCXX_3.4.8
    GLIBCXX_3.4.9
    GLIBCXX_3.4.10
    GLIBCXX_3.4.11
    GLIBCXX_3.4.12
    GLIBCXX_3.4.13
    GLIBC_2.0
    GLIBC_2.3
    GLIBC_2.4
    GLIBC_2.1
    GLIBC_2.1.3
    GLIBC_2.3.2
    GLIBC_2.2
    GLIBCXX_FORCE_NEW
    GLIBCXX_DEBUG_MESSAGE_LENGTH
    Last edited by Screech; July 25th, 2013 at 11:15 PM.

  3. #3
    Join Date
    December 2009
    Location
    UK
    Posts
    769
    Packages can (in my experience) be several versions behind the latest source available, might be an idea to download the source & compile if that won't cause too many problems

  4. #4
    Join Date
    May 2007
    Location
    Eastern NC
    Posts
    1,801
    Quote Originally Posted by Air SeaTac View Post
    Packages can (in my experience) be several versions behind the latest source available, might be an idea to download the source & compile if that won't cause too many problems
    Should be able to compile here at the house and upload to VPS, but right now I don't have that much time as I have a car or two to prep for race this weekend. Maybe they can tweek the requirement back down to GLIBCXX_3.4.13 unless they are actually using features/fixes in GLIBCXX_3.4.15. I think I recall something like this happening with an update back in 2010 while everything was still beta.

  5. #5
    Join Date
    September 2012
    Posts
    6,079
    Update

    There was a new Server Beta Release today, please note that this server release requires todays client as well. Yesterdays client will not be able to connect to this new server release!
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  6. #6
    Join Date
    May 2007
    Location
    Eastern NC
    Posts
    1,801
    Same issue as reported for me.

    Chris, you asked what "gcc --version" returns. I don't have that installed on my live server. On my test server and Dev box at the house it returns "4.1.2 20080704".
    Last edited by Screech; July 26th, 2013 at 03:34 PM.

  7. #7
    Join Date
    June 2002
    Location
    Netherlands
    Posts
    1,049
    Hi Screech,

    Thanks for your imporant report. We believe the problems can be fixed by adding 2 shared libraries to your teamspeak server directory (note, this also works for ts3 clients). THIS IS ONLY NEEDED FOR LINUX.

    Step 1: download the 2 libraries. Get the correct one, depending on your architecture
    x86 here
    amd64 here

    step 2: go to the ts3 server directory and unpack the tar archives. The files libgcc_s.so.1 and libstdc++.so.6 should now be in the same directory as ts3server_static_{x86|amd64}

    start the ts3 server as ususal. This means that LD_LIBRARY_PATH has to point to the current dir.

    Let us know if this helps

  8. #8
    Join Date
    May 2007
    Location
    Eastern NC
    Posts
    1,801
    Yes, that helps. Thanks.

  9. #9
    Join Date
    April 2013
    Posts
    34
    Please note that Client 3.0.11 is required to be able to connect to servers running this version
    ************************************************** ********************

    where i find it ? how can i test a server-beta, if we dont find the client ?
    Last edited by --- MaBo. ---; July 27th, 2013 at 08:09 AM.

  10. #10
    Join Date
    April 2011
    Location
    Germany
    Posts
    1,266
    With those redistributable libraries it work on my system, too.

    In the log of instance 0 I noticed two lines "Using hardware aes" and "Puzzle precompute time: 2441"... Are you guys reworking the voice encryption?!

    Code:
    2013-07-27 08:48:15.001910|INFO    |ServerLibPriv |   | TeamSpeak 3 Server 3.0.8 (2013-07-26 08:06:27)
    2013-07-27 08:48:15.002246|INFO    |ServerLibPriv |   | SystemInformation: Linux 2.6.18-028stab101.1 #1 SMP Sun Jun 24 19:50:48 MSD 2012 x86_64 Binary: 64bit
    2013-07-27 08:48:15.002307|INFO    |ServerLibPriv |   | Using hardware aes
    2013-07-27 08:48:15.002901|INFO    |DatabaseQuery |   | dbPlugin name:    SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2013-07-27 08:48:15.002973|INFO    |DatabaseQuery |   | dbPlugin version: 3.7.3
    2013-07-27 08:48:15.011172|INFO    |DatabaseQuery |   | checking database integrity (may take a while)
    2013-07-27 08:48:15.082655|WARNING |Accounting    |   | Unable to find valid license key, falling back to limited functionality
    2013-07-27 08:48:17.555158|INFO    |              |   | Puzzle precompute time: 2441
    2013-07-27 08:48:17.555595|INFO    |FileManager   |   | listening on 0.0.0.0:30033
    2013-07-27 08:48:17.593002|INFO    |CIDRManager   |   | updated query_ip_whitelist ips: 127.0.0.1,
    2013-07-27 08:48:17.593770|INFO    |Query         |   | listening on 0.0.0.0:10011

  11. #11
    Join Date
    June 2002
    Location
    Netherlands
    Posts
    1,049
    Teamspeak was already using aes, but now we have added code to make use of hardware aes capabilities that are present in newer intel and amd cpu's.

    The puzzle stuff is needed for the new login algorithm and is unrelated to (voice) encryption.

  12. #12
    Join Date
    December 2010
    Location
    United Kingdom
    Posts
    340
    Hello nwerensteijn !

    did you heard about new encryption sha-3 ( keccak ) ?

  13. #13
    Join Date
    June 2002
    Location
    Netherlands
    Posts
    1,049
    Yes I know it exists. We currently do not use it, since sha2 is more proven, faster, and there are no indications that it is broken.

  14. #14
    Join Date
    December 2010
    Location
    United Kingdom
    Posts
    340
    Quote Originally Posted by nwerensteijn View Post
    Yes I know it exists. We currently do not use it, since sha2 is more proven, faster, and there are no indications that it is broken.
    http://www.thawte.com/about/news/?story=800880344 please see that news =) would be great if teamspeak 3 will introduce the new sha-3 encryption.
    Last edited by hunterpl; July 28th, 2013 at 03:13 AM.

  15. #15
    Join Date
    June 2002
    Location
    Netherlands
    Posts
    1,049
    That article basically said the same thing I did . There is currently no need to include sha-3. We only have a limited amount of developers, which we have to put to fixing bugs and creating awesome new features. Fixing something that is not broken, is not a good idea for any business.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [PreRelease] TeamSpeak 3 Server 3.0.11.4 Beta
    By Matthias B in forum Archive
    Replies: 3
    Last Post: August 21st, 2015, 07:54 AM
  2. Replies: 3
    Last Post: May 10th, 2015, 04:56 PM
  3. Replies: 107
    Last Post: September 25th, 2014, 07:26 AM
  4. [PreRelease] TeamSpeak 3 Server 3.0.10
    By Chris in forum Archive
    Replies: 18
    Last Post: September 28th, 2013, 07:57 PM
  5. [PreRelease] TeamSpeak 3 Server 3.0.9
    By dante696 in forum Archive
    Replies: 16
    Last Post: September 12th, 2013, 08:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •