Forum

Results 1 to 4 of 4
  1. #1
    Join Date
    July 2013
    Posts
    17

    Why isnt my plugin working on another machine?

    Hello!
    Ive finnaly finished my first plugin. It works on my machine. But I want to install it on my Server(Windows Server 2008 32bit). Ive made this Plugin with Visual C++ 2010 Express.

    I wonder because of my working MusicBot on the Server
    http://addons.teamspeak.com/director...ot-Plugin.html
    So Microsoft Visual C++ 2010 Redistributable Package should be installed.
    Could you tell me what ive to do?
    greetings

  2. #2
    Join Date
    January 2010
    Location
    Germany
    Posts
    91
    check if you are using the 64bit version of ts3. I think Visual C++ 2010 Express can only create 32bit applications/dlls.

  3. #3
    Join Date
    October 2012
    Location
    Germany
    Posts
    553
    Well, since the Target Os is 32bit that shouldn't be it.
    Maybe a specific Version has been set, e.g. There's also a msvc2010 sp1 redist.

    Note that I personally use the very same 2008 as is delivered with ts to avoid add. Dependency Installation, however that's ofc only an Option when one doesn't need anything exclusive to 2010+.

  4. #4
    Join Date
    January 2010
    Location
    Germany
    Posts
    91
    ok, didn't see that it was a 32 bit server.
    Then make sure you are creating a release-version of the dll. Debug and release use different runtime dlls and the debug-versions aren't part of the Microsoft Visual C++ 2010 Redistributable Package.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •