Forum

Results 1 to 4 of 4
  1. #1
    Join Date
    September 2013
    Posts
    2

    TeamSpeak3 and Game (PlanetSide2) mutually exclusive?

    I'm sure this isn't the case, since a lot of people can use both at ease. So why can't I?
    I'm not even sure if this is a planetside2, teamspeak, or something else entirely kind of problem.
    Frankly it took me forever to narrow down this problem. Took far longer than it should. I'm pretty sure I've done everything you can think of and yet I know I'm missing something.

    When I load Teamspeak3 first, Planetside2 becomes incapable in any way shape or form to let me HEAR any form of in-game comms, (proxy, squad, platoon, outfit). However, it is interesting that I can still speak and BE heard using those very same comms, so my Outgoing voice works. Also, when this issue crops up, I will either be incapable of starting the in-game Microphone Record/Playback test, or I will simply not hear anything from it.

    On the few times I ran Planetside2 first, TeamSpeak3 gives me crossed out Speaker symbol, indicative that I can't hear anything TeamSpeakers say (presumably, I could still speak to them, but I'd be deaf). Upon disconnecting from the TeamSpeak server, and Reconnecting, while not closing TeamSpeak3, Planetside2 decided it would go comm-deaf again in favor for TeamSpeak.

    Why are these mutually exclusive?
    It is literally one or the other.

    My firewall is disabled, and even if it weren't, I've allowed the game's ports in my firewall.
    "Run as Administrator" changes nothing for anything involved
    ProcessLasso has no effect whether present or not.
    NONE of my Playback and Microphone devices have "Allow Exclusive Control" ticked
    I use Windows7, with a 2nd monitor via HDMI.
    Changing/Separating Audio outputs does nothing.
    Deleting game files and reValidating them does nothing.

    How do I begin to solve this? What am I missing?

  2. #2
    Join Date
    August 2013
    Posts
    65
    Shouldn't you like tick both options there where it says Allow Exclusive Control ?

  3. #3
    Join Date
    April 2012
    Location
    Sweden
    Posts
    55
    have you try and run both progs as admin ? if not try that

  4. #4
    Join Date
    September 2013
    Posts
    2
    Quote Originally Posted by Xakyrie View Post
    "Run as Administrator" changes nothing for anything involved
    NONE of my Playback and Microphone devices have "Allow Exclusive Control" ticked
    I've tried multiple arrangements of 'Run as Admin', such as both, TS admin + game-nonadmin, TS nonadmin + game admin.
    When I set the game admin, I've gone into both the Launcher.exe and Planetside2.exe and set their advanced properties to "Always Run as Admin", likewise with TeamSpeak3, although to no effect.

    I'm sure this is either a bandwidth or port issue, or something like a hardware issue. Any thoughts on what this might be? how to test it? how to fix it? I've pretty much ruled out all software issues by now.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help teamspeak3 crashes my game
    By Swaager in forum Windows
    Replies: 1
    Last Post: November 8th, 2011, 11:04 AM
  2. Help teamspeak3 crashes my game
    By Swaager in forum Server Support
    Replies: 1
    Last Post: November 8th, 2011, 11:04 AM
  3. Mutually exclusive permissions - max power
    By BitterSpock in forum Permission System
    Replies: 2
    Last Post: February 9th, 2010, 03:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •