Forum

Results 1 to 5 of 5
  1. #1
    Join Date
    September 2013
    Posts
    2

    Audio bug - part of output registered as input - razer hammerhead pro

    Hey!

    I have a specific problem, that i'm 99% sure it's a bug. When using teamspeak a part of my audio output is registered as input....

    So, i got a pair of razer hammerhead pro headphones and suddenly i get an echo loop at my end? What? If i plug in back my siberia v2 it's all fine.. wth?

    Do i have my audio settings wrong?
    That is the thirst thing i checked, but no, they all fine. If I replace my headphones with siberia v2, it all works fine. I even checked all of the win 7 audio settings, it's all fine... And just to describe the echo, its not clear, i don't have a "what you can hear" channel set to input or any other kind of setting, read on, you will see...

    Then it must be a problem with my razer hammerheads?
    Yes, i would 100% agree, but there is another factor.. They work in all my other devices and programs... They work on my mobile phone, skype, PC recording programs etc etc...

    Problem only on my PC?
    No, the identical problem is in on my laptop....

    What else did i try?
    Hammerheads have a 4 pin connector with a 4pin female adapter to separate 3pin headphones and 3pin microphone 3,5mm jack. Just to fiddle around, i tried putting my hammerheads audio in and the mic from my siberia v2. It worked fine in TS.

    So there is a clear problem in the mic of my hammerheads or a software bug, BUT if it's the mic, why is it only in teamspeak? The TS settings are 100% correct, because if i hot swap a different mic it all instantly works fine...

    Any help anyone?

    Regards,
    SimKe

  2. #2
    Join Date
    June 2008
    Posts
    18,405
    moved out of bug section

    Are these headsets connected to the same soundcard with a normal jack plug/audio jack?
    Can you also talk while you have that echo?

    When the answer to these questions is YES,
    then I think this is a hardware echo (this happens when your microphone catches outgoing sound from your speaker) and has nothing to do with teamspeak.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    September 2013
    Posts
    2
    I would agree, if that was always the case. I know how to get arround "audio stuff" even outside of my computer and have already thought of that and tested in other applications / devices. My skype calls, mobile phone calls function normaly. I can record myself in any audio software and the recording is good... The issue is exacly the same on my laptop with different hardware. All things considered it seems to be an issue only in teamspeak...

    EDIT: I'll post an audiofile shortly...

  4. #4
    Join Date
    August 2013
    Posts
    65
    Check your private messages

  5. #5
    Join Date
    April 2015
    Posts
    1
    Im with the same problem, how can i solve ? HELP

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: December 26th, 2013, 04:42 PM
  2. Replies: 4
    Last Post: July 7th, 2011, 06:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •