Forum

Results 1 to 4 of 4
  1. #1
    Join Date
    September 2013
    Posts
    2

    Angry "Failed to connect to server"

    I have been googling around and I've been trying to fix this all day with no result, it worked perfectly yesterday and earlier today but now whenever I try to connect to a server i just get "failed to connect to server"

  2. #2
    Join Date
    August 2013
    Location
    Germany
    Posts
    530
    Please make sure you have read and followed these steps: http://forum.teamspeak.com/showthrea...-amp-Solutions

    If this does not solve your problem you will need to provide more information.

  3. #3
    Join Date
    September 2013
    Posts
    2
    Quote Originally Posted by Matthias B View Post
    Please make sure you have read and followed these steps: http://forum.teamspeak.com/showthrea...-amp-Solutions

    If this does not solve your problem you will need to provide more information.
    make sure you didn't misspell the address and that you do not have any typos in the address.
    Ping the address
    Ask a few friends to try and connect to the server from their end (these friends should preferably have different ISPs to rule out ISP failure), if it doesn't work for them either it's increasingly likely it's a server problem after all and in that case nobody but the server owner can do anything about it.
    Try to connect using a mobile client using the mobile network (not Wireless LAN), it it doesn't work again it's more likely a server problem (at least if your mobile connection is stable and better than edge). I have already done all of this.


    Check your firewall and make sure it doesn't block TeamSpeak at all. - My Firewall is Off.
    Check your security software to make sure it doesn't block any ports or protocols (some like to block UDP traffic which is essential for TeamSpeak) - I have no security software, I used to have but its already removed.
    Check your router and search for any firewall, SPI Firewall, DDoS Protection, Flood Protection or similar and disable those option - Im kind of a noob at computers, how do you do this?
    Occasionally it helped to disable "UDP Checksum Offload" for the network card. On Windows this can be found in the device manager, properties of the network adapter under the advanced tab. - Same here, how do?



    Some more information: I have enabled ports 9986/9987/9988/10011/30033 | I can sometimes connect, but thats very rarely.


    dxdiag: http://pastebin.com/CQzLJQ1T

  4. #4
    Join Date
    September 2013
    Posts
    5
    Hi Crexon,
    this is a long shot but do you have any Killer drivers installed on your PC?
    I have a Killer Nic card and after uninstalling all related drivers I have managed to get back on TS. I had the Firewall turned off in the Killer software and all other FW's turned off but it still wouldnt log on to a server...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] "Failed to connect to server" - Troubleshooting & Solutions
    By Chris in forum Client Support
    Replies: 211
    Last Post: October 8th, 2019, 06:36 PM
  2. Replies: 0
    Last Post: March 26th, 2015, 09:06 PM
  3. Replies: 0
    Last Post: February 28th, 2015, 03:00 PM
  4. Replies: 0
    Last Post: January 1st, 2014, 10:28 PM
  5. Replies: 1
    Last Post: January 17th, 2013, 09:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •