Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 5 of 5
  1. #1
    Join Date
    May 2013
    Posts
    3

    Solved 64 bit Linux client uses 20% of one CPU core when idle

    I am running TeamSpeak 3.0.12 64 bit Linux client and have a constant CPU utilization of 20% of one core when the client is idle (nobody talking on the server). My CPU is a AthlonII x4 631. I am running on Debian sid with kernel 3.11 and using ALSA. When I disabled echo reduction and echo cancellation the CPU utilization went down to only 8% of one core. It seem that the client may be executing some audio processing functions when there is no audio currently being played or recorded.

  2. #2
    Join Date
    June 2008
    Posts
    18,513
    This is a known behavior and no bug in our opinion. The Echo cancelation does need more CPU
    http://forum.teamspeak.com/showthrea...of-information
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    September 2013
    Posts
    2
    Quote Originally Posted by tux9656 View Post
    I am running TeamSpeak 3.0.12 64 bit Linux client and have a constant CPU utilization of 20% of one core when the client is idle (nobody talking on the server). My CPU is a AthlonII x4 631. I am running on Debian sid with kernel 3.11 and using ALSA. When I disabled echo reduction and echo cancellation the CPU utilization went down to only 8% of one core. It seem that the client may be executing some audio processing functions when there is no audio currently being played or recorded.
    I have the same problem, and Echo cancellation and reduction are both disabled!

    Please fix this.

  4. #4
    Join Date
    January 2009
    Location
    Germany
    Posts
    31
    Hi,

    i have the same problem! TS3 Client uses way too much CPU Power in idle state. All enhancements have
    been disabled. I even tried to set Playback and Recording to nil Devices.
    The Client uses between 20% and 30% by doing nothing

  5. #5
    Join Date
    March 2014
    Posts
    6
    Hi,

    This is certainly a bug. TS3 client on linux uses 15% of my 8-core 4GHz CPU, when idle.

    Name:  Ts3_cpu_usage.jpg
Views: 512
Size:  449.4 KB

    You can see the problem from this screenshot (all echo reductions and cancellations are disabled, anyway they does not work as it should). And stop saying that this is not a bug, but fix this!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •