I am running TeamSpeak 3.0.12 64 bit Linux client on Ubuntu 13.04.

I cannot get rid of the Echo when testing the mic in Options. Also my in-game sound is producing echo.

I am using a headset, and I have no problems with echo in ex: skype

Hope there is a solution for this.