Forum

Results 1 to 6 of 6
  1. #1
    Join Date
    September 2013
    Posts
    1

    Can't fix common problem | Failure during pthread_create, error = EAGAIN

    Hello,

    I have a 2gb dedicated box, in which I only run a TS3 512 slot (NPL license) server.
    It was running fine, with an impeccable 2months of uptime (not a single crash).
    The user numbers in the server, hasn't changed much, from 70 to 90 only since day 1, and when crashed sometimes it barely had any users.

    And 7 days ago it started happening: Failure during pthread_create, error = EAGAIN

    If I just start the TS3 again, it crashes again in 30-40 mins.
    If i reboot my box, it lasts for around 1 day and half, to crash again.

    I have checked all the related topics on this forum regarding this issue, and not a single one fixed my problem.
    Here is my ulimit -a on the account running the TS3.

    core file size (blocks, -c) 0
    data seg size (kbytes, -d) unlimited
    scheduling priority (-e) 0
    file size (blocks, -f) unlimited
    pending signals (-i) 31431
    max locked memory (kbytes, -l) 64
    max memory size (kbytes, -m) unlimited
    open files (-n) 1024
    pipe size (512 bytes, -p) 8
    POSIX message queues (bytes, -q) 819200
    real-time priority (-r) 0
    stack size (kbytes, -s) 8192
    cpu time (seconds, -t) unlimited
    max user processes (-u) 31431
    virtual memory (kbytes, -v) unlimited
    file locks (-x) unlimited

    This box is running the latest CentOS version, x64.

    Please, please help me!

  2. #2
    Join Date
    October 2012
    Posts
    37
    I just got my server running after like 72 hours strait messing with it. I then logged on with one the admin programs and now I am getting this same error as you. I been searching but this seems to be the only thread with this issue.

  3. #3
    Join Date
    April 2011
    Location
    Germany
    Posts
    1,266
    Check "ulimit -a" ... take special notice at "open files", "stack size" and "max user processes".
    You might want to share those values with us. I'd recommend at least 1024, 10240 and 2048.

  4. #4
    Join Date
    October 2012
    Posts
    37
    [email protected] [~/teamspeak3-server_linux-x86]# ulimit -a
    core file size (blocks, -c) 200000
    data seg size (kbytes, -d) 200000
    scheduling priority (-e) 0
    file size (blocks, -f) unlimited
    pending signals (-i) 385233
    max locked memory (kbytes, -l) 64
    max memory size (kbytes, -m) 200000
    open files (-n) 100
    pipe size (512 bytes, -p) 8
    POSIX message queues (bytes, -q) 819200
    real-time priority (-r) 0
    stack size (kbytes, -s) 8192
    cpu time (seconds, -t) unlimited
    max user processes (-u) 35
    virtual memory (kbytes, -v) unlimited
    file locks (-x) unlimited
    [email protected] [~/teamspeak3-server_linux-x86]#

  5. #5
    Join Date
    October 2012
    Posts
    37
    Okay I changed those values but now I am getting this: "I turned off csf, as far as my knowledge goes there is nothing stopping those ports.
    2013-11-18 14:56:44.803191|ERROR |FileManager | | bind() failed: 98
    2013-11-18 14:56:44.804799|ERROR |FileManager | | bind failed on 0.0.0.0:30033
    2013-11-18 14:56:44.920893|ERROR |VirtualServer | 7| bind failed on 0.0.0.0:9999
    2013-11-18 14:56:44.921125|ERROR |VirtualSvrMgr | | loading VirtualServer(7) failed to start, error: unable to bind network port
    2013-11-18 14:56:45.074092|INFO |VirtualServer | 7| stopped
    2013-11-18 14:56:45.078969|INFO |CIDRManager | | updated query_ip_whitelist ips: 127.0.0.1,
    2013-11-18 14:56:45.127007|ERROR |Query | | bind failed on 0.0.0.0:10011

  6. #6
    Join Date
    October 2012
    Posts
    37
    Okay I got it going. Thank you so much for your help. There are no words to even describe how much I appreciate your help.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 35
    Last Post: April 4th, 2016, 02:27 AM
  2. pthread_create, error = EAGAIN [Crash]
    By heberpcl in forum Linux / FreeBSD
    Replies: 0
    Last Post: May 3rd, 2012, 08:29 PM
  3. [Resolved] Failure during pthread_create 12
    By Zion96 in forum Linux / FreeBSD
    Replies: 8
    Last Post: May 15th, 2011, 11:15 AM
  4. Beta 16 Error "pthread_create, error = EAGAIN"
    By KoldFusion in forum Linux / FreeBSD
    Replies: 12
    Last Post: February 7th, 2010, 01:43 PM
  5. Failure during pthread_create
    By sturmf4lke in forum Linux / FreeBSD
    Replies: 1
    Last Post: December 22nd, 2009, 06:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •