Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 3 of 3
  1. #1
    Join Date
    September 2013

    Solved Problem with using a joystik-button for push-to-talk, after latest update.

    Dear teamspeak Team,

    first I want to thank you for your program. Until the latest update, the software was working as I needed. Since the latest version there is a problem with using a joystick button as Push-To-Talk button. The input dialog does not close after the joystick button was pressed (for example button 5). When I press the [ESC] key to exit the dialogue, the hotkey is defined as [joystick button 5 + ESC]. The next problem is that each joystick button is accepted exactly once. The 'consumed' joystick key is redetected only after a restart of the TeamSpeak client. In older versions there was a human-readable configuration file. As it stands, these were replaced by a SQLite3 database. Is there a way to enter the Push-To-Talk button directly in the configuration file?

    I use TS3 in Windows XP. The Joystick is a saitek X52 Pro.

    My workaround for described situation is as followed. I use the share-ware 'joytokey' for simulating keybord inputs from Joystick. But I hope it will be soon possible again to use the joystick without an additional program.



    After a restart of the operating system and switching input method on Direct Input, everything works fine. This post can be deleted.

    Please Excuse the inconvenience,
    Last edited by linuxdoesitbetter; September 30th, 2013 at 07:27 PM.

  2. #2
    Join Date
    June 2008
    Can you try client 3.0.13 (this client was released today).

    Saitek devices always made problems with hotkeys, but we own an saitek X52 Pro and can not reproduce any problem.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    September 2013
    Hello dante696,

    as I wrote in the addendum, the problem is solved. The main problem was sitting (as so often) in front of the monitor. My initial mistake was that I had not saved the settings after switching the input method.

    As a developer, I am sometimes amazed, how creative some users are using my programs. Even if I think my program now is monkey safe, some users prove the contrary. No wonder you couldn't reproduce my problem.

    This thread can be deleted. Please forgive me wasting your time.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Can't set a push to talk button
    By Alivia in forum Windows
    Replies: 3
    Last Post: January 2nd, 2012, 03:43 PM
  2. Push to talk button
    By Filip5 in forum Skins / Icon & Sound Packs
    Replies: 1
    Last Post: April 23rd, 2011, 04:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts