Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Page 3 of 3 FirstFirst 123
Results 31 to 37 of 37
  1. #31
    Join Date
    December 2013
    I had the same problem. Used num lock for my push to talk, then it stopped working. Tried changing binds but nothing would work.

    Downgraded to 3.0.12 and everything works as usual. Clearly something was goof'd in 3.0.13 and/or

  2. #32
    Join Date
    June 2008
    We still wait for a reply from my post
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #33
    Join Date
    January 2014
    Still the same problem seems to haunt a large number of teamspeak users.

    To pin it down check this:
    1. Launch teamspeak. Hotkeys work.
    2. Join server. No keyboard-based hotkeys such as muting work. Mouse and joystick hotkeys act normal.
    3. Settings-options-capture, testing hotkeys works, actually. Still no joy at server after stopping the test.
    4. Now it gets interesting:
    Settings-options-hotkeys-<lower right corner>-keyboard&mouse only. Apply.
    Repeat for Default. Apply.
    5. All keys work as normal. All you need to do is to retouch that option every time after joining/rejoining a server.

    This appears after updating the client to 3.0.13. Older versions do not have this bug. I guess there is an initialization routine with a typo somewhere that is not found for weeks and weeks. Further testing for $50 per hour.

  4. #34
    Join Date
    January 2005
    Orlando, FL, USA
    Sorry for the delay.

    Do you use a Laptop or a Computer?

    What USB devices are connected?
    Logitech G15, Logitech G9X, TrackIR (all same as before the problem started)

    Do you use the Windows USB driver or did you install something from a manufactor like INTEL USB 3.0 Driver.
    All Windows Certified drives

    Can you Test and confirm something for us? We'd like to see if that happens with older clients.
    Previous versions work as expected.

  5. #35
    Join Date
    February 2014
    Name:  K0AJJA7.png
Views: 1128
Size:  8.5 KBI am having the same exact problem as OP, occuring under the same conditions as described by someanon two posts up.

    Win 7 64 tower-style (non-laptop)
    USB: TrackIR, apple keyboard w/ numpad, logitech trackball, smart card reader
    Last edited by some_nobody; February 26th, 2014 at 12:25 AM. Reason: edited to correct info

  6. #36
    Join Date
    March 2014
    Made an account to contribute to this thread.

    "@ Everybody
    Do you use a Laptop or a Computer?
    What USB devices are connected?
    Do you use the Windows USB driver or did you install something from a manufactor like INTEL USB 3.0 Driver."

    I have a computer, Windows 7x64 Ultimate SP1, latest updates installed (3/1/14)
    TS3 v3.0.13.1 (QT v4.8.3)

    USB Devices:
    Logitech Unifying receiver (M705 mouse, K750 keyboard paired) (latest firmware)
    Logitech G600 Gaming Mouse (latest firmware)
    Plantronics Bt300 wireless bluetooth adapter (Voyager Legend paired) (latest firmware)
    MiniView KVMP switch (USB hub between computers)

    I use the windows default drivers for USB controller and even the logitech Unifying receiver is using default drivers (shows as USB receiver not Unifying receiver in device manager, which is logitech's recommended use with Windows 7)

    Another note: I can recover hotkeys by the same methods described above and by unplugging my wireless receiver and plugging it back in. no idea if that will give you another hint to find resolution.

  7. #37
    Join Date
    January 2005
    Orlando, FL, USA
    There is clearly a problem with TeamSpeak not binding to the USB controller or something like that. Clearly the application is receiving keyboard input (eg. the Alt works to navigate the menu, etc.) but the binding for the hotkeys at the USB level is getting lost upon startup somehow.

    You can manually correct the problem by making TeamSpeak rescan and bind correctly -- achieved by toggling the Input (Direct vs. Keyboard Mouse) as I've mentioned way above.

    I sure hope they find a resolution to this problem as it is very annoying and pervasive across many users.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: August 10th, 2014, 06:12 PM
  2. [outdated thread][Push to talk: No hotkey assigned
    By greedywhore in forum Windows
    Replies: 43
    Last Post: October 1st, 2013, 08:16 AM
  3. Push to talk assigned...
    By dcstryker in forum Permission System
    Replies: 1
    Last Post: December 18th, 2011, 05:08 PM
  4. [outdated thread][Push to talk: No hotkey assigned
    By greedywhore in forum Bug Reports [EN/DE]
    Replies: 2
    Last Post: October 5th, 2010, 06:25 PM
  5. Push to talk problem
    By Ballzy in forum General Questions
    Replies: 25
    Last Post: August 16th, 2010, 05:24 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts